diff mbox series

[1/7] package/python-pluggy: enable host package build

Message ID 20221019215348.3262192-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/7] package/python-pluggy: enable host package build | expand

Commit Message

James Hilliard Oct. 19, 2022, 9:53 p.m. UTC
This will be needed for the upcoming host-python-hatchling.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-pluggy/python-pluggy.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Yann E. MORIN Oct. 30, 2022, 8:27 p.m. UTC | #1
James, All,

On 2022-10-19 15:53 -0600, James Hilliard spake thusly:
> This will be needed for the upcoming host-python-hatchling.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Whole series applied to master, thanks.

I really wonder how many pep517 buildsystems there will be, and how many
packages we'll have to introduce... Fantastic...

Regards,
Yann E. MORIN.

> ---
>  package/python-pluggy/python-pluggy.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/python-pluggy/python-pluggy.mk b/package/python-pluggy/python-pluggy.mk
> index 59382518ed..6dc6f970ea 100644
> --- a/package/python-pluggy/python-pluggy.mk
> +++ b/package/python-pluggy/python-pluggy.mk
> @@ -11,5 +11,7 @@ PYTHON_PLUGGY_SETUP_TYPE = setuptools
>  PYTHON_PLUGGY_LICENSE = MIT
>  PYTHON_PLUGGY_LICENSE_FILES = LICENSE
>  PYTHON_PLUGGY_DEPENDENCIES = host-python-setuptools-scm
> +HOST_PYTHON_PLUGGY_DEPENDENCIES = host-python-setuptools-scm
>  
>  $(eval $(python-package))
> +$(eval $(host-python-package))
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
James Hilliard Oct. 31, 2022, 6:08 p.m. UTC | #2
On Sun, Oct 30, 2022 at 4:27 PM Yann E. MORIN <yann.morin.1998@free.fr> wrote:
>
> James, All,
>
> On 2022-10-19 15:53 -0600, James Hilliard spake thusly:
> > This will be needed for the upcoming host-python-hatchling.
> >
> > Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
>
> Whole series applied to master, thanks.
>
> I really wonder how many pep517 buildsystems there will be, and how many
> packages we'll have to introduce... Fantastic...

Considering pep517 seems to have been designed to make it easy for everyone
to write their own pep517 build backends...could be quite a few...yeah...

>
> Regards,
> Yann E. MORIN.
>
> > ---
> >  package/python-pluggy/python-pluggy.mk | 2 ++
> >  1 file changed, 2 insertions(+)
> >
> > diff --git a/package/python-pluggy/python-pluggy.mk b/package/python-pluggy/python-pluggy.mk
> > index 59382518ed..6dc6f970ea 100644
> > --- a/package/python-pluggy/python-pluggy.mk
> > +++ b/package/python-pluggy/python-pluggy.mk
> > @@ -11,5 +11,7 @@ PYTHON_PLUGGY_SETUP_TYPE = setuptools
> >  PYTHON_PLUGGY_LICENSE = MIT
> >  PYTHON_PLUGGY_LICENSE_FILES = LICENSE
> >  PYTHON_PLUGGY_DEPENDENCIES = host-python-setuptools-scm
> > +HOST_PYTHON_PLUGGY_DEPENDENCIES = host-python-setuptools-scm
> >
> >  $(eval $(python-package))
> > +$(eval $(host-python-package))
> > --
> > 2.34.1
> >
> > _______________________________________________
> > buildroot mailing list
> > buildroot@buildroot.org
> > https://lists.buildroot.org/mailman/listinfo/buildroot
>
> --
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> '------------------------------^-------^------------------^--------------------'
diff mbox series

Patch

diff --git a/package/python-pluggy/python-pluggy.mk b/package/python-pluggy/python-pluggy.mk
index 59382518ed..6dc6f970ea 100644
--- a/package/python-pluggy/python-pluggy.mk
+++ b/package/python-pluggy/python-pluggy.mk
@@ -11,5 +11,7 @@  PYTHON_PLUGGY_SETUP_TYPE = setuptools
 PYTHON_PLUGGY_LICENSE = MIT
 PYTHON_PLUGGY_LICENSE_FILES = LICENSE
 PYTHON_PLUGGY_DEPENDENCIES = host-python-setuptools-scm
+HOST_PYTHON_PLUGGY_DEPENDENCIES = host-python-setuptools-scm
 
 $(eval $(python-package))
+$(eval $(host-python-package))