diff mbox series

[8/9] package/zlib-ng: Revert Power8 special casing

Message ID 20220729000904.1295295-9-joel@jms.id.au
State Changes Requested
Headers show
Series powerpc: Fix ppc64le configurations | expand

Commit Message

Joel Stanley July 29, 2022, 12:09 a.m. UTC
With "arch/powerpc: Enable powerpc64le only on CPUs that support it"
buildroot will no longer build a toolchain that breaks feature
detection.

Remove the special casing so the build system can do feature detection.

Signed-off-by: Joel Stanley <joel@jms.id.au>
---
 package/zlib-ng/zlib-ng.mk | 6 ------
 1 file changed, 6 deletions(-)

Comments

Cédric Le Goater July 29, 2022, 6:55 a.m. UTC | #1
On 7/29/22 02:09, Joel Stanley wrote:
> With "arch/powerpc: Enable powerpc64le only on CPUs that support it"
> buildroot will no longer build a toolchain that breaks feature
> detection.
> 
> Remove the special casing so the build system can do feature detection.
> 
> Signed-off-by: Joel Stanley <joel@jms.id.au>



Reviewed-by: Cédric Le Goater <clg@kaod.org>

Thanks,

C.
> ---
>   package/zlib-ng/zlib-ng.mk | 6 ------
>   1 file changed, 6 deletions(-)
> 
> diff --git a/package/zlib-ng/zlib-ng.mk b/package/zlib-ng/zlib-ng.mk
> index 938acd4181a6..fb497b8c11d0 100644
> --- a/package/zlib-ng/zlib-ng.mk
> +++ b/package/zlib-ng/zlib-ng.mk
> @@ -23,10 +23,4 @@ ifeq ($(BR2_arm),y)
>   ZLIB_NG_CONF_OPTS += -DWITH_ACLE=1 -DWITH_NEON=1
>   endif
>   
> -ifeq ($(BR2_powerpc_power8),y)
> -ZLIB_NG_CONF_OPTS += -DWITH_POWER8=ON
> -else
> -ZLIB_NG_CONF_OPTS += -DWITH_POWER8=OFF
> -endif
> -
>   $(eval $(cmake-package))
diff mbox series

Patch

diff --git a/package/zlib-ng/zlib-ng.mk b/package/zlib-ng/zlib-ng.mk
index 938acd4181a6..fb497b8c11d0 100644
--- a/package/zlib-ng/zlib-ng.mk
+++ b/package/zlib-ng/zlib-ng.mk
@@ -23,10 +23,4 @@  ifeq ($(BR2_arm),y)
 ZLIB_NG_CONF_OPTS += -DWITH_ACLE=1 -DWITH_NEON=1
 endif
 
-ifeq ($(BR2_powerpc_power8),y)
-ZLIB_NG_CONF_OPTS += -DWITH_POWER8=ON
-else
-ZLIB_NG_CONF_OPTS += -DWITH_POWER8=OFF
-endif
-
 $(eval $(cmake-package))