diff mbox series

[2/2] package/nodejs: use ninja for build

Message ID 20220512121217.176652-2-arnout@mind.be
State Accepted
Headers show
Series [1/2] package/nodejs: clean up DEPENDENCIES | expand

Commit Message

Arnout Vandecappelle May 12, 2022, 12:12 p.m. UTC
Not only is ninja much faster, it also avoids the following build
failure:
make[3]: printf: Argument list too long

This failure happens when the output directory is about 6 levels deep.
It's due to the make generator of gyp that uses some crazy shell
processing for splitting up paths on /. The ninja generator does no such
thing.

While we're at it, remove redundant parenthesis in
HOST_NODEJS_CONFIGURE_CMDS.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/nodejs/nodejs.mk | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

Comments

Yann E. MORIN May 12, 2022, 8:18 p.m. UTC | #1
Arnout, All,

On 2022-05-12 14:12 +0200, Arnout Vandecappelle (Essensium/Mind) spake thusly:
> Not only is ninja much faster, it also avoids the following build
> failure:
> make[3]: printf: Argument list too long
> 
> This failure happens when the output directory is about 6 levels deep.
> It's due to the make generator of gyp that uses some crazy shell
> processing for splitting up paths on /. The ninja generator does no such
> thing.
> 
> While we're at it, remove redundant parenthesis in
> HOST_NODEJS_CONFIGURE_CMDS.

Thank you! \o/

> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/nodejs/nodejs.mk | 9 ++++++---
>  1 file changed, 6 insertions(+), 3 deletions(-)
> 
> diff --git a/package/nodejs/nodejs.mk b/package/nodejs/nodejs.mk
> index 909347eb2e..70febca74f 100644
> --- a/package/nodejs/nodejs.mk
> +++ b/package/nodejs/nodejs.mk
> @@ -10,6 +10,7 @@ NODEJS_SITE = http://nodejs.org/dist/v$(NODEJS_VERSION)
>  NODEJS_DEPENDENCIES = \
>  	c-ares \
>  	host-nodejs \
> +	host-ninja \
>  	host-pkgconf \
>  	host-python3 \
>  	host-qemu \
> @@ -20,6 +21,7 @@ NODEJS_DEPENDENCIES = \
>  HOST_NODEJS_DEPENDENCIES = \
>  	host-icu \
>  	host-libopenssl \
> +	host-ninja \
>  	host-pkgconf \
>  	host-python3 \
>  	host-zlib
> @@ -37,7 +39,8 @@ NODEJS_CONF_OPTS = \
>  	--without-dtrace \
>  	--without-etw \
>  	--cross-compiling \
> -	--dest-os=linux
> +	--dest-os=linux \
> +	--ninja
>  
>  HOST_NODEJS_MAKE_OPTS = \
>  	$(HOST_CONFIGURE_OPTS) \
> @@ -82,7 +85,7 @@ NODEJS_CONF_OPTS += --without-npm
>  endif
>  
>  define HOST_NODEJS_CONFIGURE_CMDS
> -	(cd $(@D); \
> +	cd $(@D); \
>  		$(HOST_CONFIGURE_OPTS) \
>  		PATH=$(@D)/bin:$(BR_PATH) \
>  		PYTHON=$(HOST_DIR)/bin/python3 \
> @@ -96,7 +99,7 @@ define HOST_NODEJS_CONFIGURE_CMDS
>  		--shared-zlib \
>  		--no-cross-compiling \
>  		--with-intl=system-icu \
> -	)
> +		--ninja
>  endef
>  
>  NODEJS_HOST_TOOLS_V8 = \
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/nodejs/nodejs.mk b/package/nodejs/nodejs.mk
index 909347eb2e..70febca74f 100644
--- a/package/nodejs/nodejs.mk
+++ b/package/nodejs/nodejs.mk
@@ -10,6 +10,7 @@  NODEJS_SITE = http://nodejs.org/dist/v$(NODEJS_VERSION)
 NODEJS_DEPENDENCIES = \
 	c-ares \
 	host-nodejs \
+	host-ninja \
 	host-pkgconf \
 	host-python3 \
 	host-qemu \
@@ -20,6 +21,7 @@  NODEJS_DEPENDENCIES = \
 HOST_NODEJS_DEPENDENCIES = \
 	host-icu \
 	host-libopenssl \
+	host-ninja \
 	host-pkgconf \
 	host-python3 \
 	host-zlib
@@ -37,7 +39,8 @@  NODEJS_CONF_OPTS = \
 	--without-dtrace \
 	--without-etw \
 	--cross-compiling \
-	--dest-os=linux
+	--dest-os=linux \
+	--ninja
 
 HOST_NODEJS_MAKE_OPTS = \
 	$(HOST_CONFIGURE_OPTS) \
@@ -82,7 +85,7 @@  NODEJS_CONF_OPTS += --without-npm
 endif
 
 define HOST_NODEJS_CONFIGURE_CMDS
-	(cd $(@D); \
+	cd $(@D); \
 		$(HOST_CONFIGURE_OPTS) \
 		PATH=$(@D)/bin:$(BR_PATH) \
 		PYTHON=$(HOST_DIR)/bin/python3 \
@@ -96,7 +99,7 @@  define HOST_NODEJS_CONFIGURE_CMDS
 		--shared-zlib \
 		--no-cross-compiling \
 		--with-intl=system-icu \
-	)
+		--ninja
 endef
 
 NODEJS_HOST_TOOLS_V8 = \