diff mbox series

[1/2] package/nodejs: clean up DEPENDENCIES

Message ID 20220512121217.176652-1-arnout@mind.be
State Accepted
Headers show
Series [1/2] package/nodejs: clean up DEPENDENCIES | expand

Commit Message

Arnout Vandecappelle May 12, 2022, 12:12 p.m. UTC
One per line, and alphabetical (was already the case for host).

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/nodejs/nodejs.mk | 17 ++++++++++++++---
 1 file changed, 14 insertions(+), 3 deletions(-)

Comments

Yann E. MORIN May 12, 2022, 8:18 p.m. UTC | #1
Arnout, All,

On 2022-05-12 14:12 +0200, Arnout Vandecappelle (Essensium/Mind) spake thusly:
> One per line, and alphabetical (was already the case for host).
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
>  package/nodejs/nodejs.mk | 17 ++++++++++++++---
>  1 file changed, 14 insertions(+), 3 deletions(-)
> 
> diff --git a/package/nodejs/nodejs.mk b/package/nodejs/nodejs.mk
> index 6dcaf34aa4..909347eb2e 100644
> --- a/package/nodejs/nodejs.mk
> +++ b/package/nodejs/nodejs.mk
> @@ -7,10 +7,21 @@
>  NODEJS_VERSION = 16.15.0
>  NODEJS_SOURCE = node-v$(NODEJS_VERSION).tar.xz
>  NODEJS_SITE = http://nodejs.org/dist/v$(NODEJS_VERSION)
> -NODEJS_DEPENDENCIES = host-qemu host-pkgconf host-python3 host-nodejs c-ares \
> -	libuv zlib nghttp2 \
> +NODEJS_DEPENDENCIES = \
> +	c-ares \
> +	host-nodejs \
> +	host-pkgconf \
> +	host-python3 \
> +	host-qemu \

I prefer when all host dependencies go first, then all target
dependencies, so I've also lightly re-oredered.

Applied to master, thanks.

Regards,
Yann E. MORIN.

> +	libuv \
> +	nghttp2 \
> +	zlib \
>  	$(call qstrip,$(BR2_PACKAGE_NODEJS_MODULES_ADDITIONAL_DEPS))
> -HOST_NODEJS_DEPENDENCIES = host-icu host-libopenssl host-pkgconf host-python3 \
> +HOST_NODEJS_DEPENDENCIES = \
> +	host-icu \
> +	host-libopenssl \
> +	host-pkgconf \
> +	host-python3 \
>  	host-zlib
>  NODEJS_INSTALL_STAGING = YES
>  NODEJS_LICENSE = MIT (core code); MIT, Apache and BSD family licenses (Bundled components)
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Arnout Vandecappelle May 12, 2022, 10:34 p.m. UTC | #2
On 12/05/2022 22:18, Yann E. MORIN wrote:
> Arnout, All,
> 
> On 2022-05-12 14:12 +0200, Arnout Vandecappelle (Essensium/Mind) spake thusly:
>> One per line, and alphabetical (was already the case for host).
>>
>> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
>> ---
>>   package/nodejs/nodejs.mk | 17 ++++++++++++++---
>>   1 file changed, 14 insertions(+), 3 deletions(-)
>>
>> diff --git a/package/nodejs/nodejs.mk b/package/nodejs/nodejs.mk
>> index 6dcaf34aa4..909347eb2e 100644
>> --- a/package/nodejs/nodejs.mk
>> +++ b/package/nodejs/nodejs.mk
>> @@ -7,10 +7,21 @@
>>   NODEJS_VERSION = 16.15.0
>>   NODEJS_SOURCE = node-v$(NODEJS_VERSION).tar.xz
>>   NODEJS_SITE = http://nodejs.org/dist/v$(NODEJS_VERSION)
>> -NODEJS_DEPENDENCIES = host-qemu host-pkgconf host-python3 host-nodejs c-ares \
>> -	libuv zlib nghttp2 \
>> +NODEJS_DEPENDENCIES = \
>> +	c-ares \
>> +	host-nodejs \
>> +	host-pkgconf \
>> +	host-python3 \
>> +	host-qemu \
> 
> I prefer when all host dependencies go first, then all target
> dependencies, so I've also lightly re-oredered.

  I actually prefer that as well. So good call!

  Regards,
  Arnout

> 
> Applied to master, thanks.
> 
> Regards,
> Yann E. MORIN.
> 
>> +	libuv \
>> +	nghttp2 \
>> +	zlib \
>>   	$(call qstrip,$(BR2_PACKAGE_NODEJS_MODULES_ADDITIONAL_DEPS))
>> -HOST_NODEJS_DEPENDENCIES = host-icu host-libopenssl host-pkgconf host-python3 \
>> +HOST_NODEJS_DEPENDENCIES = \
>> +	host-icu \
>> +	host-libopenssl \
>> +	host-pkgconf \
>> +	host-python3 \
>>   	host-zlib
>>   NODEJS_INSTALL_STAGING = YES
>>   NODEJS_LICENSE = MIT (core code); MIT, Apache and BSD family licenses (Bundled components)
>> -- 
>> 2.35.1
>>
>> _______________________________________________
>> buildroot mailing list
>> buildroot@buildroot.org
>> https://lists.buildroot.org/mailman/listinfo/buildroot
>
Peter Korsgaard May 28, 2022, 10:46 a.m. UTC | #3
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 > One per line, and alphabetical (was already the case for host).
 > Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/nodejs/nodejs.mk b/package/nodejs/nodejs.mk
index 6dcaf34aa4..909347eb2e 100644
--- a/package/nodejs/nodejs.mk
+++ b/package/nodejs/nodejs.mk
@@ -7,10 +7,21 @@ 
 NODEJS_VERSION = 16.15.0
 NODEJS_SOURCE = node-v$(NODEJS_VERSION).tar.xz
 NODEJS_SITE = http://nodejs.org/dist/v$(NODEJS_VERSION)
-NODEJS_DEPENDENCIES = host-qemu host-pkgconf host-python3 host-nodejs c-ares \
-	libuv zlib nghttp2 \
+NODEJS_DEPENDENCIES = \
+	c-ares \
+	host-nodejs \
+	host-pkgconf \
+	host-python3 \
+	host-qemu \
+	libuv \
+	nghttp2 \
+	zlib \
 	$(call qstrip,$(BR2_PACKAGE_NODEJS_MODULES_ADDITIONAL_DEPS))
-HOST_NODEJS_DEPENDENCIES = host-icu host-libopenssl host-pkgconf host-python3 \
+HOST_NODEJS_DEPENDENCIES = \
+	host-icu \
+	host-libopenssl \
+	host-pkgconf \
+	host-python3 \
 	host-zlib
 NODEJS_INSTALL_STAGING = YES
 NODEJS_LICENSE = MIT (core code); MIT, Apache and BSD family licenses (Bundled components)