diff mbox series

[v2,2/3] package/glmark2: drm-glesv2 needs libgbm

Message ID 20211113093009.6915-2-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [v2,1/3] package/glmark2: drm-glesv2 needs libdrm | expand

Commit Message

Bernd Kuhls Nov. 13, 2021, 9:30 a.m. UTC
Fixes build error with defconfig from:
http://autobuild.buildroot.net/results/e393dbfba7c2989fe983df47ea0638c3ba62ae7a/

  Checking for 'libdrm': yes
  Checking for 'gbm'   : not found

after http://patchwork.ozlabs.org/project/buildroot/patch/20200104193919.91589-1-bernd.kuhls@t-online.de/
was applied. Both patches are needed to fix the build error.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
v2: no changes

 package/glmark2/Config.in  | 1 +
 package/glmark2/glmark2.mk | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN Nov. 13, 2021, 9:53 a.m. UTC | #1
Bernd, All,

On 2021-11-13 10:30 +0100, Bernd Kuhls spake thusly:
> Fixes build error with defconfig from:
> http://autobuild.buildroot.net/results/e393dbfba7c2989fe983df47ea0638c3ba62ae7a/
> 
>   Checking for 'libdrm': yes
>   Checking for 'gbm'   : not found
> 
> after http://patchwork.ozlabs.org/project/buildroot/patch/20200104193919.91589-1-bernd.kuhls@t-online.de/
> was applied. Both patches are needed to fix the build error.
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> v2: no changes
> 
>  package/glmark2/Config.in  | 1 +
>  package/glmark2/glmark2.mk | 2 +-
>  2 files changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/glmark2/Config.in b/package/glmark2/Config.in
> index 3ef3a0e8e3..6761397d3f 100644
> --- a/package/glmark2/Config.in
> +++ b/package/glmark2/Config.in
> @@ -5,6 +5,7 @@ config BR2_PACKAGE_GLMARK2_FLAVOR_DRM_GLESV2
>  	bool
>  	default y
>  	depends on BR2_PACKAGE_HAS_LIBEGL
> +	depends on BR2_PACKAGE_HAS_LIBGBM
>  	depends on BR2_PACKAGE_HAS_LIBGLES
>  	depends on BR2_PACKAGE_HAS_UDEV
>  	# libpthread-stubs -> libdrm
> diff --git a/package/glmark2/glmark2.mk b/package/glmark2/glmark2.mk
> index 5ad3ea2cb4..e8d6f71dad 100644
> --- a/package/glmark2/glmark2.mk
> +++ b/package/glmark2/glmark2.mk
> @@ -11,7 +11,7 @@ GLMARK2_LICENSE_FILES = COPYING COPYING.SGI
>  GLMARK2_DEPENDENCIES = host-pkgconf jpeg libegl libpng
>  
>  ifeq ($(BR2_PACKAGE_GLMARK2_FLAVOR_DRM_GLESV2),y)
> -GLMARK2_DEPENDENCIES += libdrm libgles udev
> +GLMARK2_DEPENDENCIES += libdrm libgbm libgles udev
>  GLMARK2_FLAVORS += drm-glesv2
>  endif
>  
> -- 
> 2.30.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Nov. 17, 2021, 10:01 p.m. UTC | #2
>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls@t-online.de> writes:

 > Fixes build error with defconfig from:
 > http://autobuild.buildroot.net/results/e393dbfba7c2989fe983df47ea0638c3ba62ae7a/

 >   Checking for 'libdrm': yes
 >   Checking for 'gbm'   : not found

 > after http://patchwork.ozlabs.org/project/buildroot/patch/20200104193919.91589-1-bernd.kuhls@t-online.de/
 > was applied. Both patches are needed to fix the build error.

 > Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 > ---
 > v2: no changes

We don't have BR2_PACKAGE_HAS_LIBGBM / the virtual gbm package in
2021.02.x / 2021.08.x, so I have NOT applied this to the stable
branches.

What is the solution here? Depend on mesa?
Bernd Kuhls Nov. 18, 2021, 6:30 a.m. UTC | #3
Am Wed, 17 Nov 2021 23:01:08 +0100 schrieb Peter Korsgaard:

> We don't have BR2_PACKAGE_HAS_LIBGBM / the virtual gbm package in
> 2021.02.x / 2021.08.x, so I have NOT applied this to the stable
> branches.
> 
> What is the solution here? Depend on mesa?

Hi Peter,

yes, please pick http://patchwork.ozlabs.org/project/buildroot/patch/
20200104193919.91589-2-bernd.kuhls@t-online.de/

Regards, Bernd
diff mbox series

Patch

diff --git a/package/glmark2/Config.in b/package/glmark2/Config.in
index 3ef3a0e8e3..6761397d3f 100644
--- a/package/glmark2/Config.in
+++ b/package/glmark2/Config.in
@@ -5,6 +5,7 @@  config BR2_PACKAGE_GLMARK2_FLAVOR_DRM_GLESV2
 	bool
 	default y
 	depends on BR2_PACKAGE_HAS_LIBEGL
+	depends on BR2_PACKAGE_HAS_LIBGBM
 	depends on BR2_PACKAGE_HAS_LIBGLES
 	depends on BR2_PACKAGE_HAS_UDEV
 	# libpthread-stubs -> libdrm
diff --git a/package/glmark2/glmark2.mk b/package/glmark2/glmark2.mk
index 5ad3ea2cb4..e8d6f71dad 100644
--- a/package/glmark2/glmark2.mk
+++ b/package/glmark2/glmark2.mk
@@ -11,7 +11,7 @@  GLMARK2_LICENSE_FILES = COPYING COPYING.SGI
 GLMARK2_DEPENDENCIES = host-pkgconf jpeg libegl libpng
 
 ifeq ($(BR2_PACKAGE_GLMARK2_FLAVOR_DRM_GLESV2),y)
-GLMARK2_DEPENDENCIES += libdrm libgles udev
+GLMARK2_DEPENDENCIES += libdrm libgbm libgles udev
 GLMARK2_FLAVORS += drm-glesv2
 endif