diff mbox series

[v3,7/7] package/cups: adding python support

Message ID 20200624204347.797088-8-angelo@amarulasolutions.com
State Rejected
Headers show
Series Cups revamp | expand

Commit Message

Angelo Compagnucci June 24, 2020, 8:43 p.m. UTC
Enables python support if python is available.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Michael Trimarchi <michael@amarulasolutions.com>
---
 package/cups/cups.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Arnout Vandecappelle Sept. 2, 2020, 9:07 p.m. UTC | #1
On 24/06/2020 22:43, Angelo Compagnucci wrote:
> Enables python support if python is available.
> 
> Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
> Signed-off-by: Michael Trimarchi <michael@amarulasolutions.com>
> ---
>  package/cups/cups.mk | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/package/cups/cups.mk b/package/cups/cups.mk
> index 805a80e854..67baaf82f9 100644
> --- a/package/cups/cups.mk
> +++ b/package/cups/cups.mk
> @@ -75,6 +75,13 @@ else
>  CUPS_CONF_OPTS += --disable-avahi
>  endif
>  
> +ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
> +CUPS_CONF_OPTS += --with-python
> +CUPS_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
> +else
> +CUPS_CONF_OPTS += --without-python
> +endif

 configure doesn't know this option, and I couldn't find any reference to python
in the cups 2.3.3 source tree. So I marked this path as rejected.

 Regards,
 Arnout

> +
>  ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
>  define CUPS_INSTALL_UDEV_RULES
>  	$(INSTALL) -D -m 0644 package/cups/70-usb-printers.rules \
>
diff mbox series

Patch

diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index 805a80e854..67baaf82f9 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -75,6 +75,13 @@  else
 CUPS_CONF_OPTS += --disable-avahi
 endif
 
+ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
+CUPS_CONF_OPTS += --with-python
+CUPS_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
+else
+CUPS_CONF_OPTS += --without-python
+endif
+
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
 define CUPS_INSTALL_UDEV_RULES
 	$(INSTALL) -D -m 0644 package/cups/70-usb-printers.rules \