diff mbox series

[1/1] package/collectd: fix netsnmp dependency handling

Message ID 20190810122904.22400-1-bernd.kuhls@t-online.de
State Changes Requested
Headers show
Series [1/1] package/collectd: fix netsnmp dependency handling | expand

Commit Message

Bernd Kuhls Aug. 10, 2019, 12:29 p.m. UTC
When a defconfig contains

BR2_PACKAGE_COLLECTD_SNMP is not set
BR2_PACKAGE_NETSNMP=y

collectd was built with snmp support, --with-libnetsnmp should only be
enabled if the collectd-specific option BR2_PACKAGE_COLLECTD_SNMP
is enabled.

Fixes:
http://autobuild.buildroot.net/results/d1c/d1c88b21883d9a6af54cd9a99bc4b0125f08095d/

Please note that this patch does not fix the collectd build with
netsnmp support but the build should only fail for defconfigs with
BR2_PACKAGE_COLLECTD_SNMP enabled ;)

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/collectd/collectd.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 11, 2019, 1:03 p.m. UTC | #1
Hello Bernd,

On Sat, 10 Aug 2019 14:29:04 +0200
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> diff --git a/package/collectd/collectd.mk b/package/collectd/collectd.mk
> index 8eb7aa2ec0..ff36adaef3 100644
> --- a/package/collectd/collectd.mk
> +++ b/package/collectd/collectd.mk
> @@ -182,8 +182,10 @@ endif
>  ifeq ($(BR2_PACKAGE_MYSQL),y)
>  COLLECTD_CONF_OPTS += --with-libmysql=$(STAGING_DIR)/usr
>  endif
> -ifeq ($(BR2_PACKAGE_NETSNMP),y)
> +ifeq ($(BR2_PACKAGE_COLLECTD_SNMP),y)
>  COLLECTD_CONF_OPTS += --with-libnetsnmp=$(STAGING_DIR)/usr
> +else
> +COLLECTD_CONF_OPTS += --with-libnetsnmp=no
>  endif

We normally use --without-foo instead of --with-foo=no.

But more importantly, there is already a --without-snmp that is passed
when BR2_PACKAGE_COLLECTD_SNMP is disabled:

	$(if $(BR2_PACKAGE_COLLECTD_SNMP),--enable-snmp,--disable-snmp) \

Isn't that sufficient ?

Also, if the --disable-snmp isn't sufficient, then don't we have the
same problem for MySQL, PostgreSQL and a number of other dependencies ?

For example, for MySQL, we have in CONF_OPTS:

	$(if $(BR2_PACKAGE_COLLECTD_MYSQL),--enable-mysql,--disable-mysql) \

Then in DEPENDENCIES:

	$(if $(BR2_PACKAGE_COLLECTD_MYSQL),mysql) \

And later:

ifeq ($(BR2_PACKAGE_MYSQL),y)
COLLECTD_CONF_OPTS += --with-libmysql=$(STAGING_DIR)/usr
endif

So we have the exact same situation as SNMP.

Could you have a look into this ?

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/collectd/collectd.mk b/package/collectd/collectd.mk
index 8eb7aa2ec0..ff36adaef3 100644
--- a/package/collectd/collectd.mk
+++ b/package/collectd/collectd.mk
@@ -182,8 +182,10 @@  endif
 ifeq ($(BR2_PACKAGE_MYSQL),y)
 COLLECTD_CONF_OPTS += --with-libmysql=$(STAGING_DIR)/usr
 endif
-ifeq ($(BR2_PACKAGE_NETSNMP),y)
+ifeq ($(BR2_PACKAGE_COLLECTD_SNMP),y)
 COLLECTD_CONF_OPTS += --with-libnetsnmp=$(STAGING_DIR)/usr
+else
+COLLECTD_CONF_OPTS += --with-libnetsnmp=no
 endif
 ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
 COLLECTD_CONF_OPTS += --with-libpq=$(STAGING_DIR)/usr/bin/pg_config