diff mbox series

[1/2] package/libva: remove optional mesa3d support

Message ID 20190407171318.19852-1-bernd.kuhls@t-online.de
State Superseded
Headers show
Series [1/2] package/libva: remove optional mesa3d support | expand

Commit Message

Bernd Kuhls April 7, 2019, 5:13 p.m. UTC
Kodi 18.0-Leia will support vaapi on r600 and radeonsi.
We need libva support in mesa3d for this. To avoid the circular
dependency we switch from using mesa3d in libva to use libva in mesa3d.

This patch is the first step: disable mesa3d support in libva.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/libva/libva.mk | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

Comments

Thomas Petazzoni April 10, 2019, 5:13 p.m. UTC | #1
Hello Bernd,

On Sun,  7 Apr 2019 19:13:17 +0200
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> Kodi 18.0-Leia will support vaapi on r600 and radeonsi.
> We need libva support in mesa3d for this. To avoid the circular
> dependency we switch from using mesa3d in libva to use libva in mesa3d.
> 
> This patch is the first step: disable mesa3d support in libva.
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/libva/libva.mk | 7 ++-----
>  1 file changed, 2 insertions(+), 5 deletions(-)

I understand the circular dependency issue, but what makes it
reasonable to drop mesa3d support in libva ? Until now, the choice was
rather the opposite: have mesa3d support in libva, and no libva support
in mesa3d. Is there a fundamental reason why one is more useful than
the other ?

Thanks,

Thomas
Bernd Kuhls April 10, 2019, 5:43 p.m. UTC | #2
Am Wed, 10 Apr 2019 19:13:07 +0200 schrieb Thomas Petazzoni:

> I understand the circular dependency issue, but what makes it reasonable
> to drop mesa3d support in libva ? Until now, the choice was rather the
> opposite: have mesa3d support in libva, and no libva support in mesa3d.
> Is there a fundamental reason why one is more useful than the other ?

Hi Thomas,

first I like to mention that I do not have any AMD hardware in use with 
buildroot, I am just following the development of Libreelec:

https://github.com/xbmc/xbmc/pull/13333
https://github.com/LibreELEC/LibreELEC.tv/pull/2403

The motivation for the Kodi patch was: "Hardware decoding with AMD GPUs 
is only supported with this new method"

Because I think this will improve user experience with AMD hardware I 
sent these patches.

Regards, Bernd
diff mbox series

Patch

diff --git a/package/libva/libva.mk b/package/libva/libva.mk
index 8a21c11b6c..d1538934e7 100644
--- a/package/libva/libva.mk
+++ b/package/libva/libva.mk
@@ -15,17 +15,14 @@  LIBVA_DEPENDENCIES = host-pkgconf libdrm
 # libdrm is a hard-dependency
 LIBVA_CONF_OPTS = \
 	--enable-drm \
+	--disable-glx \
 	--with-drivers-path="/usr/lib/va"
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
 LIBVA_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXfixes
 LIBVA_CONF_OPTS += --enable-x11
-ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),y)
-LIBVA_DEPENDENCIES += mesa3d
-LIBVA_CONF_OPTS += --enable-glx
-endif
 else
-LIBVA_CONF_OPTS += --disable-glx --disable-x11
+LIBVA_CONF_OPTS += --disable-x11
 endif
 
 ifeq ($(BR2_PACKAGE_WAYLAND),y)