diff mbox series

[1/1] package/freeswitch: add optional support for postgresql

Message ID 20180504182634.20368-1-bernd.kuhls@t-online.de
State Accepted
Commit 71b9679034a4d9cea66a5fe900ff560ac83e3663
Headers show
Series [1/1] package/freeswitch: add optional support for postgresql | expand

Commit Message

Bernd Kuhls May 4, 2018, 6:26 p.m. UTC
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/freeswitch/freeswitch.mk | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comments

Peter Korsgaard May 6, 2018, 7:08 a.m. UTC | #1
>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls@t-online.de> writes:

 > Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/freeswitch/freeswitch.mk b/package/freeswitch/freeswitch.mk
index 98f2f48356..4d490b0730 100644
--- a/package/freeswitch/freeswitch.mk
+++ b/package/freeswitch/freeswitch.mk
@@ -275,6 +275,17 @@  FREESWITCH_DEPENDENCIES += opencv
 FREESWITCH_ENABLED_MODULES += applications/mod_cv
 endif
 
+ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
+FREESWITCH_CONF_ENV += \
+	ac_cv_path_PG_CONFIG=$(STAGING_DIR)/usr/bin/pg_config
+FREESWITCH_CONF_OPTS += \
+	--enable-core-pgsql-pkgconfig \
+	--enable-core-pgsql-support
+FREESWITCH_DEPENDENCIES += postgresql
+else
+FREESWITCH_CONF_OPTS += --disable-core-pgsql-support
+endif
+
 ifeq ($(BR2_PACKAGE_UNIXODBC),y)
 FREESWITCH_DEPENDENCIES += unixodbc
 FREESWITCH_CONF_OPTS += \