diff mbox series

[1/1] vte: new package

Message ID 20180116152333.29596-1-stefan.froberg@petroprogram.com
State Changes Requested
Headers show
Series [1/1] vte: new package | expand

Commit Message

Stefan Fröberg Jan. 16, 2018, 3:23 p.m. UTC
The VTE package contains a termcap file implementation for terminal emulators. 

Signed-off-by: Stefan Fröberg <stefan.froberg@petroprogram.com>
---
 DEVELOPERS            |  1 +
 package/Config.in     |  1 +
 package/vte/Config.in | 15 +++++++++++++++
 package/vte/vte.mk    | 15 +++++++++++++++
 4 files changed, 32 insertions(+)
 create mode 100644 package/vte/Config.in
 create mode 100644 package/vte/vte.mk

Comments

Thomas Petazzoni Jan. 16, 2018, 4:07 p.m. UTC | #1
Hello,

On Tue, 16 Jan 2018 17:23:33 +0200, Stefan Fröberg wrote:

> diff --git a/package/vte/Config.in b/package/vte/Config.in
> new file mode 100644
> index 0000000000..e448477d69
> --- /dev/null
> +++ b/package/vte/Config.in
> @@ -0,0 +1,15 @@
> +config BR2_PACKAGE_VTE
> +	bool "vte"
> +	select BR2_PACKAGE_LIBGTK3

You can't just select libgtk3 so easily. It has lots of dependencies:

        depends on BR2_USE_WCHAR # glib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
        depends on BR2_USE_MMU # glib2
        depends on BR2_INSTALL_LIBSTDCPP # pango
        depends on BR2_TOOLCHAIN_HAS_SYNC_4 # pango -> harfbuzz
        depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
                BR2_PACKAGE_HAS_LIBGL

> +	select BR2_PACKAGE_LIBXML2
> +	select BR2_PACKAGE_PCRE2
> +	depends on BR2_PACKAGE_XORG7

The depends on should go before the select. This is checked
by ./utils/check-package.

> +	help
> +	  VTE is a library (libvte) implementing a terminal emulator
> +	  widget for GTK+, and a minimal sample application (vte)
> +	  using that. Vte is mainly used in gnome-terminal, but
> +	  can also be used to embed a console/terminal in games,
> +	  editors, IDEs, etc.
> +
> +	  http://github.com/GNOME/vte
> +

Spurious empty line.

You will need a bunch of Config.in comments here about this package
dependencies.

Thanks!

Thomas
Stefan Fröberg Jan. 16, 2018, 5:58 p.m. UTC | #2
Hi Thomas


Thomas Petazzoni kirjoitti 16.01.2018 klo 18:07:
> Hello,
>
> On Tue, 16 Jan 2018 17:23:33 +0200, Stefan Fröberg wrote:
>
>> diff --git a/package/vte/Config.in b/package/vte/Config.in
>> new file mode 100644
>> index 0000000000..e448477d69
>> --- /dev/null
>> +++ b/package/vte/Config.in
>> @@ -0,0 +1,15 @@
>> +config BR2_PACKAGE_VTE
>> +	bool "vte"
>> +	select BR2_PACKAGE_LIBGTK3
> You can't just select libgtk3 so easily. It has lots of dependencies:
>
>         depends on BR2_USE_WCHAR # glib2
>         depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
>         depends on BR2_USE_MMU # glib2
>         depends on BR2_INSTALL_LIBSTDCPP # pango
>         depends on BR2_TOOLCHAIN_HAS_SYNC_4 # pango -> harfbuzz
>         depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
>                 BR2_PACKAGE_HAS_LIBGL
>
>> +	select BR2_PACKAGE_LIBXML2
>> +	select BR2_PACKAGE_PCRE2
>> +	depends on BR2_PACKAGE_XORG7
> The depends on should go before the select. This is checked
> by ./utils/check-package.
>
>> +	help
>> +	  VTE is a library (libvte) implementing a terminal emulator
>> +	  widget for GTK+, and a minimal sample application (vte)
>> +	  using that. Vte is mainly used in gnome-terminal, but
>> +	  can also be used to embed a console/terminal in games,
>> +	  editors, IDEs, etc.
>> +
>> +	  http://github.com/GNOME/vte
>> +
> Spurious empty line.
>
> You will need a bunch of Config.in comments here about this package
> dependencies.
>
> Thanks!
>
> Thomas

Gosh, and it looked soooo simple package do when I saw that anonymous
package request.
Oh, well...Time for patch round 2 then... ;-)

Thanks T!
-S-
Stefan Fröberg Jan. 16, 2018, 10:29 p.m. UTC | #3
Oh, one thing ...


Stefan Fröberg kirjoitti 16.01.2018 klo 19:58:
> Hi Thomas
>
>
> Thomas Petazzoni kirjoitti 16.01.2018 klo 18:07:
>> Hello,
>>
>> On Tue, 16 Jan 2018 17:23:33 +0200, Stefan Fröberg wrote:
>>
>>> diff --git a/package/vte/Config.in b/package/vte/Config.in
>>> new file mode 100644
>>> index 0000000000..e448477d69
>>> --- /dev/null
>>> +++ b/package/vte/Config.in
>>> @@ -0,0 +1,15 @@
>>> +config BR2_PACKAGE_VTE
>>> +	bool "vte"
>>> +	select BR2_PACKAGE_LIBGTK3
>> You can't just select libgtk3 so easily. It has lots of dependencies:
>>
>>         depends on BR2_USE_WCHAR # glib2
>>         depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
>>         depends on BR2_USE_MMU # glib2
>>         depends on BR2_INSTALL_LIBSTDCPP # pango
>>         depends on BR2_TOOLCHAIN_HAS_SYNC_4 # pango -> harfbuzz
>> *depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \ BR2_PACKAGE_HAS_LIBGL *

Is OpenGL *really* needed for libgtk3 ?

Im asking because I have a chrooted musl environment where I
intentionally tried to avoid any package that tries to pull OpenGL stuff
(like mesa, wayland etc...) and I managed to build
gtk3 just fine (version 3.22.26)

Here's it's built conf (uses static libs, introspection disabled and
uses X11 backend):

./configure --prefix=/usr --sysconfdir=/etc --disable-nls
--disable-rpath --disable-shared --disable-modules --enable-static
--enable-x11-backend --enable-broadway-backend --disable-glibtest
--disable-cloudprint --disable-introspection --disable-gtk-doc
--disable-man --disable-gtk-doc-html --disable-gtk-doc-pdf --with-pic



Regards
-S
<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <p><br>
    </p>
    <p>Oh, one thing ...<br>
    </p>
    <br>
    <div class="moz-cite-prefix">Stefan Fröberg kirjoitti 16.01.2018 klo
      19:58:<br>
    </div>
    <blockquote type="cite"
      cite="mid:d8bb959e-509d-98fa-6f1f-178a16096fe5@petroprogram.com">
      <pre wrap="">Hi Thomas


Thomas Petazzoni kirjoitti 16.01.2018 klo 18:07:
</pre>
      <blockquote type="cite">
        <pre wrap="">Hello,

On Tue, 16 Jan 2018 17:23:33 +0200, Stefan Fröberg wrote:

</pre>
        <blockquote type="cite">
          <pre wrap="">diff --git a/package/vte/Config.in b/package/vte/Config.in
new file mode 100644
index 0000000000..e448477d69
--- /dev/null
+++ b/package/vte/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_VTE
+	bool "vte"
+	select BR2_PACKAGE_LIBGTK3
</pre>
        </blockquote>
        <pre wrap="">You can't just select libgtk3 so easily. It has lots of dependencies:

        depends on BR2_USE_WCHAR # glib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
        depends on BR2_USE_MMU # glib2
        depends on BR2_INSTALL_LIBSTDCPP # pango
        depends on BR2_TOOLCHAIN_HAS_SYNC_4 # pango -&gt; harfbuzz
<b>        depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
                BR2_PACKAGE_HAS_LIBGL
</b></pre>
      </blockquote>
    </blockquote>
    <br>
    Is OpenGL *really* needed for libgtk3 ?<br>
    <br>
    Im asking because I have a chrooted musl environment where I
    intentionally tried to avoid any package that tries to pull OpenGL
    stuff (like mesa, wayland etc...) and I managed to build<br>
    gtk3 just fine (version 3.22.26)<br>
    <br>
    Here's it's built conf (uses static libs, introspection disabled and
    uses X11 backend):<br>
    <br>
    ./configure --prefix=/usr --sysconfdir=/etc --disable-nls
    --disable-rpath --disable-shared --disable-modules --enable-static
    --enable-x11-backend --enable-broadway-backend --disable-glibtest
    --disable-cloudprint --disable-introspection --disable-gtk-doc
    --disable-man --disable-gtk-doc-html --disable-gtk-doc-pdf
    --with-pic<br>
    <br>
    <br>
    <br>
    Regards<br>
    -S<br>
    <br>
  </body>
</html>
Thomas Petazzoni Jan. 16, 2018, 10:47 p.m. UTC | #4
Hello,

On Wed, 17 Jan 2018 00:29:13 +0200, Stefan Fröberg wrote:

> >>         depends on BR2_USE_WCHAR # glib2
> >>         depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
> >>         depends on BR2_USE_MMU # glib2
> >>         depends on BR2_INSTALL_LIBSTDCPP # pango
> >>         depends on BR2_TOOLCHAIN_HAS_SYNC_4 # pango -> harfbuzz
> >> *depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \ BR2_PACKAGE_HAS_LIBGL *  
> 
> Is OpenGL *really* needed for libgtk3 ?

I remember having a lengthy discussion back then with Gustavo, who said
OpenGL was really needed. However, things might have evolved since then.

> Im asking because I have a chrooted musl environment where I
> intentionally tried to avoid any package that tries to pull OpenGL stuff
> (like mesa, wayland etc...) and I managed to build
> gtk3 just fine (version 3.22.26)
> 
> Here's it's built conf (uses static libs, introspection disabled and
> uses X11 backend):
> 
> ./configure --prefix=/usr --sysconfdir=/etc --disable-nls
> --disable-rpath --disable-shared --disable-modules --enable-static
> --enable-x11-backend --enable-broadway-backend --disable-glibtest
> --disable-cloudprint --disable-introspection --disable-gtk-doc
> --disable-man --disable-gtk-doc-html --disable-gtk-doc-pdf --with-pic

Does the result actually runs on some target platform ?

If so, it would definitely be nice to support gtk3 without OpenGL.

Best regards,

Thomas
Stefan Fröberg Jan. 16, 2018, 10:55 p.m. UTC | #5
Hi


Thomas Petazzoni kirjoitti 17.01.2018 klo 00:47:
> Hello,
>
> On Wed, 17 Jan 2018 00:29:13 +0200, Stefan Fröberg wrote:
>
>>>>         depends on BR2_USE_WCHAR # glib2
>>>>         depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
>>>>         depends on BR2_USE_MMU # glib2
>>>>         depends on BR2_INSTALL_LIBSTDCPP # pango
>>>>         depends on BR2_TOOLCHAIN_HAS_SYNC_4 # pango -> harfbuzz
>>>> *depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \ BR2_PACKAGE_HAS_LIBGL *  
>> Is OpenGL *really* needed for libgtk3 ?
> I remember having a lengthy discussion back then with Gustavo, who said
> OpenGL was really needed. However, things might have evolved since then.
>
>> Im asking because I have a chrooted musl environment where I
>> intentionally tried to avoid any package that tries to pull OpenGL stuff
>> (like mesa, wayland etc...) and I managed to build
>> gtk3 just fine (version 3.22.26)
>>
>> Here's it's built conf (uses static libs, introspection disabled and
>> uses X11 backend):
>>
>> ./configure --prefix=/usr --sysconfdir=/etc --disable-nls
>> --disable-rpath --disable-shared --disable-modules --enable-static
>> --enable-x11-backend --enable-broadway-backend --disable-glibtest
>> --disable-cloudprint --disable-introspection --disable-gtk-doc
>> --disable-man --disable-gtk-doc-html --disable-gtk-doc-pdf --with-pic
> Does the result actually runs on some target platform ?
I really hope so.
I am currently, at this very moment, building my app against webkitgtk
in that chrooted environment
and if all goes well, I get a nice big static binary blob that I could
try with any Linux, no matter
what C-libc is being used. And should not need OpenGL.
As long as the CPU is x86_64 it should run.
>
> If so, it would definitely be nice to support gtk3 without OpenGL.
>
>
Great! I keep fingers crossed :-)

Regards
-S-
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 2f7d051e8a..0f81b7093b 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1642,6 +1642,7 @@  N:	Stefan Fröberg <stefan.froberg@petroprogram.com>
 F:	package/elfutils/
 F:	package/libtasn1/
 F:	package/proxychains-ng/
+F:	package/vte/
 F:	package/yasm/
 F:	package/zlib-ng/
 
diff --git a/package/Config.in b/package/Config.in
index 01f4095be5..be0304442a 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -333,6 +333,7 @@  comment "X applications"
 	source "package/qt-webkit-kiosk/Config.in"
 	source "package/rdesktop/Config.in"
 	source "package/synergy/Config.in"
+	source "package/vte/Config.in"
 	source "package/wmctrl/Config.in"
 	source "package/x11vnc/Config.in"
 	source "package/xdotool/Config.in"
diff --git a/package/vte/Config.in b/package/vte/Config.in
new file mode 100644
index 0000000000..e448477d69
--- /dev/null
+++ b/package/vte/Config.in
@@ -0,0 +1,15 @@ 
+config BR2_PACKAGE_VTE
+	bool "vte"
+	select BR2_PACKAGE_LIBGTK3
+	select BR2_PACKAGE_LIBXML2
+	select BR2_PACKAGE_PCRE2
+	depends on BR2_PACKAGE_XORG7
+	help
+	  VTE is a library (libvte) implementing a terminal emulator
+	  widget for GTK+, and a minimal sample application (vte)
+	  using that. Vte is mainly used in gnome-terminal, but
+	  can also be used to embed a console/terminal in games,
+	  editors, IDEs, etc.
+
+	  http://github.com/GNOME/vte
+
diff --git a/package/vte/vte.mk b/package/vte/vte.mk
new file mode 100644
index 0000000000..e62f807efc
--- /dev/null
+++ b/package/vte/vte.mk
@@ -0,0 +1,15 @@ 
+################################################################################
+#
+# vte
+#
+################################################################################
+
+VTE_VERSION = 0.48.3
+VTE_SOURCE = vte-$(VTE_VERSION).tar.xz
+VTE_SITE = http://ftp.gnome.org/pub/gnome/sources/vte/0.48
+VTE_DEPENDENCIES = host-pkgconf libgtk3 libxml2 pcre2
+VTE_LICENSE = LGPL-2.0+
+VTE_LICENSE_FILES = COPYING
+VTE_CONF_OPTS += --disable-introspection --without-gnutls --disable-vala
+
+$(eval $(autotools-package))