diff mbox series

package/brltty: disable features and add optional dependencies

Message ID 20171218095143.15343-1-mlang@blind.guru
State Accepted
Headers show
Series package/brltty: disable features and add optional dependencies | expand

Commit Message

Mario Lang Dec. 18, 2017, 9:51 a.m. UTC
* --without-midi-package should fix a number of autobuild failures.
* Disable a number of speech drivers to avoid build failures
  if they are installed on the host.
* Optional dependency on espeak and flite fixes builds where
  espeak or flite are installed on the host.

Signed-off-by: Mario Lang <mlang@blind.guru>
---
 package/brltty/brltty.mk | 19 ++++++++++++++++++-
 1 file changed, 18 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Dec. 18, 2017, 10:01 a.m. UTC | #1
Hello,

Thanks for this fixup patch. A few comments/questions below.

On Mon, 18 Dec 2017 10:51:43 +0100, Mario Lang wrote:
> * --without-midi-package should fix a number of autobuild failures.

Which ones? We like to have references to autobuilder failures.

> * Disable a number of speech drivers to avoid build failures
>   if they are installed on the host.
> * Optional dependency on espeak and flite fixes builds where
>   espeak or flite are installed on the host.

Autobuilder failure references ?

Thanks!

Thomas
Mario Lang Dec. 18, 2017, 11:31 a.m. UTC | #2
Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

> On Mon, 18 Dec 2017 10:51:43 +0100, Mario Lang wrote:
>> * --without-midi-package should fix a number of autobuild failures.
>
> Which ones? We like to have references to autobuilder failures.

At least these two:
http://autobuild.buildroot.net/results/0c4f557c2ad276b1ed065119532af37c0af5f014
http://autobuild.buildroot.net/results/ea82b7c7732821368746ddddb5d529e97c9b6c16

>> * Disable a number of speech drivers to avoid build failures
>>   if they are installed on the host.
>> * Optional dependency on espeak and flite fixes builds where
>>   espeak or flite are installed on the host.
>
> Autobuilder failure references ?

These failures didn't show up on any autobuilder, as autobuilders
typically don't have commercial speech synthesizers or espeak/flite
installed on the host.  But these build failures showed up during builds
of BRLTTY users.  In particular, espeak, flite and speechd were
accidentally picked up from the host during configure.
Thomas Petazzoni Dec. 18, 2017, 2:57 p.m. UTC | #3
Hello,

On Mon, 18 Dec 2017 10:51:43 +0100, Mario Lang wrote:
> * --without-midi-package should fix a number of autobuild failures.
> * Disable a number of speech drivers to avoid build failures
>   if they are installed on the host.
> * Optional dependency on espeak and flite fixes builds where
>   espeak or flite are installed on the host.
> 
> Signed-off-by: Mario Lang <mlang@blind.guru>
> ---
>  package/brltty/brltty.mk | 19 ++++++++++++++++++-
>  1 file changed, 18 insertions(+), 1 deletion(-)

Applied to master after adding the references to the autobuilder
failures.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/brltty/brltty.mk b/package/brltty/brltty.mk
index 5ce0684168..7214f10fa0 100644
--- a/package/brltty/brltty.mk
+++ b/package/brltty/brltty.mk
@@ -18,7 +18,10 @@  BRLTTY_CONF_OPTS = \
 	--disable-lisp-bindings \
 	--disable-ocaml-bindings \
 	--disable-python-bindings \
-	--disable-tcl-bindings
+	--disable-tcl-bindings \
+	--without-midi-package \
+	--without-mikropuhe --without-speechd --without-swift \
+	--without-theta --without-viavoice
 
 ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
 BRLTTY_DEPENDENCIES += bluez5_utils
@@ -27,6 +30,20 @@  else
 BRLTTY_CONF_OPTS += --without-bluetooth-package
 endif
 
+ifeq ($(BR2_PACKAGE_ESPEAK),y)
+BRLTTY_DEPENDENCIES += espeak
+BRLTTY_CONF_OPTS += --with-espeak=$(TARGET_DIR)/usr
+else
+BRLTTY_CONF_OPTS += --without-espeak
+endif
+
+ifeq ($(BR2_PACKAGE_FLITE),y)
+BRLTTY_DEPENDENCIES += flite
+BRLTTY_CONF_OPTS += --with-flite=$(STAGING_DIR)/usr
+else
+BRLTTY_CONF_OPTS += --without-flite
+endif
+
 ifeq ($(BR2_PACKAGE_ICU),y)
 BRLTTY_DEPENDENCIES += icu
 BRLTTY_CONF_OPTS += --enable-icu