diff mbox series

xenomai: bump to 3.0.6

Message ID 20171204175909.21596-1-nolange79@gmail.com
State Accepted
Headers show
Series xenomai: bump to 3.0.6 | expand

Commit Message

Norbert Lange Dec. 4, 2017, 5:59 p.m. UTC
From: Norbert Lange <norbert.lange@andritz.com>

this includes a fix to allow compilation with compilers
defaulting to -fpie (gcc 6+)

Signed-off-by: Norbert Lange <nolange79@gmail.com>
---
 package/xenomai/xenomai.hash | 2 +-
 package/xenomai/xenomai.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Romain Naour Dec. 4, 2017, 11:24 p.m. UTC | #1
Hi Norbert,

Le 04/12/2017 à 18:59, Norbert Lange a écrit :
> From: Norbert Lange <norbert.lange@andritz.com>
> 
> this includes a fix to allow compilation with compilers
> defaulting to -fpie (gcc 6+)

Maybe you can add this link about a critical bug in Cobalt:

http://xenomai.org/pipermail/xenomai/2017-November/037923.html

This bug affect all previous version of Xenomai.

Otherwise:
Reviewed-by: Romain Naour <romain.naour@gmail.com>

Also, Xenomai contains several license files, can you add a license hash for
each of them in a followup patch?

Thanks!

Best regards,
Romain
> 
> Signed-off-by: Norbert Lange <nolange79@gmail.com>
> ---
>  package/xenomai/xenomai.hash | 2 +-
>  package/xenomai/xenomai.mk   | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/xenomai/xenomai.hash b/package/xenomai/xenomai.hash
> index 1290ca54fb..c36badb6bf 100644
> --- a/package/xenomai/xenomai.hash
> +++ b/package/xenomai/xenomai.hash
> @@ -1,2 +1,2 @@
>  # Locally computed;
> -sha256 84836a43b6a996dcdcb42b0b1653a3271cc201df2a2d42c1b4b3bafb2cca7c63  xenomai-3.0.5.tar.bz2
> +sha256 2c0dd3f0e36e4a10f97e0028989bb873e80f4d1ce212ac55fd3b28857c464f94  xenomai-3.0.6.tar.bz2
> diff --git a/package/xenomai/xenomai.mk b/package/xenomai/xenomai.mk
> index c53d5148f0..6bf08edfbc 100644
> --- a/package/xenomai/xenomai.mk
> +++ b/package/xenomai/xenomai.mk
> @@ -6,7 +6,7 @@
>  
>  XENOMAI_VERSION = $(call qstrip,$(BR2_PACKAGE_XENOMAI_VERSION))
>  ifeq ($(XENOMAI_VERSION),)
> -XENOMAI_VERSION = 3.0.5
> +XENOMAI_VERSION = 3.0.6
>  else
>  BR_NO_CHECK_HASH_FOR += $(XENOMAI_SOURCE)
>  endif
>
Thomas Petazzoni Dec. 6, 2017, 9:56 p.m. UTC | #2
Hello,

On Mon,  4 Dec 2017 18:59:08 +0100, Norbert Lange wrote:
> From: Norbert Lange <norbert.lange@andritz.com>
> 
> this includes a fix to allow compilation with compilers
> defaulting to -fpie (gcc 6+)
> 
> Signed-off-by: Norbert Lange <nolange79@gmail.com>
> ---
>  package/xenomai/xenomai.hash | 2 +-
>  package/xenomai/xenomai.mk   | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)

Applied to master after adding some comment in the commit log about the
critical bug that has been fixed in this version, as reported by Romain.

Speaking of Xenomai, it would be really nice to have a test case for it
in our runtime test infrastructure, see support/testing/. If you're
interested feel free to contribute :-)

Thanks a lot!

Thomas
Peter Korsgaard Dec. 27, 2017, 11:34 a.m. UTC | #3
>>>>> "Norbert" == Norbert Lange <nolange79@gmail.com> writes:

 > From: Norbert Lange <norbert.lange@andritz.com>
 > this includes a fix to allow compilation with compilers
 > defaulting to -fpie (gcc 6+)

 > Signed-off-by: Norbert Lange <nolange79@gmail.com>

Committed to 2017.11.x, thanks.
diff mbox series

Patch

diff --git a/package/xenomai/xenomai.hash b/package/xenomai/xenomai.hash
index 1290ca54fb..c36badb6bf 100644
--- a/package/xenomai/xenomai.hash
+++ b/package/xenomai/xenomai.hash
@@ -1,2 +1,2 @@ 
 # Locally computed;
-sha256 84836a43b6a996dcdcb42b0b1653a3271cc201df2a2d42c1b4b3bafb2cca7c63  xenomai-3.0.5.tar.bz2
+sha256 2c0dd3f0e36e4a10f97e0028989bb873e80f4d1ce212ac55fd3b28857c464f94  xenomai-3.0.6.tar.bz2
diff --git a/package/xenomai/xenomai.mk b/package/xenomai/xenomai.mk
index c53d5148f0..6bf08edfbc 100644
--- a/package/xenomai/xenomai.mk
+++ b/package/xenomai/xenomai.mk
@@ -6,7 +6,7 @@ 
 
 XENOMAI_VERSION = $(call qstrip,$(BR2_PACKAGE_XENOMAI_VERSION))
 ifeq ($(XENOMAI_VERSION),)
-XENOMAI_VERSION = 3.0.5
+XENOMAI_VERSION = 3.0.6
 else
 BR_NO_CHECK_HASH_FOR += $(XENOMAI_SOURCE)
 endif