diff mbox series

[1/1] package/lftp: Add optional support for libidn

Message ID 20171128121012.27857-1-mlang@blind.guru
State Accepted
Headers show
Series [1/1] package/lftp: Add optional support for libidn | expand

Commit Message

Mario Lang Nov. 28, 2017, 12:10 p.m. UTC
Signed-off-by: Mario Lang <mlang@blind.guru>
---
 package/lftp/lftp.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni Nov. 29, 2017, 8:36 p.m. UTC | #1
Hello,

On Tue, 28 Nov 2017 13:10:12 +0100, Mario Lang wrote:
> Signed-off-by: Mario Lang <mlang@blind.guru>
> ---
>  package/lftp/lftp.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/lftp/lftp.mk b/package/lftp/lftp.mk
index de4ebb8521..b174057f03 100644
--- a/package/lftp/lftp.mk
+++ b/package/lftp/lftp.mk
@@ -41,6 +41,13 @@  else
 LFTP_CONF_OPTS += --without-openssl
 endif
 
+ifeq ($(BR2_PACKAGE_LIBIDN),y)
+LFTP_DEPENDENCIES += libidn
+LFTP_CONF_OPTS += --with-libidn=$(STAGING_DIR)/usr
+else
+LFTP_CONF_OPTS += --without-libidn
+endif
+
 # Remove /usr/share/lftp
 define LFTP_REMOVE_DATA
 	$(RM) -fr $(TARGET_DIR)/usr/share/lftp