diff mbox series

[1/2] rauc: select host-squashfs as a host dependency

Message ID 20171128032723.14081-1-yurovsky@gmail.com
State Accepted
Headers show
Series [1/2] rauc: select host-squashfs as a host dependency | expand

Commit Message

Andrey Yurovsky Nov. 28, 2017, 3:27 a.m. UTC
The rauc host tool (used to generate update bundles) runs mksquashfs so
host-squashfs is required for it to work at runtime.

Signed-off-by: Andrey Yurovsky <yurovsky@gmail.com>
---
 package/rauc/Config.in.host | 1 +
 package/rauc/rauc.mk        | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Nov. 29, 2017, 9:16 p.m. UTC | #1
Hello,

On Mon, 27 Nov 2017 19:27:22 -0800, Andrey Yurovsky wrote:
> The rauc host tool (used to generate update bundles) runs mksquashfs so
> host-squashfs is required for it to work at runtime.
> 
> Signed-off-by: Andrey Yurovsky <yurovsky@gmail.com>
> ---
>  package/rauc/Config.in.host | 1 +
>  package/rauc/rauc.mk        | 2 +-
>  2 files changed, 2 insertions(+), 1 deletion(-)

I've applied to master. Note however that it in fact doesn't really
solve the problem entirely, because $(HOST_DIR)/bin is not in the PATH,
so rauc still doesn't find mksquashfs:

$ ./output/host/bin/rauc --cert demo.cert.pem --key demo.key.pem bundle output/images/t/ test.raucb
input directory: output/images/t/
output bundle: test.raucb

(rauc:17776): rauc-WARNING **: failed to create bundle: Failed to start mksquashfs: Failed to execute child process ?mksquashfs? (No such file or directory)

But mksquashfs is in output/host/bin. Perhaps rauc should also try to
find mksquashfs from the same directory as rauc, before trying a
system-wide installed one?

Or we expect people to run "rauc bundle" from a post-image script, in
which case $(HOST_DIR)/bin is in the PATH ?

Best regards,

Thomas
Thomas Petazzoni Nov. 29, 2017, 9:18 p.m. UTC | #2
Hello,

On Mon, 27 Nov 2017 19:27:23 -0800, Andrey Yurovsky wrote:
> Version 0.2 of rauc provides several bug fixes and minor feature
> enhancements.
> 
> Signed-off-by: Andrey Yurovsky <yurovsky@gmail.com>
> ---
>  package/rauc/rauc.hash | 4 ++--
>  package/rauc/rauc.mk   | 2 +-
>  2 files changed, 3 insertions(+), 3 deletions(-)

Applied to next, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/rauc/Config.in.host b/package/rauc/Config.in.host
index a58685a2e6..1bd9a7935a 100644
--- a/package/rauc/Config.in.host
+++ b/package/rauc/Config.in.host
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_HOST_RAUC
 	bool "host rauc"
+	select BR2_PACKAGE_HOST_SQUASHFS # run-time dependency
 	help
 	  RAUC is the Robust Auto-Update Controller developed by
 	  Pengutronix. Enable this option to build the rauc
diff --git a/package/rauc/rauc.mk b/package/rauc/rauc.mk
index 479a583206..67ef1556e7 100644
--- a/package/rauc/rauc.mk
+++ b/package/rauc/rauc.mk
@@ -29,7 +29,7 @@  ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 RAUC_DEPENDENCIES += systemd
 endif
 
-HOST_RAUC_DEPENDENCIES = host-pkgconf host-openssl host-libglib2
+HOST_RAUC_DEPENDENCIES = host-pkgconf host-openssl host-libglib2 host-squashfs
 HOST_RAUC_CONF_OPTS += --disable-network --disable-json --disable-service
 
 $(eval $(autotools-package))