diff mbox series

[1/1] linphone: add libupnp dependency

Message ID 20171126212640.23519-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] linphone: add libupnp dependency | expand

Commit Message

Fabrice Fontaine Nov. 26, 2017, 9:26 p.m. UTC
linphone is compatible with libupnp but not with libupnp18 so disable
upnp if libupnp is not enabled

Fixes:
 - http://autobuild.buildroot.net/results/473c686f9bc5335d25b720cf1b0c45389138a7b4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/linphone/linphone.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni Nov. 27, 2017, 8:31 a.m. UTC | #1
Hello,

On Sun, 26 Nov 2017 22:26:40 +0100, Fabrice Fontaine wrote:
> linphone is compatible with libupnp but not with libupnp18 so disable
> upnp if libupnp is not enabled
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/473c686f9bc5335d25b720cf1b0c45389138a7b4
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/linphone/linphone.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Even though it fixes a build failure that happens only in next, I've
pushed this patch to the master branch, because we generally consider
adding such optional dependencies patches to be bug fixes.

So: applied to master with a reworked commit log. Thanks!

Thomas
Peter Korsgaard Dec. 20, 2017, 8:45 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 > Hello,
 > On Sun, 26 Nov 2017 22:26:40 +0100, Fabrice Fontaine wrote:
 >> linphone is compatible with libupnp but not with libupnp18 so disable
 >> upnp if libupnp is not enabled
 >> 
 >> Fixes:
 >> - http://autobuild.buildroot.net/results/473c686f9bc5335d25b720cf1b0c45389138a7b4
 >> 
 >> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 >> ---
 >> package/linphone/linphone.mk | 7 +++++++
 >> 1 file changed, 7 insertions(+)

 > Even though it fixes a build failure that happens only in next, I've
 > pushed this patch to the master branch, because we generally consider
 > adding such optional dependencies patches to be bug fixes.

 > So: applied to master with a reworked commit log. Thanks!

Committed to 2017.02.x, thanks.
diff mbox series

Patch

diff --git a/package/linphone/linphone.mk b/package/linphone/linphone.mk
index fb5e18db6..a10d6bb20 100644
--- a/package/linphone/linphone.mk
+++ b/package/linphone/linphone.mk
@@ -50,4 +50,11 @@  else
 LINPHONE_CONF_OPTS += --disable-libv4l1 --disable-libv4l2
 endif
 
+ifeq ($(BR2_PACKAGE_LIBUPNP),y)
+LINPHONE_DEPENDENCIES += libupnp
+LINPHONE_CONF_OPTS += --enable-upnp
+else
+LINPHONE_CONF_OPTS += --disable-upnp
+endif
+
 $(eval $(autotools-package))