diff mbox series

axel: bump to version 2.16

Message ID 20171125044447.7188-1-ismael@iodev.co.uk
State Accepted
Headers show
Series axel: bump to version 2.16 | expand

Commit Message

Ismael Luceno Nov. 25, 2017, 4:44 a.m. UTC
- Change upstream URL.
- Add optional dependency on libressl/openssl.
- Switch to autotools-package.

Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>
---
 package/axel/Config.in |  2 +-
 package/axel/axel.hash |  3 +--
 package/axel/axel.mk   | 42 ++++++++++++++++++------------------------
 3 files changed, 20 insertions(+), 27 deletions(-)

Comments

Thomas Petazzoni Nov. 25, 2017, 12:23 p.m. UTC | #1
Hello,

On Sat, 25 Nov 2017 01:44:47 -0300, Ismael Luceno wrote:
> - Change upstream URL.
> - Add optional dependency on libressl/openssl.
> - Switch to autotools-package.
> 
> Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>

I've applied to next, but now that I review the patch again, I see a
problem, see below.

> +ifeq ($(BR2_PACKAGE_LIBRESSL),y)
> +AXEL_CONF_OPTS += --with-ssl
> +AXEL_DEPENDENCIES += libressl

This is not needed, because the below case with BR2_PACKAGE_OPENSSL is
sufficient. Indeed openssl is not a virtual package, that depends
either on libopenssl or libressl depending on which implementation is
selected.

> +else ifeq ($(BR2_PACKAGE_OPENSSL),y)
> +AXEL_CONF_OPTS += --with-ssl
> +AXEL_DEPENDENCIES += openssl

Could you send a follow-up patch (based on the next branch) that fixes
this?

Thanks!

Thomas
Thomas Petazzoni Dec. 4, 2017, 8:14 a.m. UTC | #2
Hello,

On Sat, 25 Nov 2017 01:44:47 -0300, Ismael Luceno wrote:
> - Change upstream URL.
> - Add optional dependency on libressl/openssl.
> - Switch to autotools-package.
> 
> Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>

This update broke the build:

  http://autobuild.buildroot.net/?reason=axel-2.16

Could you look into it? Thanks a lot!

Thomas
Ismael Luceno Dec. 4, 2017, 7:04 p.m. UTC | #3
On 04/Dec/2017 09:14, Thomas Petazzoni wrote:
> Hello,
> 
> On Sat, 25 Nov 2017 01:44:47 -0300, Ismael Luceno wrote:
> > - Change upstream URL.
> > - Add optional dependency on libressl/openssl.
> > - Switch to autotools-package.
> > 
> > Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>
> 
> This update broke the build:
> 
>   http://autobuild.buildroot.net/?reason=axel-2.16
> 
> Could you look into it? Thanks a lot!

I'm going to release 2.16.1, probably tomorrow, fixing the issue. I
apologize for the delay, but I'm a little bit overloaded right now with
other stuff.
diff mbox series

Patch

diff --git a/package/axel/Config.in b/package/axel/Config.in
index 6e709cfb1351..4507855ff8e7 100644
--- a/package/axel/Config.in
+++ b/package/axel/Config.in
@@ -4,7 +4,7 @@  config BR2_PACKAGE_AXEL
 	help
 	  HTTP/FTP download accelerator.
 
-	  http://axel.alioth.debian.org/
+	  https://github.com/axel-download-accelerator/axel/
 
 comment "axel needs a toolchain w/ threads"
 	depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/axel/axel.hash b/package/axel/axel.hash
index 895767011892..1fc1c55ae07d 100644
--- a/package/axel/axel.hash
+++ b/package/axel/axel.hash
@@ -1,2 +1 @@ 
-# Locally calculated
-sha256	359a57ab4e354bcb6075430d977c59d33eb3e2f1415a811948fa8ae657ca8036  axel-2.4.tar.gz
+sha256 bd65f8d8add34ab61ce1fb9e1c7b1c3449b1cfd981ce48aeee218e755ba0d6fb  axel-2.16.tar.xz
diff --git a/package/axel/axel.mk b/package/axel/axel.mk
index 60bf5e4a61df..dcc8afd0b4a0 100644
--- a/package/axel/axel.mk
+++ b/package/axel/axel.mk
@@ -4,33 +4,27 @@ 
 #
 ################################################################################
 
-AXEL_VERSION = 2.4
-AXEL_SITE = http://sources.buildroot.net
+AXEL_VERSION = 2.16
+AXEL_SITE = https://github.com/axel-download-accelerator/axel/releases/download/v$(AXEL_VERSION)
+AXEL_SOURCE = axel-$(AXEL_VERSION).tar.xz
 AXEL_LICENSE = GPL-2.0+
 AXEL_LICENSE_FILES = COPYING
 AXEL_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
-AXEL_LDFLAGS = -lpthread $(TARGET_NLS_LIBS)
 
-ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
-AXEL_DISABLE_I18N = --i18n=0
-endif
-
-define AXEL_CONFIGURE_CMDS
-	(cd $(@D); \
-		./configure \
-			--prefix=/usr \
-			--debug=1 \
-			$(AXEL_DISABLE_I18N) \
-	)
-endef
+# ac_cv_prog_cc_c99 is required for BR2_USE_WCHAR=n because the C99 test
+# provided by autoconf relies on wchar_t.
+AXEL_CONF_OPTS = \
+	ac_cv_prog_cc_c99=-std=c99 \
+	CFLAGS="$(TARGET_CFLAGS)"
 
-define AXEL_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
-	LFLAGS="$(TARGET_LDFLAGS) $(AXEL_LDFLAGS)" -C $(@D)
-endef
-
-define AXEL_INSTALL_TARGET_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
-endef
+ifeq ($(BR2_PACKAGE_LIBRESSL),y)
+AXEL_CONF_OPTS += --with-ssl
+AXEL_DEPENDENCIES += libressl
+else ifeq ($(BR2_PACKAGE_OPENSSL),y)
+AXEL_CONF_OPTS += --with-ssl
+AXEL_DEPENDENCIES += openssl
+else
+AXEL_CONF_OPTS += --without-ssl
+endif
 
-$(eval $(generic-package))
+$(eval $(autotools-package))