diff mbox series

[v2,2/2] sdl2: Add KMS/DRM(experimental) video driver support

Message ID 20171001184601.30620-2-olivier.schonken@gmail.com
State Accepted
Headers show
Series [v2,1/2] sdl2: Bump version to 2.0.6 | expand

Commit Message

Olivier Schonken Oct. 1, 2017, 6:46 p.m. UTC
Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
---
Changes v1 -> v2:
	-Implementation stays same as other video drivers for now. If a cleanup
	 is required, that can be part of a larger effort touching other video
	 drivers as well.

20170926144723.17619-1-olivier.schonken@gmail.com
 package/sdl2/Config.in | 7 +++++++
 package/sdl2/sdl2.mk   | 7 +++++++
 2 files changed, 14 insertions(+)

Comments

Thomas Petazzoni Oct. 8, 2017, 1:47 p.m. UTC | #1
Hello,

On Sun,  1 Oct 2017 20:46:01 +0200, Olivier Schonken wrote:
> Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
> ---
> Changes v1 -> v2:
> 	-Implementation stays same as other video drivers for now. If a cleanup
> 	 is required, that can be part of a larger effort touching other video
> 	 drivers as well.

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/sdl2/Config.in b/package/sdl2/Config.in
index a2971edc89..f29b3c7c38 100644
--- a/package/sdl2/Config.in
+++ b/package/sdl2/Config.in
@@ -29,6 +29,13 @@  comment "X11 video driver needs X.org"
 	depends on !BR2_PACKAGE_XORG7
 	depends on BR2_USE_MMU
 
+config BR2_PACKAGE_SDL2_KMSDRM
+	bool "KMS/DRM video driver"
+	depends on BR2_PACKAGE_LIBDRM
+
+comment "KMS/DRM video driver needs libdrm"
+	depends on !BR2_PACKAGE_LIBDRM
+
 config BR2_PACKAGE_SDL2_OPENGL
 	bool "OpenGL (GLX)"
 	depends on BR2_PACKAGE_HAS_LIBGL
diff --git a/package/sdl2/sdl2.mk b/package/sdl2/sdl2.mk
index e64628d0cd..facb41e527 100644
--- a/package/sdl2/sdl2.mk
+++ b/package/sdl2/sdl2.mk
@@ -125,4 +125,11 @@  else
 SDL2_CONF_OPTS += --disable-alsa
 endif
 
+ifeq ($(BR2_PACKAGE_SDL2_KMSDRM),y)
+SDL2_DEPENDENCIES += libdrm
+SDL2_CONF_OPTS += --enable-video-kmsdrm
+else
+SDL2_CONF_OPTS += --disable-video-kmsdrm
+endif
+
 $(eval $(autotools-package))