diff mbox series

libmbim: add udev as optional feature

Message ID 20170906212809.18889-1-aleksander@aleksander.es
State Accepted
Headers show
Series libmbim: add udev as optional feature | expand

Commit Message

Aleksander Morgado Sept. 6, 2017, 9:28 p.m. UTC
udev support will be enabled in the build if libgudev is selected.

Signed-off-by: Aleksander Morgado <aleksander@aleksander.es>
---
 package/libmbim/Config.in  |  7 ++-----
 package/libmbim/libmbim.mk | 10 +++++++++-
 2 files changed, 11 insertions(+), 6 deletions(-)

Comments

Thomas Petazzoni Sept. 6, 2017, 9:47 p.m. UTC | #1
Hello,

On Wed,  6 Sep 2017 23:28:09 +0200, Aleksander Morgado wrote:
> udev support will be enabled in the build if libgudev is selected.
> 
> Signed-off-by: Aleksander Morgado <aleksander@aleksander.es>

Applied to master, thanks! I just realized you're the maintainer for
libmbim and libqmi, so it's nice to see you sending patches to
Buildroot to improve their packaging!

Thanks!

Thomas
Aleksander Morgado Sept. 7, 2017, 6:05 a.m. UTC | #2
> On Wed,  6 Sep 2017 23:28:09 +0200, Aleksander Morgado wrote:
>> udev support will be enabled in the build if libgudev is selected.
>>
>> Signed-off-by: Aleksander Morgado <aleksander@aleksander.es>
>
> Applied to master, thanks! I just realized you're the maintainer for
> libmbim and libqmi, so it's nice to see you sending patches to
> Buildroot to improve their packaging!
>

Speaking of which, is there any way I can get CC-ed to changes done in
either libqmi, libmbim or modem-manager? I wouldn't mind to review
those.
Baruch Siach Sept. 7, 2017, 7:01 a.m. UTC | #3
Hi Aleksander,

On Thu, Sep 07, 2017 at 08:05:32AM +0200, Aleksander Morgado wrote:
> > On Wed,  6 Sep 2017 23:28:09 +0200, Aleksander Morgado wrote:
> >> udev support will be enabled in the build if libgudev is selected.
> >>
> >> Signed-off-by: Aleksander Morgado <aleksander@aleksander.es>
> >
> > Applied to master, thanks! I just realized you're the maintainer for
> > libmbim and libqmi, so it's nice to see you sending patches to
> > Buildroot to improve their packaging!
> 
> Speaking of which, is there any way I can get CC-ed to changes done in
> either libqmi, libmbim or modem-manager? I wouldn't mind to review
> those.

Add an entry to DEVELOPERS listing the packages you are interested in.

baruch
Thomas Petazzoni Sept. 7, 2017, 7:04 a.m. UTC | #4
Hello,

On Thu, 7 Sep 2017 08:05:32 +0200, Aleksander Morgado wrote:

> Speaking of which, is there any way I can get CC-ed to changes done in
> either libqmi, libmbim or modem-manager? I wouldn't mind to review
> those.

Add yourself to the DEVELOPERS file for those packages. This way:

 * You will be Cc'ed when patches are sent,
   because ./utils/get-developers on patches touching those packages
   will return your e-mail address

 * You will be notified when http://autobuild.buildroot.org detects
   build failures for those packages.

If you're interested, just send a patch adding you to the DEVELOPERS
file.

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/package/libmbim/Config.in b/package/libmbim/Config.in
index 5db8efbf9..fd7dbb313 100644
--- a/package/libmbim/Config.in
+++ b/package/libmbim/Config.in
@@ -3,8 +3,6 @@  config BR2_PACKAGE_LIBMBIM
 	depends on BR2_USE_WCHAR # libglib2
 	depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
 	depends on BR2_USE_MMU # libglib2
-	depends on BR2_PACKAGE_HAS_UDEV
-	select BR2_PACKAGE_LIBGUDEV
 	select BR2_PACKAGE_LIBGLIB2
 	help
 	  libmbim is a glib-based library for talking to WWAN modems and
@@ -13,7 +11,6 @@  config BR2_PACKAGE_LIBMBIM
 
 	  http://www.freedesktop.org/wiki/Software/libmbim/
 
-comment "libmbim needs udev /dev management and a toolchain w/ wchar, threads"
+comment "libmbim needs a toolchain w/ wchar, threads"
 	depends on BR2_USE_MMU
-	depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
-		!BR2_PACKAGE_HAS_UDEV
+	depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libmbim/libmbim.mk b/package/libmbim/libmbim.mk
index 33e500e53..b8dfa832d 100644
--- a/package/libmbim/libmbim.mk
+++ b/package/libmbim/libmbim.mk
@@ -11,9 +11,17 @@  LIBMBIM_LICENSE = LGPL-2.0+ (library), GPL-2.0+ (programs)
 LIBMBIM_LICENSE_FILES = COPYING
 LIBMBIM_INSTALL_STAGING = YES
 
-LIBMBIM_DEPENDENCIES = libglib2 udev libgudev
+LIBMBIM_DEPENDENCIES = libglib2
 
 # we don't want -Werror
 LIBMBIM_CONF_OPTS = --enable-more-warnings=no
 
+# if libgudev available, request udev support
+ifeq ($(BR2_PACKAGE_LIBGUDEV),y)
+LIBMBIM_DEPENDENCIES += libgudev
+LIBMBIM_CONF_OPTS += --with-udev
+else
+LIBMBIM_CONF_OPTS += --without-udev
+endif
+
 $(eval $(autotools-package))