diff mbox

[3/3] mediastreamer: add dependency on host-vim

Message ID 20170821205516.20620-3-thomas.petazzoni@free-electrons.com
State Accepted
Headers show

Commit Message

Thomas Petazzoni Aug. 21, 2017, 8:55 p.m. UTC
host-vim is needed to provide the xxd tool, otherwise the build fails
with:

checking for xxd... no
configure: error: "xxd is required (provided by vim package)"

This isn't noticed by the autobuilders, presumably because all of them
have vim installed locally.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/mediastreamer/mediastreamer.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 25, 2017, 2:03 p.m. UTC | #1
Hello,

On Mon, 21 Aug 2017 22:55:16 +0200, Thomas Petazzoni wrote:
> host-vim is needed to provide the xxd tool, otherwise the build fails
> with:
> 
> checking for xxd... no
> configure: error: "xxd is required (provided by vim package)"
> 
> This isn't noticed by the autobuilders, presumably because all of them
> have vim installed locally.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
>  package/mediastreamer/mediastreamer.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Sept. 6, 2017, 10:27 a.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 > host-vim is needed to provide the xxd tool, otherwise the build fails
 > with:

 > checking for xxd... no
 > configure: error: "xxd is required (provided by vim package)"

 > This isn't noticed by the autobuilders, presumably because all of them
 > have vim installed locally.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

Committed to 2017.02.x, thanks.
diff mbox

Patch

diff --git a/package/mediastreamer/mediastreamer.mk b/package/mediastreamer/mediastreamer.mk
index 44d9e97..1276cfa 100644
--- a/package/mediastreamer/mediastreamer.mk
+++ b/package/mediastreamer/mediastreamer.mk
@@ -7,7 +7,8 @@ 
 MEDIASTREAMER_VERSION = 2.14.0
 MEDIASTREAMER_SITE = http://download.savannah.nongnu.org/releases/linphone/mediastreamer
 MEDIASTREAMER_INSTALL_STAGING = YES
-MEDIASTREAMER_DEPENDENCIES = host-intltool host-pkgconf ortp host-gettext
+# host-vim needed for the xxd utility
+MEDIASTREAMER_DEPENDENCIES = host-intltool host-pkgconf ortp host-gettext host-vim
 # tests fail linking on some architectures, so disable them
 MEDIASTREAMER_CONF_OPTS = --disable-tests --disable-glx --disable-strict
 MEDIASTREAMER_LICENSE = GPL-2.0+