diff mbox

[013/100] avahi: use new gettext logic

Message ID 20170704144920.12318-14-thomas.petazzoni@free-electrons.com
State Accepted
Headers show

Commit Message

Thomas Petazzoni July 4, 2017, 2:47 p.m. UTC
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/avahi/Config.in | 1 -
 package/avahi/avahi.mk  | 6 +++---
 2 files changed, 3 insertions(+), 4 deletions(-)

Comments

Arnout Vandecappelle July 4, 2017, 3:33 p.m. UTC | #1
On 04-07-17 16:47, Thomas Petazzoni wrote:
> This commit switches to use the new gettext logic, which involves:
> 
>  - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
>    on gettext/host-gettext
> 
>  - using TARGET_NLS_LIBS to force linking against libintl
> 
>  - dropping BR2_PACKAGE_GETTEXT selection
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 Regards,
 Arnout


> ---
>  package/avahi/Config.in | 1 -
>  package/avahi/avahi.mk  | 6 +++---
>  2 files changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/package/avahi/Config.in b/package/avahi/Config.in
> index a6b4ac8..5e303d0 100644
> --- a/package/avahi/Config.in
> +++ b/package/avahi/Config.in
> @@ -4,7 +4,6 @@ config BR2_PACKAGE_AVAHI
>  	depends on BR2_USE_MMU
>  	depends on BR2_TOOLCHAIN_HAS_THREADS
>  	depends on !BR2_STATIC_LIBS
> -	select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
>  	help
>  	  Avahi is a system which facilitates service
>  	  discovery on a local network.
> diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
> index a356a08..94b6292 100644
> --- a/package/avahi/avahi.mk
> +++ b/package/avahi/avahi.mk
> @@ -97,8 +97,8 @@ AVAHI_CONF_OPTS = \
>  	--with-autoipd-group=avahi
>  
>  AVAHI_DEPENDENCIES = \
> -	$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-intltool \
> -	host-pkgconf host-gettext
> +	host-intltool host-pkgconf \
> +	$(TARGET_NLS_DEPENDENCIES)
>  
>  AVAHI_CFLAGS = $(TARGET_CFLAGS)
>  
> @@ -168,7 +168,7 @@ endif
>  
>  AVAHI_CONF_ENV += CFLAGS="$(AVAHI_CFLAGS)"
>  
> -AVAHI_MAKE_OPTS += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),LIBS=-lintl)
> +AVAHI_MAKE_OPTS += LIBS=$(TARGET_NLS_LIBS)
>  
>  define AVAHI_USERS
>  	avahi -1 avahi -1 * - - -
>
diff mbox

Patch

diff --git a/package/avahi/Config.in b/package/avahi/Config.in
index a6b4ac8..5e303d0 100644
--- a/package/avahi/Config.in
+++ b/package/avahi/Config.in
@@ -4,7 +4,6 @@  config BR2_PACKAGE_AVAHI
 	depends on BR2_USE_MMU
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	depends on !BR2_STATIC_LIBS
-	select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
 	help
 	  Avahi is a system which facilitates service
 	  discovery on a local network.
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index a356a08..94b6292 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -97,8 +97,8 @@  AVAHI_CONF_OPTS = \
 	--with-autoipd-group=avahi
 
 AVAHI_DEPENDENCIES = \
-	$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-intltool \
-	host-pkgconf host-gettext
+	host-intltool host-pkgconf \
+	$(TARGET_NLS_DEPENDENCIES)
 
 AVAHI_CFLAGS = $(TARGET_CFLAGS)
 
@@ -168,7 +168,7 @@  endif
 
 AVAHI_CONF_ENV += CFLAGS="$(AVAHI_CFLAGS)"
 
-AVAHI_MAKE_OPTS += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),LIBS=-lintl)
+AVAHI_MAKE_OPTS += LIBS=$(TARGET_NLS_LIBS)
 
 define AVAHI_USERS
 	avahi -1 avahi -1 * - - -