diff mbox

python-crossbar: add a warning comment concerning version bump

Message ID 20170302135853.3111-1-yegorslists@googlemail.com
State Accepted
Headers show

Commit Message

Yegor Yefremov March 2, 2017, 1:58 p.m. UTC
From: Yegor Yefremov <yegorslists@googlemail.com>

The latest crossbar needs a rather recent setuptools package, that
has circular dependencies. Until this issue is not resolved, it is
not safe to bump crossbar version.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
---
 package/python-crossbar/python-crossbar.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Thomas Petazzoni March 2, 2017, 9:23 p.m. UTC | #1
Hello,

On Thu,  2 Mar 2017 14:58:53 +0100, yegorslists@googlemail.com wrote:
> From: Yegor Yefremov <yegorslists@googlemail.com>
> 
> The latest crossbar needs a rather recent setuptools package, that
> has circular dependencies. Until this issue is not resolved, it is
> not safe to bump crossbar version.
> 
> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> ---
>  package/python-crossbar/python-crossbar.mk | 2 ++
>  1 file changed, 2 insertions(+)

Applied to master, thanks.

Thomas
Yann E. MORIN Dec. 30, 2017, 10:28 a.m. UTC | #2
Yegor, All,

On 2017-03-02 14:58 +0100, yegorslists@googlemail.com spake thusly:
> From: Yegor Yefremov <yegorslists@googlemail.com>
> 
> The latest crossbar needs a rather recent setuptools package, that
> has circular dependencies. Until this issue is not resolved, it is
> not safe to bump crossbar version.
> 
> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> ---
>  package/python-crossbar/python-crossbar.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/python-crossbar/python-crossbar.mk b/package/python-crossbar/python-crossbar.mk
> index 3d82d7704..9c543e6cc 100644
> --- a/package/python-crossbar/python-crossbar.mk
> +++ b/package/python-crossbar/python-crossbar.mk
> @@ -4,6 +4,8 @@
>  #
>  ################################################################################
>  
> +# don't bump version as newer setuptools package is needed,
> +# that still didn't make its way into BR

Now that we are using setup-tools 36.0.1, is this comment still valid?

Regards,
Yann E. MORIN.

>  PYTHON_CROSSBAR_VERSION = 0.14.0
>  PYTHON_CROSSBAR_SOURCE = crossbar-$(PYTHON_CROSSBAR_VERSION).tar.gz
>  PYTHON_CROSSBAR_SITE = https://pypi.python.org/packages/f0/9a/e0b77e15698c47b6293655bc0e1996dd8e87bd8af7bc7434a5c8281a024e
> -- 
> 2.11.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Yegor Yefremov Dec. 30, 2017, 10:33 a.m. UTC | #3
Yann,

On Sat, Dec 30, 2017 at 11:28 AM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> Yegor, All,
>
> On 2017-03-02 14:58 +0100, yegorslists@googlemail.com spake thusly:
>> From: Yegor Yefremov <yegorslists@googlemail.com>
>>
>> The latest crossbar needs a rather recent setuptools package, that
>> has circular dependencies. Until this issue is not resolved, it is
>> not safe to bump crossbar version.
>>
>> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
>> ---
>>  package/python-crossbar/python-crossbar.mk | 2 ++
>>  1 file changed, 2 insertions(+)
>>
>> diff --git a/package/python-crossbar/python-crossbar.mk b/package/python-crossbar/python-crossbar.mk
>> index 3d82d7704..9c543e6cc 100644
>> --- a/package/python-crossbar/python-crossbar.mk
>> +++ b/package/python-crossbar/python-crossbar.mk
>> @@ -4,6 +4,8 @@
>>  #
>>  ################################################################################
>>
>> +# don't bump version as newer setuptools package is needed,
>> +# that still didn't make its way into BR
>
> Now that we are using setup-tools 36.0.1, is this comment still valid?

I'll have to check this and bump to the newest version.

Yegor
diff mbox

Patch

diff --git a/package/python-crossbar/python-crossbar.mk b/package/python-crossbar/python-crossbar.mk
index 3d82d7704..9c543e6cc 100644
--- a/package/python-crossbar/python-crossbar.mk
+++ b/package/python-crossbar/python-crossbar.mk
@@ -4,6 +4,8 @@ 
 #
 ################################################################################
 
+# don't bump version as newer setuptools package is needed,
+# that still didn't make its way into BR
 PYTHON_CROSSBAR_VERSION = 0.14.0
 PYTHON_CROSSBAR_SOURCE = crossbar-$(PYTHON_CROSSBAR_VERSION).tar.gz
 PYTHON_CROSSBAR_SITE = https://pypi.python.org/packages/f0/9a/e0b77e15698c47b6293655bc0e1996dd8e87bd8af7bc7434a5c8281a024e