diff mbox

gcc: the special workaround for ARC is no longer required

Message ID 20161123112016.GA29549@waldemar-brodkorb.de
State Accepted
Headers show

Commit Message

Waldemar Brodkorb Nov. 23, 2016, 11:20 a.m. UTC
It seems with the change to gcc 6.x based toolchain this
workaround is no longer required. Tested with an arc hs toolchain.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 package/gcc/gcc-initial/gcc-initial.mk | 13 -------------
 1 file changed, 13 deletions(-)

Comments

Alexey Brodkin Nov. 23, 2016, 3:50 p.m. UTC | #1
Hi Waldemar,

On Wed, 2016-11-23 at 12:20 +0100, Waldemar Brodkorb wrote:
> It seems with the change to gcc 6.x based toolchain this

> workaround is no longer required. Tested with an arc hs toolchain.

> 

> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>

> ---


Nice catch!

Indeed since https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/commit/80a9c1591ccce130ced8ee4581efacd55ba0a81e
there's no libgmon building for ARC in gcc.

But unfortunately that's one of very few patches that were not yet merged
in upstream gcc. That said if anybody attempts to build toolchain for ARC
right out of upstream GCC the code in question will be required.

But given the fact we're not ready to switch to upstream GCC ATM
your change is very much appreciated so

Acked-by: Alexey Brodkin <abrodkin@synopsys.com>
Thomas Petazzoni Nov. 23, 2016, 10:17 p.m. UTC | #2
Hello,

On Wed, 23 Nov 2016 12:20:16 +0100, Waldemar Brodkorb wrote:
> It seems with the change to gcc 6.x based toolchain this
> workaround is no longer required. Tested with an arc hs toolchain.
> 
> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
> ---
>  package/gcc/gcc-initial/gcc-initial.mk | 13 -------------
>  1 file changed, 13 deletions(-)

Applied to next, thanks.

Thomas
diff mbox

Patch

diff --git a/package/gcc/gcc-initial/gcc-initial.mk b/package/gcc/gcc-initial/gcc-initial.mk
index 7bb988b..a51e29c 100644
--- a/package/gcc/gcc-initial/gcc-initial.mk
+++ b/package/gcc/gcc-initial/gcc-initial.mk
@@ -25,19 +25,6 @@  HOST_GCC_INITIAL_SUBDIR = build
 
 HOST_GCC_INITIAL_PRE_CONFIGURE_HOOKS += HOST_GCC_CONFIGURE_SYMLINK
 
-# gcc on ARC has a bug: in its libgcc, even when no C library is
-# available (--with-newlib is passed, and therefore inhibit_libc is
-# defined), it tries to use the C library for the libgmon
-# library. Since it's not needed in gcc-initial, we disabled it here.
-ifeq ($(BR2_GCC_VERSION_ARC),y)
-define HOST_GCC_INITIAL_DISABLE_LIBGMON
-	$(SED) 's/crtbeginS.o libgmon.a crtg.o/crtbeginS.o crtg.o/' \
-		$(@D)/libgcc/config.host
-endef
-HOST_GCC_INITIAL_POST_PATCH_HOOKS += HOST_GCC_INITIAL_DISABLE_LIBGMON
-HOST_GCC_INITIAL_POST_RSYNC_HOOKS += HOST_GCC_INITIAL_DISABLE_LIBGMON
-endif
-
 HOST_GCC_INITIAL_CONF_OPTS = \
 	$(HOST_GCC_COMMON_CONF_OPTS) \
 	--enable-languages=c \