diff mbox

Makefile: fix ignored trace at target-finalize

Message ID 20161122205333.9735-1-gael.portay@savoirfairelinux.com
State Accepted
Headers show

Commit Message

Gaël PORTAY Nov. 22, 2016, 8:53 p.m. UTC
Make may throw an error (but ignored) trace when cleaning up the
rootfs.

The target-finalize rule intends to remove the folder
`$(TARGET_DIR)/usr/share' but this directory may still contain items
(such as the `udhcpc' helper script) and causes the rmdir to fail.

The stderr output is redirected to /dev/null but it returns and error
which is escaped by the leading `-'; but make reports an ignored-error.

See the log below:
$ make
(...)
rm -rf (...)/target/usr/share/gtk-doc
rmdir (...)/target/usr/share
rmdir: failed to remove '(...)/target/usr/share': Directory not empty
make[1]: [Makefile:650: target-finalize] Error 1 (ignored)
find /(...)/target -type f \( -perm /111 -o -name '*.so*' \) -not \( -name 'libpthread*.so*' -o -name 'ld-*.so*' -o -name '*.ko' \) -print0 | xargs -0 (...)/host/usr/bin/arm-buildroot-linux-uclibcgnueabihf-strip --remove-section=.comment --remove-section=.note 2>/dev/null || true

This patch apply the same rule at the instruction immediately after:
* redirecting stderr to /dev/null (already done) and
* executing true if the `rmdir' instruction fails.

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN Nov. 22, 2016, 9:33 p.m. UTC | #1
Ga"el, All,

On 2016-11-22 15:53 -0500, Gaël PORTAY spake thusly:
> Make may throw an error (but ignored) trace when cleaning up the
> rootfs.
> 
> The target-finalize rule intends to remove the folder
> `$(TARGET_DIR)/usr/share' but this directory may still contain items
> (such as the `udhcpc' helper script) and causes the rmdir to fail.
> 
> The stderr output is redirected to /dev/null but it returns and error
> which is escaped by the leading `-'; but make reports an ignored-error.
> 
> See the log below:
> $ make
> (...)
> rm -rf (...)/target/usr/share/gtk-doc
> rmdir (...)/target/usr/share
> rmdir: failed to remove '(...)/target/usr/share': Directory not empty
> make[1]: [Makefile:650: target-finalize] Error 1 (ignored)
> find /(...)/target -type f \( -perm /111 -o -name '*.so*' \) -not \( -name 'libpthread*.so*' -o -name 'ld-*.so*' -o -name '*.ko' \) -print0 | xargs -0 (...)/host/usr/bin/arm-buildroot-linux-uclibcgnueabihf-strip --remove-section=.comment --remove-section=.note 2>/dev/null || true
> 
> This patch apply the same rule at the instruction immediately after:
> * redirecting stderr to /dev/null (already done) and
> * executing true if the `rmdir' instruction fails.
> 
> Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/Makefile b/Makefile
> index 37e4bd4..7f162e2 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -656,7 +656,7 @@ endif
>  	rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
>  	rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc
>  	rm -rf $(TARGET_DIR)/usr/share/gtk-doc
> -	-rmdir $(TARGET_DIR)/usr/share 2>/dev/null
> +	rmdir $(TARGET_DIR)/usr/share 2>/dev/null || true
>  	$(STRIP_FIND_CMD) | xargs -0 $(STRIPCMD) 2>/dev/null || true
>  
>  # See http://sourceware.org/gdb/wiki/FAQ, "GDB does not see any threads
> -- 
> 2.10.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni Nov. 23, 2016, 8:24 a.m. UTC | #2
Hello,

On Tue, 22 Nov 2016 15:53:33 -0500, Gaël PORTAY wrote:
> Make may throw an error (but ignored) trace when cleaning up the
> rootfs.
> 
> The target-finalize rule intends to remove the folder
> `$(TARGET_DIR)/usr/share' but this directory may still contain items
> (such as the `udhcpc' helper script) and causes the rmdir to fail.
> 
> The stderr output is redirected to /dev/null but it returns and error
> which is escaped by the leading `-'; but make reports an ignored-error.

Ah, what is the problem with that? Just the fact that there is this
"Error 1 (ignored)" message?

Thomas
Gaël PORTAY Nov. 23, 2016, 2:30 p.m. UTC | #3
Thomas,

On Wed, Nov 23, 2016 at 09:24:36AM +0100, Thomas Petazzoni wrote:
> Ah, what is the problem with that? Just the fact that there is this
> "Error 1 (ignored)" message?
> 

Yes, just a nitpick.

There is absolutly no error: simply the trace. Error when things are `ok'. 

Also to be more consistent with what is applied at the next line:
stderr + || true.
Thomas Petazzoni Nov. 23, 2016, 10:22 p.m. UTC | #4
Hello,

On Tue, 22 Nov 2016 15:53:33 -0500, Gaël PORTAY wrote:
> Make may throw an error (but ignored) trace when cleaning up the
> rootfs.
> 
> The target-finalize rule intends to remove the folder
> `$(TARGET_DIR)/usr/share' but this directory may still contain items
> (such as the `udhcpc' helper script) and causes the rmdir to fail.
> 
> The stderr output is redirected to /dev/null but it returns and error
> which is escaped by the leading `-'; but make reports an ignored-error.
> 
> See the log below:
> $ make
> (...)
> rm -rf (...)/target/usr/share/gtk-doc
> rmdir (...)/target/usr/share
> rmdir: failed to remove '(...)/target/usr/share': Directory not empty
> make[1]: [Makefile:650: target-finalize] Error 1 (ignored)
> find /(...)/target -type f \( -perm /111 -o -name '*.so*' \) -not \( -name 'libpthread*.so*' -o -name 'ld-*.so*' -o -name '*.ko' \) -print0 | xargs -0 (...)/host/usr/bin/arm-buildroot-linux-uclibcgnueabihf-strip --remove-section=.comment --remove-section=.note 2>/dev/null || true
> 
> This patch apply the same rule at the instruction immediately after:
> * redirecting stderr to /dev/null (already done) and
> * executing true if the `rmdir' instruction fails.
> 
> Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
> ---
>  Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to next, thanks.

Thomas
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 37e4bd4..7f162e2 100644
--- a/Makefile
+++ b/Makefile
@@ -656,7 +656,7 @@  endif
 	rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
 	rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc
 	rm -rf $(TARGET_DIR)/usr/share/gtk-doc
-	-rmdir $(TARGET_DIR)/usr/share 2>/dev/null
+	rmdir $(TARGET_DIR)/usr/share 2>/dev/null || true
 	$(STRIP_FIND_CMD) | xargs -0 $(STRIPCMD) 2>/dev/null || true
 
 # See http://sourceware.org/gdb/wiki/FAQ, "GDB does not see any threads