diff mbox

[for-next] Makefile: delete default rules

Message ID 20161105210508.7930-1-arnout@mind.be
State Accepted
Headers show

Commit Message

Arnout Vandecappelle Nov. 5, 2016, 9:05 p.m. UTC
We don't use the default implicit rules that are added by make, so
they just slow down the Makefile processing. The default implicit
rules can be removed by defining an empty .SUFFIXES: target.

This speeds up the start of the build on my machine from 5.6s to
4.9s.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 Makefile | 3 +++
 1 file changed, 3 insertions(+)

Comments

Thomas Petazzoni Nov. 5, 2016, 10:34 p.m. UTC | #1
Hello,

On Sat, 5 Nov 2016 22:05:08 +0100, Arnout Vandecappelle
(Essensium/Mind) wrote:
> We don't use the default implicit rules that are added by make, so
> they just slow down the Makefile processing. The default implicit
> rules can be removed by defining an empty .SUFFIXES: target.
> 
> This speeds up the start of the build on my machine from 5.6s to
> 4.9s.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
>  Makefile | 3 +++
>  1 file changed, 3 insertions(+)

Applied to next, thanks.

Thomas
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 4ea64b3..6cf5f1c 100644
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,9 @@ 
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
 
+# Delete default rules. We don't use them. This saves a bit of time.
+.SUFFIXES:
+
 # we want bash as shell
 SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
 	 else if [ -x /bin/bash ]; then echo /bin/bash; \