diff mbox

[1/2] core: don't reset MAKEOVERRIDES when re-entering make

Message ID 20161103015517.15943-1-arnout@mind.be
State Accepted
Headers show

Commit Message

Arnout Vandecappelle Nov. 3, 2016, 1:55 a.m. UTC
We reset MAKEOVERRIDES to avoid passing down variables that are
overridden on the command line to the package build systems. Indeed,
the variables overridden on the command line will be Buildroot
variables and not relevant to the package build system. In particular
the O option is used by some packages and the value passed in on the
command line is plain wrong for the individual package.

However, in commit 916e614b, MAKEOVERRIDES was moved earlier and it
was reset _before_ re-entering make in the cases when something has
to be fixed up (incorrect umask, non-absolute paths in O or CURDIR).
Therefore, if make is re-entered, any command line overrides are lost.

This particularly bites the autobuilders, because they use
O=<relative path> to specify the output directory, and they add
BR2_JLEVEL=... to avoid starting too many jobs in parallel. The
BR2_JLEVEL override is lost.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Cc: Samuel Martin <s.martin49@gmail.com>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
---
I have a little worry, because there are two other places where we re-
enter top-level make and those are not handled: silentoldconfig and
external-deps. BR2_JLEVEL is not relevant for those, but other command-
line overridden options may be. However, this hasn't changed from before
commit 916e614b so I guess it's OK.
---
 Makefile | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Comments

Samuel Martin Nov. 3, 2016, 7:48 a.m. UTC | #1
On Thu, Nov 3, 2016 at 2:55 AM, Arnout Vandecappelle (Essensium/Mind)
<arnout@mind.be> wrote:
> We reset MAKEOVERRIDES to avoid passing down variables that are
> overridden on the command line to the package build systems. Indeed,
> the variables overridden on the command line will be Buildroot
> variables and not relevant to the package build system. In particular
> the O option is used by some packages and the value passed in on the
> command line is plain wrong for the individual package.
>
> However, in commit 916e614b, MAKEOVERRIDES was moved earlier and it
> was reset _before_ re-entering make in the cases when something has
> to be fixed up (incorrect umask, non-absolute paths in O or CURDIR).
> Therefore, if make is re-entered, any command line overrides are lost.
>
> This particularly bites the autobuilders, because they use
> O=<relative path> to specify the output directory, and they add
> BR2_JLEVEL=... to avoid starting too many jobs in parallel. The
> BR2_JLEVEL override is lost.
>
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> Cc: Samuel Martin <s.martin49@gmail.com>
> Cc: Yann E. MORIN <yann.morin.1998@free.fr>
> ---
> I have a little worry, because there are two other places where we re-
> enter top-level make and those are not handled: silentoldconfig and
> external-deps. BR2_JLEVEL is not relevant for those, but other command-
> line overridden options may be. However, this hasn't changed from before
> commit 916e614b so I guess it's OK.


Reviewed-by: Samuel Martin <s.martin49@gmail.com>

Regards,
Maxime Hadjinlian Nov. 3, 2016, 5:58 p.m. UTC | #2
Tested-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>

On Thu, Nov 3, 2016 at 8:48 AM, Samuel Martin <s.martin49@gmail.com> wrote:
> On Thu, Nov 3, 2016 at 2:55 AM, Arnout Vandecappelle (Essensium/Mind)
> <arnout@mind.be> wrote:
>> We reset MAKEOVERRIDES to avoid passing down variables that are
>> overridden on the command line to the package build systems. Indeed,
>> the variables overridden on the command line will be Buildroot
>> variables and not relevant to the package build system. In particular
>> the O option is used by some packages and the value passed in on the
>> command line is plain wrong for the individual package.
>>
>> However, in commit 916e614b, MAKEOVERRIDES was moved earlier and it
>> was reset _before_ re-entering make in the cases when something has
>> to be fixed up (incorrect umask, non-absolute paths in O or CURDIR).
>> Therefore, if make is re-entered, any command line overrides are lost.
>>
>> This particularly bites the autobuilders, because they use
>> O=<relative path> to specify the output directory, and they add
>> BR2_JLEVEL=... to avoid starting too many jobs in parallel. The
>> BR2_JLEVEL override is lost.
>>
>> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
>> Cc: Samuel Martin <s.martin49@gmail.com>
>> Cc: Yann E. MORIN <yann.morin.1998@free.fr>
>> ---
>> I have a little worry, because there are two other places where we re-
>> enter top-level make and those are not handled: silentoldconfig and
>> external-deps. BR2_JLEVEL is not relevant for those, but other command-
>> line overridden options may be. However, this hasn't changed from before
>> commit 916e614b so I guess it's OK.
>
>
> Reviewed-by: Samuel Martin <s.martin49@gmail.com>
>
> Regards,
>
> --
> Samuel
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni Nov. 3, 2016, 8:49 p.m. UTC | #3
Hello,

On Thu, 3 Nov 2016 02:55:16 +0100, Arnout Vandecappelle
(Essensium/Mind) wrote:
> We reset MAKEOVERRIDES to avoid passing down variables that are
> overridden on the command line to the package build systems. Indeed,
> the variables overridden on the command line will be Buildroot
> variables and not relevant to the package build system. In particular
> the O option is used by some packages and the value passed in on the
> command line is plain wrong for the individual package.
> 
> However, in commit 916e614b, MAKEOVERRIDES was moved earlier and it
> was reset _before_ re-entering make in the cases when something has
> to be fixed up (incorrect umask, non-absolute paths in O or CURDIR).
> Therefore, if make is re-entered, any command line overrides are lost.
> 
> This particularly bites the autobuilders, because they use
> O=<relative path> to specify the output directory, and they add
> BR2_JLEVEL=... to avoid starting too many jobs in parallel. The
> BR2_JLEVEL override is lost.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> Cc: Samuel Martin <s.martin49@gmail.com>
> Cc: Yann E. MORIN <yann.morin.1998@free.fr>
> ---
> I have a little worry, because there are two other places where we re-
> enter top-level make and those are not handled: silentoldconfig and
> external-deps. BR2_JLEVEL is not relevant for those, but other command-
> line overridden options may be. However, this hasn't changed from before
> commit 916e614b so I guess it's OK.
> ---
>  Makefile | 12 +++++++-----
>  1 file changed, 7 insertions(+), 5 deletions(-)

Both applied, thanks!

Thomas
diff mbox

Patch

diff --git a/Makefile b/Makefile
index c00e200..4b494a3 100644
--- a/Makefile
+++ b/Makefile
@@ -35,11 +35,6 @@  SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
 ifneq ("$(origin O)", "command line")
 O := $(CURDIR)/output
 else
-# Other packages might also support Linux-style out of tree builds
-# with the O=<dir> syntax (E.G. BusyBox does). As make automatically
-# forwards command line variable definitions those packages get very
-# confused. Fix this by telling make to not do so.
-MAKEOVERRIDES :=
 # Strangely enough O is still passed to submakes with MAKEOVERRIDES
 # (with make 3.81 atleast), the only thing that changes is the output
 # of the origin function (command line -> environment).
@@ -155,6 +150,13 @@  else ifneq ($(filter-out $(nobuild_targets),$(MAKECMDGOALS)),)
 BR_BUILDING = y
 endif
 
+# We call make recursively to build packages. The command-line overrides that
+# are passed to Buildroot don't apply to those package build systems. In
+# particular, we don't want to pass down the O=<dir> option for out-of-tree
+# builds, because the value specified on the command line will not be correct
+# for packages.
+MAKEOVERRIDES :=
+
 # Include some helper macros and variables
 include support/misc/utils.mk