diff mbox

[2/2] enable amcodec if it is set in the config. based on the libreelec implementation.

Message ID 20160609074644.4976-2-daggs@gmx.com
State Superseded
Headers show

Commit Message

Dagg Stompler June 9, 2016, 7:46 a.m. UTC
Signed-off-by: Dagg Stompler <daggs@gmx.com>
---
 package/kodi/kodi.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Thomas Petazzoni June 9, 2016, 8:19 a.m. UTC | #1
Hello,

On Thu,  9 Jun 2016 10:46:44 +0300, Dagg Stompler wrote:
> Signed-off-by: Dagg Stompler <daggs@gmx.com>

The commit log should rather look like:

	kodi: enable optional dependency on libamcodec

	This is based on what LibreELEC is doing.

Indeed, the commit title should always have the form:

	<package>: <description>.

Thanks!

Thomas
Dagg Stompler June 9, 2016, 8:39 a.m. UTC | #2
Greetings,
> 
> On Thu,  9 Jun 2016 10:46:44 +0300, Dagg Stompler wrote:
> > Signed-off-by: Dagg Stompler <daggs@gmx.com>
> 
> The commit log should rather look like:
> 
> 	kodi: enable optional dependency on libamcodec
> 
> 	This is based on what LibreELEC is doing.
> 
> Indeed, the commit title should always have the form:
> 
> 	<package>: <description>.
> 
> Thanks!
> 

will resend.

Dagg.
diff mbox

Patch

diff --git a/package/kodi/kodi.mk b/package/kodi/kodi.mk
index e163c24..d0b2c22 100644
--- a/package/kodi/kodi.mk
+++ b/package/kodi/kodi.mk
@@ -56,6 +56,9 @@  endif
 ifeq ($(BR2_PACKAGE_LIBFSLVPUWRAP),y)
 KODI_DEPENDENCIES += libfslvpuwrap
 KODI_CONF_OPTS += --enable-codec=imxvpu
+else ifeq ($(BR2_PACKAGE_LIBAMCODEC),y)
+KODI_DEPENDENCIES += libamcodec
+KODI_CONF_OPTS += --enable-codec=amcodec
 endif
 
 ifeq ($(BR2_PACKAGE_LIBCAP),y)