diff mbox

toolchain: Allow ld64.so linker

Message ID 20131202172311.2641462e@kryten
State Accepted
Commit fb6dd8f49b28f16ca8114ec00d368ed8d0931329
Headers show

Commit Message

Anton Blanchard Dec. 2, 2013, 6:23 a.m. UTC
From: Jeremy Kerr <jk@ozlabs.org>
    
Expand the glibc dynamic linker check to allow ld64.so.
    
Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Signed-off-by: Anton Blanchard <anton@samba.org>
---

Comments

Thomas Petazzoni Dec. 2, 2013, 10:09 a.m. UTC | #1
Dear Anton Blanchard,

On Mon, 2 Dec 2013 17:23:11 +1100, Anton Blanchard wrote:
> From: Jeremy Kerr <jk@ozlabs.org>
>     
> Expand the glibc dynamic linker check to allow ld64.so.

Can you add to the commit log the specific toolchain/situation for
which this is needed? The external toolchain logic is full of special
cases, and I very often read the commit logs to find out why such or
such special case was added.

Thanks a lot!

Thomas
diff mbox

Patch

diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index a8944ce..faa9d90 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -204,7 +204,7 @@  check_glibc_rpc_feature = \
 #
 check_glibc = \
 	SYSROOT_DIR="$(strip $1)"; \
-	if test `find $${SYSROOT_DIR}/ -maxdepth 2 -name 'ld-linux*.so.*' -o -name 'ld.so.*' | wc -l` -eq 0 ; then \
+	if test `find $${SYSROOT_DIR}/ -maxdepth 2 -name 'ld-linux*.so.*' -o -name 'ld.so.*' -o -name 'ld64.so.*' | wc -l` -eq 0 ; then \
 		echo "Incorrect selection of the C library"; \
 		exit -1; \
 	fi; \