diff mbox

linux.mk: change linux tarball compression to xz

Message ID 20130510162239.GA8882@trismegisto.universo
State Superseded
Headers show

Commit Message

Raúl Sánchez Siles May 10, 2013, 4:22 p.m. UTC
Hi:

On Fri, May 10, 2013 at 10:51:48AM +0200, Jerzy Grzegorek wrote:
> After selecting BR2_LINUX_KERNEL or BR2_LINUX_KERNEL_CUSTOM_VERSION 
> configuration item, if any of linux tarball linux-$(LINUX_VERSION).tar.xx
> in local download tarball directory $(BR2_DL_DIR) exists, it used should be,
> otherwise *we* set the compression of linux tarball to download to xz.

  What about the one I'm attaching?

  Regards,

Comments

Thomas Petazzoni May 10, 2013, 4:27 p.m. UTC | #1
Dear Raúl Sánchez Siles,

On Fri, 10 May 2013 18:22:39 +0200, Raúl Sánchez Siles wrote:

> On Fri, May 10, 2013 at 10:51:48AM +0200, Jerzy Grzegorek wrote:
> > After selecting BR2_LINUX_KERNEL or BR2_LINUX_KERNEL_CUSTOM_VERSION 
> > configuration item, if any of linux tarball linux-$(LINUX_VERSION).tar.xx
> > in local download tarball directory $(BR2_DL_DIR) exists, it used should be,
> > otherwise *we* set the compression of linux tarball to download to xz.
> 
>   What about the one I'm attaching?

This one works if we're sure that all the 3.x and 2.6 versions of the
Linux kernel, as hosted on kernel.org, are available as .xz.

Looking at https://www.kernel.org/pub/linux/kernel/v2.6/ and
https://www.kernel.org/pub/linux/kernel/v3.x/ it indeed seems to be the
case, so looks like your patch should be go to go.

Could you resend your patch inline, with 'git send-email', so that it
can be reviewed and Acked-by other developers, and hopefully applied?

Thanks!

Thomas
diff mbox

Patch

Choose xz compressed tarball for linux kernel.

Signed-off-by: Raúl Sánchez Siles <rasasi78@gmail.com>
---
 linux/linux.mk                             |    2 +-
 toolchain/kernel-headers/kernel-headers.mk |    4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/linux/linux.mk b/linux/linux.mk
index d375cf0..3115564 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -16,7 +16,7 @@  else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_GIT),y)
 LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL))
 LINUX_SITE_METHOD = git
 else
-LINUX_SOURCE = linux-$(LINUX_VERSION).tar.bz2
+LINUX_SOURCE = linux-$(LINUX_VERSION).tar.xz
 # In X.Y.Z, get X and Y. We replace dots and dashes by spaces in order
 # to use the $(word) function. We support versions such as 3.1,
 # 2.6.32, 2.6.32-rc1, 3.0-rc6, etc.
diff --git a/toolchain/kernel-headers/kernel-headers.mk b/toolchain/kernel-headers/kernel-headers.mk
index adf7bc4..b5ae322 100644
--- a/toolchain/kernel-headers/kernel-headers.mk
+++ b/toolchain/kernel-headers/kernel-headers.mk
@@ -31,8 +31,8 @@  LINUX_HEADERS_SITE:=$(BR2_KERNEL_MIRROR:/=)/linux/kernel/v2.6/
 else
 LINUX_HEADERS_SITE:=$(BR2_KERNEL_MIRROR:/=)/linux/kernel/v3.x/
 endif
-LINUX_HEADERS_SOURCE:=linux-$(LINUX_HEADERS_VERSION).tar.bz2
-LINUX_HEADERS_CAT:=$(BZCAT)
+LINUX_HEADERS_SOURCE:=linux-$(LINUX_HEADERS_VERSION).tar.xz
+LINUX_HEADERS_CAT:=$(XZCAT)
 LINUX_HEADERS_UNPACK_DIR:=$(TOOLCHAIN_DIR)/linux-$(LINUX_HEADERS_VERSION)
 LINUX_HEADERS_DIR:=$(TOOLCHAIN_DIR)/linux
 
-- 
1.7.10.4