diff mbox

[2/2] ne10: Add aarch64 configuration option

Message ID 1493418486-109149-2-git-send-email-g4@novadsp.com
State Changes Requested
Headers show

Commit Message

J Evans April 28, 2017, 10:28 p.m. UTC
Signed-off-by: J Evans <g4@novadsp.com>
---
 package/ne10/ne10.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

J Evans April 29, 2017, noon UTC | #1
> -----Original Message-----
> From: buildroot [mailto:buildroot-bounces@busybox.net] On Behalf Of J
> Evans
> Sent: 28 April 2017 23:28
> To: buildroot@buildroot.org
> Cc: Thomas Petazzoni; J Evans
> Subject: [Buildroot] [PATCH 2/2] ne10: Add aarch64 configuration option
> 
> Signed-off-by: J Evans <g4@novadsp.com>

Apologies. This patch appears to be incomplete, please ignore. Whilst it
works fine for ARM64 the latest does not want to configure correctly for a
PI3 for example.

BR,

Jerry.
Thomas Petazzoni April 29, 2017, 12:09 p.m. UTC | #2
Hello,

On Fri, 28 Apr 2017 23:28:06 +0100, J Evans wrote:

> +ifeq ($(BR2_aarch64),y)
> +NE10_CONF_OPTS += \
> +    -DNE10_LINUX_TARGET_ARCH=aarch64
> +endif

PATCH 1/2 is already enabling ne10 on AArch64, so there's something
wrong going on here. This change should go with the patch enabling ne10
on AArch64.

But I believe you should in fact rework your patches:

 - One patch that just bumps ne10, keeping only the ARM support

 - One patch that refactors the architecture dependency with a
   Config.in hidden boolean BR2_PACKAGE_NE10_ARCH_SUPPORTS

 - One patch that allows to use ne10 on AArch64

Best regards,

Thomas
jerry@chordia.co.uk April 29, 2017, 12:43 p.m. UTC | #3
Hello,

> 
> But I believe you should in fact rework your patches:
> 
>  - One patch that just bumps ne10, keeping only the ARM support
> 
>  - One patch that refactors the architecture dependency with a
>    Config.in hidden boolean BR2_PACKAGE_NE10_ARCH_SUPPORTS
> 
>  - One patch that allows to use ne10 on AArch64

OK, I will do that.

BR

Jerry
diff mbox

Patch

diff --git a/package/ne10/ne10.mk b/package/ne10/ne10.mk
index 0da862c..b4611e8 100755
--- a/package/ne10/ne10.mk
+++ b/package/ne10/ne10.mk
@@ -17,6 +17,12 @@  NE10_CONF_OPTS += \
 	-DNE10_BUILD_SHARED=ON
 endif
 
+# 
+ifeq ($(BR2_aarch64),y)
+NE10_CONF_OPTS += \
+    -DNE10_LINUX_TARGET_ARCH=aarch64
+endif
+
 # The package does not have any install target, so have to provide
 # INSTALL_STAGING_CMDS and INSTALL_TARGET_CMDS.