diff mbox

[v2] Add out-of-source U-Boot device tree support

Message ID 1491363951-3971-1-git-send-email-james@balean.com.au
State Accepted
Headers show

Commit Message

James Balean April 5, 2017, 3:45 a.m. UTC
Similaly to Linux, this patch adds the ability to copy in and build
out-of-source device tree sources during a U-Boot build.

Signed-off-by: James Balean <james@balean.com.au>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
Changes for v2:
  - Added dependency on U-Boot Kconfig build system.
  - Code style cleanup

 boot/uboot/Config.in | 14 ++++++++++++++
 boot/uboot/uboot.mk  |  3 +++
 2 files changed, 17 insertions(+)

Comments

Thomas Petazzoni April 5, 2017, 8:30 p.m. UTC | #1
Hello,

On Tue,  4 Apr 2017 22:45:51 -0500, James Balean wrote:
> Similaly to Linux, this patch adds the ability to copy in and build
> out-of-source device tree sources during a U-Boot build.
> 
> Signed-off-by: James Balean <james@balean.com.au>
> Cc: Arnout Vandecappelle <arnout@mind.be>
> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
> Changes for v2:
>   - Added dependency on U-Boot Kconfig build system.
>   - Code style cleanup

Applied to master after slightly tweaking the help text and dropping a
needlessly added newline at the end of Config.in.

Thanks!

Thomas
diff mbox

Patch

diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index c33861b..ca94749 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -407,4 +407,18 @@  config BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT
 
 endif # BR2_TARGET_UBOOT_ENVIMAGE
 
+if BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG
+
+config BR2_TARGET_UBOOT_CUSTOM_DTS_PATH
+	string "Device Tree Source file paths"
+	help
+	  Path to the device tree source files. You can provide a list
+	  of dts paths to copy, separated by spaces.
+
+	  To use this device tree source file, the U-Boot configuration
+	  file must refer to it.
+
+endif
+
 endif # BR2_TARGET_UBOOT
+
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index aac692c..1d464d9 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -195,6 +195,9 @@  endef
 endif # BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY
 
 define UBOOT_BUILD_CMDS
+	$(if $(BR2_TARGET_UBOOT_CUSTOM_DTS_PATH),
+		cp -f $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_DTS_PATH)) $(@D)/arch/$(UBOOT_ARCH)/dts/
+	)
 	$(TARGET_CONFIGURE_OPTS) 	\
 		$(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) 		\
 		$(UBOOT_MAKE_TARGET)