diff mbox

[v1] motion: fix postgresql support

Message ID 1476734488-3436-1-git-send-email-ps.report@gmx.net
State Accepted
Headers show

Commit Message

Peter Seiderer Oct. 17, 2016, 8:01 p.m. UTC
The commandline paramter to enable/disable postgresql support is
called '--with-pgsql/--without-pgsql' and not '--with-postgresql/
--without-postgresql'.

Fixes [1] in case postgresql development files are installed on the host:

  checking for PostgreSQL... testing
  checking autodect pgsql headers... yes /usr/include/postgresql
  checking autodect pgsql libs... /usr/lib64
  checking for PQconnectStart in -lpq... no
  configure: error: PostgreSQL support can't build without PostgreSQL libraries

[1] http://autobuild.buildroot.net/results/749/7497730da2affffe0e5b9b790081de10c269f416

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/motion/motion.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Oct. 19, 2016, 9:38 p.m. UTC | #1
Hello,

On Mon, 17 Oct 2016 22:01:28 +0200, Peter Seiderer wrote:
> The commandline paramter to enable/disable postgresql support is
> called '--with-pgsql/--without-pgsql' and not '--with-postgresql/
> --without-postgresql'.
> 
> Fixes [1] in case postgresql development files are installed on the host:
> 
>   checking for PostgreSQL... testing
>   checking autodect pgsql headers... yes /usr/include/postgresql
>   checking autodect pgsql libs... /usr/lib64
>   checking for PQconnectStart in -lpq... no
>   configure: error: PostgreSQL support can't build without PostgreSQL libraries
> 
> [1] http://autobuild.buildroot.net/results/749/7497730da2affffe0e5b9b790081de10c269f416
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
>  package/motion/motion.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
diff mbox

Patch

diff --git a/package/motion/motion.mk b/package/motion/motion.mk
index de29a2a..1b80561 100644
--- a/package/motion/motion.mk
+++ b/package/motion/motion.mk
@@ -44,11 +44,11 @@  endif
 ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
 MOTION_DEPENDENCIES += postgresql
 MOTION_CONF_OPTS += \
-	--with-postgresql \
+	--with-pgsql \
 	--with-pgsql-include=$(STAGING_DIR)/usr/include \
 	--with-pgsql-lib=$(STAGING_DIR)/usr/lib
 else
-MOTION_CONF_OPTS += --without-postgresql
+MOTION_CONF_OPTS += --without-pgsql
 endif
 
 ifeq ($(BR2_PACKAGE_SDL),y)