diff mbox

[1/3] gdb: get rid of host-texinfo dependency

Message ID 1475870958-14790-1-git-send-email-patrickdepinguin@gmail.com
State Changes Requested
Headers show

Commit Message

Thomas De Schampheleire Oct. 7, 2016, 8:09 p.m. UTC
From: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

The host-texinfo dependency in gdb/host-gdb was added because gdb insisted
in building info documentation in recent versions, and we want to avoid
'makeinfo' to be present on the build system.

However, there is another solution that does not require actually building
host-texinfo: instruct the makefiles to use a dummy makeinfo command
('true').

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
---
 package/gdb/gdb.mk | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

Comments

Thomas Petazzoni Oct. 7, 2016, 8:40 p.m. UTC | #1
Hello,

On Fri,  7 Oct 2016 22:09:16 +0200, Thomas De Schampheleire wrote:
> +# Disable building documentation
> +GDB_MAKE_OPTS += MAKEINFO=true
> +GDB_INSTALL_OPTS += MAKEINFO=true

Setting GDB_INSTALL_OPTS doesn't do anything. There is no such variable
offered by the package infra: for target packages, you have
GDB_INSTALL_TARGET_OPTS and GDB_INSTALL_STAGING_OPTS.

So if it works without this, maybe it means that it is useless?

Best regards,

Thomas
Thomas De Schampheleire Oct. 8, 2016, 5:46 a.m. UTC | #2
On Oct 7, 2016 10:40 PM, "Thomas Petazzoni" <
thomas.petazzoni@free-electrons.com> wrote:
>
> Hello,
>
> On Fri,  7 Oct 2016 22:09:16 +0200, Thomas De Schampheleire wrote:
> > +# Disable building documentation
> > +GDB_MAKE_OPTS += MAKEINFO=true
> > +GDB_INSTALL_OPTS += MAKEINFO=true
>
> Setting GDB_INSTALL_OPTS doesn't do anything. There is no such variable
> offered by the package infra: for target packages, you have
> GDB_INSTALL_TARGET_OPTS and GDB_INSTALL_STAGING_OPTS.

Right, at some point I realized that but forgot to change it.

>
> So if it works without this, maybe it means that it is useless?

No, I think it will be necessary for some combinations, for target-gdb I
did not test all.
Remember, gdb and host-gdb are essentially built the same, they have the
same makefiles. So I think that the tricks used for host-gdb need to be
symmetrical with target-gdb.

I'll update the patch.

Thanks,
Thomas
diff mbox

Patch

diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index 1c778e9..b54d232 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -37,12 +37,11 @@  endif
 # also need ncurses.
 HOST_GDB_DEPENDENCIES = host-expat host-ncurses
 
-# Starting with gdb 7.10, gdb wants to re-generate its documentation.
-# We were trying to avoid that by patching the Makefiles, but it wasn't
-# working in all situations. So, we simply add a dependency on
-# host-texinfo in all case.
-GDB_DEPENDENCIES += host-texinfo
-HOST_GDB_DEPENDENCIES += host-texinfo
+# Disable building documentation
+GDB_MAKE_OPTS += MAKEINFO=true
+GDB_INSTALL_OPTS += MAKEINFO=true
+HOST_GDB_MAKE_OPTS += MAKEINFO=true
+HOST_GDB_INSTALL_OPTS += MAKEINFO=true
 
 # Apply the Xtensa specific patches
 XTENSA_CORE_NAME = $(call qstrip, $(BR2_XTENSA_CORE_NAME))