diff mbox

pugixml: new package

Message ID 1473262627-14429-2-git-send-email-theo.debrouwere@skynet.be
State Accepted
Commit 27071be0d8c648a6f7ec314c29f5b3a033e1208a
Headers show

Commit Message

Theo Debrouwere Sept. 7, 2016, 3:37 p.m. UTC
From: Theo Debrouwere <t.debrouwere@televic.com>

pugixml is a light-weight C++ XML processing library. It features:
* DOM-like interface with rich traversal/modification capabilities
* Extremely fast non-validating XML parser which constructs the DOM tree from an XML file/buffer
* XPath 1.0 implementation for complex data-driven tree queries
* Full Unicode support with Unicode interface variants and automatic encoding conversions

Homepage: http://pugixml.org/
Repository: https://github.com/zeux/pugixml

Signed-off-by: Theo Debrouwere <t.debrouwere@televic.com>
---
 package/Config.in            |  1 +
 package/pugixml/Config.in    | 16 ++++++++++++++++
 package/pugixml/pugixml.hash |  2 ++
 package/pugixml/pugixml.mk   | 15 +++++++++++++++
 4 files changed, 34 insertions(+)
 create mode 100644 package/pugixml/Config.in
 create mode 100644 package/pugixml/pugixml.hash
 create mode 100644 package/pugixml/pugixml.mk

Comments

Peter Korsgaard Sept. 7, 2016, 7:44 p.m. UTC | #1
>>>>> "Theo" == Theo Debrouwere <theo.debrouwere@skynet.be> writes:

 > From: Theo Debrouwere <t.debrouwere@televic.com>
 > pugixml is a light-weight C++ XML processing library. It features:
 > * DOM-like interface with rich traversal/modification capabilities
 > * Extremely fast non-validating XML parser which constructs the DOM tree from an XML file/buffer
 > * XPath 1.0 implementation for complex data-driven tree queries
 > * Full Unicode support with Unicode interface variants and automatic encoding conversions

 > Homepage: http://pugixml.org/
 > Repository: https://github.com/zeux/pugixml

 > Signed-off-by: Theo Debrouwere <t.debrouwere@televic.com>

Committed, thanks.
Thomas Petazzoni Sept. 11, 2016, 9:08 p.m. UTC | #2
Hello,

On Wed,  7 Sep 2016 17:37:07 +0200, Theo Debrouwere wrote:
> From: Theo Debrouwere <t.debrouwere@televic.com>
> 
> pugixml is a light-weight C++ XML processing library. It features:
> * DOM-like interface with rich traversal/modification capabilities
> * Extremely fast non-validating XML parser which constructs the DOM tree from an XML file/buffer
> * XPath 1.0 implementation for complex data-driven tree queries
> * Full Unicode support with Unicode interface variants and automatic encoding conversions
> 
> Homepage: http://pugixml.org/
> Repository: https://github.com/zeux/pugixml
> 
> Signed-off-by: Theo Debrouwere <t.debrouwere@televic.com>

This new package is causing a number of build failures. See:

  http://autobuild.buildroot.net/?reason=pugixml-1.7

Could you have a look?

Thanks,

Thomas
Theo Debrouwere Sept. 11, 2016, 9:56 p.m. UTC | #3
Hello,

> This new package is causing a number of build failures. See:
>
>   http://autobuild.buildroot.net/?reason=pugixml-1.7
>
> Could you have a look?


The bfin issues seems to be caused by a fault in the CMakelist.txt file.
Which seems to have been solved in the upstream git repo.
I will test the fix & verify that it solves the issue.

If it does, I'll provide the fix as a patch on 1.7, unless you/someone
else prefers bumping to an unreleased git commit.


The arc issue: the compiler complains about an internal error.
I'm not sure if this is a pugimxl issue, but I'll reproduce it
tomorrow. (currently building bfin)



Theo
Arnout Vandecappelle Sept. 11, 2016, 10:15 p.m. UTC | #4
On 11-09-16 23:56, Theo Debrouwere wrote:
> Hello,
> 
>> This new package is causing a number of build failures. See:
>>
>>   http://autobuild.buildroot.net/?reason=pugixml-1.7
>>
>> Could you have a look?
> 
> 
> The bfin issues seems to be caused by a fault in the CMakelist.txt file.
> Which seems to have been solved in the upstream git repo.
> I will test the fix & verify that it solves the issue.
> 
> If it does, I'll provide the fix as a patch on 1.7, unless you/someone
> else prefers bumping to an unreleased git commit.

 No, better cherry-pick the patch. If the upstream patch can be applied as-is,
we prefer pointing PUGIXML_PATCH to the upstream commit (and adding it to the
hash file) rather than saving a copy in buildroot.

> 
> 
> The arc issue: the compiler complains about an internal error.
> I'm not sure if this is a pugimxl issue, but I'll reproduce it
> tomorrow. (currently building bfin)

 Compiler errors on ARC are handled pretty quickly by the ARC team. Just to be
sure, I'm adding Vlad in Cc.


 Regards,
 Arnout

> 
> 
> 
> Theo
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
Zakharov Vlad Sept. 12, 2016, 6:47 a.m. UTC | #5
Hi all,

On Mon, 2016-09-12 at 00:15 +0200, Arnout Vandecappelle wrote:
> 

> On 11-09-16 23:56, Theo Debrouwere wrote:

> > 

> > Hello,

> > 

> > > 

> > > This new package is causing a number of build failures. See:

> > > 

> > >   http://autobuild.buildroot.net/?reason=pugixml-1.7

> > > 

> > > Could you have a look?

> > 

> > 

> > The bfin issues seems to be caused by a fault in the CMakelist.txt file.

> > Which seems to have been solved in the upstream git repo.

> > I will test the fix & verify that it solves the issue.

> > 

> > If it does, I'll provide the fix as a patch on 1.7, unless you/someone

> > else prefers bumping to an unreleased git commit.

> 

>  No, better cherry-pick the patch. If the upstream patch can be applied as-is,

> we prefer pointing PUGIXML_PATCH to the upstream commit (and adding it to the

> hash file) rather than saving a copy in buildroot.

> 

> > 

> > 

> > 

> > The arc issue: the compiler complains about an internal error.

> > I'm not sure if this is a pugimxl issue, but I'll reproduce it

> > tomorrow. (currently building bfin)

> 

>  Compiler errors on ARC are handled pretty quickly by the ARC team. Just to be

> sure, I'm adding Vlad in Cc.

> 

> 

>  Regards,

>  Arnout

> 

> > 

> > 

> > 

> > 

> > Theo

> > 

> > _______________________________________________

> > buildroot mailing list

> > buildroot@busybox.net

> > http://lists.busybox.net/mailman/listinfo/buildroot

> > 

> 


We know about that ARC compiler issue and working on it. 
I hope we will provide a fix soon. 

-- 
Best regards,
Vlad Zakharov <vzakhar@synopsys.com>
Thomas Petazzoni Sept. 12, 2016, 7:19 a.m. UTC | #6
Hello,

Thanks for having looked into this!

On Sun, 11 Sep 2016 23:56:27 +0200, Theo Debrouwere wrote:

> The bfin issues seems to be caused by a fault in the CMakelist.txt file.
> Which seems to have been solved in the upstream git repo.
> I will test the fix & verify that it solves the issue.
> 
> If it does, I'll provide the fix as a patch on 1.7, unless you/someone
> else prefers bumping to an unreleased git commit.

The fix as a patch on 1.7 is probably the best solution for now, until
upstream makes a new release that includes the fix.

> The arc issue: the compiler complains about an internal error.
> I'm not sure if this is a pugimxl issue, but I'll reproduce it
> tomorrow. (currently building bfin)

The ARC issue is indeed a compiler problem, which is not directly
related to pugixml. The people taking care of the ARC architecture have
been notified of this build failure, and they regularly provide updates
to the ARC toolchain support in Buildroot.

Best regards,

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 1e51a45..8d864bc 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1092,6 +1092,7 @@  menu "JSON/XML"
 	source "package/libxslt/Config.in"
 	source "package/libyaml/Config.in"
 	source "package/mxml/Config.in"
+	source "package/pugixml/Config.in"
 	source "package/rapidjson/Config.in"
 	source "package/rapidxml/Config.in"
 	source "package/raptor/Config.in"
diff --git a/package/pugixml/Config.in b/package/pugixml/Config.in
new file mode 100644
index 0000000..5310b10
--- /dev/null
+++ b/package/pugixml/Config.in
@@ -0,0 +1,16 @@ 
+config BR2_PACKAGE_PUGIXML
+	bool "pugixml"
+	depends on BR2_INSTALL_LIBSTDCPP
+	help
+	  Light-weight, simple and fast XML parser for C++ with XPath support
+
+	  Features:
+	  * DOM-like interface with rich traversal/modification capabilities
+	  * Extremely fast non-validating XML parser which constructs the DOM tree
+	    from an XML file/buffer
+	  * XPath 1.0 implementation for complex data-driven tree queries
+	  * Full Unicode support with Unicode interface variants and automatic
+	    encoding conversions
+
+	  http://pugixml.org/
+	  https://github.com/zeux/pugixml
diff --git a/package/pugixml/pugixml.hash b/package/pugixml/pugixml.hash
new file mode 100644
index 0000000..9007f7c
--- /dev/null
+++ b/package/pugixml/pugixml.hash
@@ -0,0 +1,2 @@ 
+# Locally computed:
+sha256  fbe10d46f61d769f7d92a296102e4e2bd3ee16130f11c5b10a1aae590ea1f5ca  pugixml-1.7.tar.gz
diff --git a/package/pugixml/pugixml.mk b/package/pugixml/pugixml.mk
new file mode 100644
index 0000000..2e4f0ce
--- /dev/null
+++ b/package/pugixml/pugixml.mk
@@ -0,0 +1,15 @@ 
+################################################################################
+#
+# pugixml
+#
+################################################################################
+
+PUGIXML_VERSION = 1.7
+PUGIXML_SITE = http://github.com/zeux/pugixml/releases/download/v$(PUGIXML_VERSION)
+PUGIXML_LICENSE = MIT
+PUGIXML_LICENSE_FILES = readme.txt
+PUGIXML_INSTALL_STAGING = YES
+
+PUGIXML_SUBDIR = scripts
+
+$(eval $(cmake-package))