diff mbox

[6/6] alsa-lib: update legal info

Message ID 1467636386-6759-6-git-send-email-rahul.bedarkar@imgtec.com
State Rejected
Headers show

Commit Message

Rahul Bedarkar July 4, 2016, 12:46 p.m. UTC
aserver tool is licensed under GPLv2+. It is built if 'shm' pcm plugin
is enabled. So, specify its license conditionally when it is enabled.

Reviewed-by: Abhimanyu Vishwakarma <abhimanyu.vishwakarma@imgtec.com>
Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
---
 package/alsa-lib/alsa-lib.mk | 13 +++++++++++++
 1 file changed, 13 insertions(+)

Comments

Yann E. MORIN July 4, 2016, 4:14 p.m. UTC | #1
Rahul, All,

On 2016-07-04 18:16 +0530, Rahul Bedarkar spake thusly:
> aserver tool is licensed under GPLv2+. It is built if 'shm' pcm plugin
> is enabled. So, specify its license conditionally when it is enabled.
> 
> Reviewed-by: Abhimanyu Vishwakarma <abhimanyu.vishwakarma@imgtec.com>
> Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
> ---
>  package/alsa-lib/alsa-lib.mk | 13 +++++++++++++
>  1 file changed, 13 insertions(+)
> 
> diff --git a/package/alsa-lib/alsa-lib.mk b/package/alsa-lib/alsa-lib.mk
> index ae0377d..163c840 100644
> --- a/package/alsa-lib/alsa-lib.mk
> +++ b/package/alsa-lib/alsa-lib.mk
> @@ -12,6 +12,19 @@ ALSA_LIB_LICENSE_FILES = COPYING
>  ALSA_LIB_INSTALL_STAGING = YES
>  ALSA_LIB_CFLAGS = $(TARGET_CFLAGS)
>  ALSA_LIB_AUTORECONF = YES
> +
> +ifneq (,$(findstring shm,$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS))))

We prefer positive logic, which you can achieve with something like:

    ifeq ($(filter shm,$($(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS)))),shm)

> +ALSA_LIB_HAS_SHM_PLUGIN = y
> +else ifneq (,$(findstring all,$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS))))

Ditto.

> +ALSA_LIB_HAS_SHM_PLUGIN = y
> +endif
> +
> +# aserver tool is built when shm pcm plugin is enabled and licensed under GPLv2+
> +ifeq ($(ALSA_LIB_HAS_SHM_PLUGIN),y)
> +ALSA_LIB_LICENSE += , GPLv2+ (aserver tool)

As for libuci, this creates an ill-formatted string. Use the same trick
to fix it. ;-)

Regards,
Yann E. MORIN.

> +ALSA_LIB_LICENSE_FILES += aserver/COPYING
> +endif
> +
>  ALSA_LIB_CONF_OPTS = \
>  	--with-alsa-devdir=$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_DEVDIR)) \
>  	--with-pcm-plugins="$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS))" \
> -- 
> 2.6.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni July 5, 2016, 7:15 a.m. UTC | #2
Hello,

On Mon, 4 Jul 2016 18:16:26 +0530, Rahul Bedarkar wrote:

> +ifneq (,$(findstring shm,$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS))))
> +ALSA_LIB_HAS_SHM_PLUGIN = y
> +else ifneq (,$(findstring all,$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS))))
> +ALSA_LIB_HAS_SHM_PLUGIN = y
> +endif
> +
> +# aserver tool is built when shm pcm plugin is enabled and licensed under GPLv2+
> +ifeq ($(ALSA_LIB_HAS_SHM_PLUGIN),y)
> +ALSA_LIB_LICENSE += , GPLv2+ (aserver tool)
> +ALSA_LIB_LICENSE_FILES += aserver/COPYING
> +endif

I think this is somewhat too complicated, what about just doing:

ALSA_LIB_LICENSE = LGPLv2.1+ (library), GPLv2+ (aserver)

However, the code in src/topology/, which can get linked into the
library, seems to be licensed under GPLv2+. This would make the whole
library GPLv2+, no? If that's the case, then the license information
should be updated accordingly.

I've pushed a commit that adds the aserver licensing information (since
it's already better than it is), but it would be good to clarify the
src/topology/ situation.

Thanks,

Thomas
diff mbox

Patch

diff --git a/package/alsa-lib/alsa-lib.mk b/package/alsa-lib/alsa-lib.mk
index ae0377d..163c840 100644
--- a/package/alsa-lib/alsa-lib.mk
+++ b/package/alsa-lib/alsa-lib.mk
@@ -12,6 +12,19 @@  ALSA_LIB_LICENSE_FILES = COPYING
 ALSA_LIB_INSTALL_STAGING = YES
 ALSA_LIB_CFLAGS = $(TARGET_CFLAGS)
 ALSA_LIB_AUTORECONF = YES
+
+ifneq (,$(findstring shm,$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS))))
+ALSA_LIB_HAS_SHM_PLUGIN = y
+else ifneq (,$(findstring all,$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS))))
+ALSA_LIB_HAS_SHM_PLUGIN = y
+endif
+
+# aserver tool is built when shm pcm plugin is enabled and licensed under GPLv2+
+ifeq ($(ALSA_LIB_HAS_SHM_PLUGIN),y)
+ALSA_LIB_LICENSE += , GPLv2+ (aserver tool)
+ALSA_LIB_LICENSE_FILES += aserver/COPYING
+endif
+
 ALSA_LIB_CONF_OPTS = \
 	--with-alsa-devdir=$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_DEVDIR)) \
 	--with-pcm-plugins="$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS))" \