diff mbox

lft: new package

Message ID 1462300214-8562-1-git-send-email-gustavo@zacarias.com.ar
State Accepted
Headers show

Commit Message

Gustavo Zacarias May 3, 2016, 6:30 p.m. UTC
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/Config.in                |  1 +
 package/lft/0001-no-strip.patch  | 19 +++++++++++++++++++
 package/lft/0002-no-incdir.patch | 27 +++++++++++++++++++++++++++
 package/lft/Config.in            | 10 ++++++++++
 package/lft/lft.hash             |  2 ++
 package/lft/lft.mk               | 19 +++++++++++++++++++
 6 files changed, 78 insertions(+)
 create mode 100644 package/lft/0001-no-strip.patch
 create mode 100644 package/lft/0002-no-incdir.patch
 create mode 100644 package/lft/Config.in
 create mode 100644 package/lft/lft.hash
 create mode 100644 package/lft/lft.mk

Comments

Thomas Petazzoni May 13, 2016, 9:34 p.m. UTC | #1
Hello,

On Tue,  3 May 2016 15:30:14 -0300, Gustavo Zacarias wrote:
> Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
> ---
>  package/Config.in                |  1 +
>  package/lft/0001-no-strip.patch  | 19 +++++++++++++++++++
>  package/lft/0002-no-incdir.patch | 27 +++++++++++++++++++++++++++
>  package/lft/Config.in            | 10 ++++++++++
>  package/lft/lft.hash             |  2 ++
>  package/lft/lft.mk               | 19 +++++++++++++++++++
>  6 files changed, 78 insertions(+)
>  create mode 100644 package/lft/0001-no-strip.patch
>  create mode 100644 package/lft/0002-no-incdir.patch
>  create mode 100644 package/lft/Config.in
>  create mode 100644 package/lft/lft.hash
>  create mode 100644 package/lft/lft.mk

I've changed the license name from VOSCOM to the more complete "VOSTROM
Public License for Open Source", which is the complete license name
found in the COPYING file. And then I've applied to next. Thanks!

I guess the chance of seeing the patches merged upstream is pretty
small, unfortunately :/ Have you talked with upstream about the silly
form-based download method?

Thanks!

Thomas
Gustavo Zacarias May 13, 2016, 10:07 p.m. UTC | #2
On 13/05/16 18:34, Thomas Petazzoni wrote:

> I guess the chance of seeing the patches merged upstream is pretty
> small, unfortunately :/ Have you talked with upstream about the silly
> form-based download method?
>
> Thanks!
>
> Thomas

Hi.
It seems unlikely, i've emailed them about the build patches and never 
got any reply back which i was hoping for to ask about the form.
Regards.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 12cfdd8..ca16a24 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1425,6 +1425,7 @@  endif
 	source "package/kismet/Config.in"
 	source "package/knock/Config.in"
 	source "package/leafnode2/Config.in"
+	source "package/lft/Config.in"
 	source "package/lftp/Config.in"
 	source "package/lighttpd/Config.in"
 	source "package/linknx/Config.in"
diff --git a/package/lft/0001-no-strip.patch b/package/lft/0001-no-strip.patch
new file mode 100644
index 0000000..f1bd700
--- /dev/null
+++ b/package/lft/0001-no-strip.patch
@@ -0,0 +1,19 @@ 
+Don't forcibly strip binaries, we do so on our own.
+Also using strip rather than $(STRIP) is bad when cross-compiling.
+
+Patch status: notified upstream.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura lft-3.74.orig/Makefile.in lft-3.74/Makefile.in
+--- lft-3.74.orig/Makefile.in	2016-05-03 14:11:30.965530923 -0300
++++ lft-3.74/Makefile.in	2016-05-03 14:11:42.120918849 -0300
+@@ -50,8 +50,6 @@
+ 
+ install: lft lft.8 whob whob.8
+ 	@echo "LFT and WhoB"
+-	@echo "  \_Stripping binaries"
+-	@strip lft whob
+ 	@echo "  \_Copying files to their intended destinations"
+ 	@test -d $(DESTDIR)$(bindir)/. || $(MKDIR) $(DESTDIR)$(bindir)
+ 	$(INSTALL) lft $(DESTDIR)$(bindir)/lft
diff --git a/package/lft/0002-no-incdir.patch b/package/lft/0002-no-incdir.patch
new file mode 100644
index 0000000..dbfaad5
--- /dev/null
+++ b/package/lft/0002-no-incdir.patch
@@ -0,0 +1,27 @@ 
+Don't pollute incdir with absolute directories, it's bad when
+cross-compiling.
+Patch configure directly since autoreconf isn't clean.
+
+Patch status: notified upstream.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura lft-3.74.orig/configure lft-3.74/configure
+--- lft-3.74.orig/configure	2016-05-03 14:11:30.964530888 -0300
++++ lft-3.74/configure	2016-05-03 14:12:45.038106775 -0300
+@@ -5732,15 +5732,6 @@
+ 
+ 
+ 
+-for incdir in /usr/local/include /usr/include
+-do
+-  if test -d $incdir/pcap
+-  then
+-    CFLAGS="$CFLAGS -I$incdir/pcap"
+-    CPPFLAGS="$CFLAGS -I$incdir/pcap"
+-  fi
+-done
+-
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h.  */
+ _ACEOF
diff --git a/package/lft/Config.in b/package/lft/Config.in
new file mode 100644
index 0000000..9ed7b8b
--- /dev/null
+++ b/package/lft/Config.in
@@ -0,0 +1,10 @@ 
+config BR2_PACKAGE_LFT
+	bool "lft"
+	select BR2_PACKAGE_LIBPCAP
+	help
+	  LFT, short for Layer Four Traceroute, is a sort of
+	  'traceroute' that often works much faster (than the
+	  commonly-used Van Jacobson method) and goes through many
+	  configurations of packet-filters (firewalls).
+
+	  http://pwhois.org/lft/
diff --git a/package/lft/lft.hash b/package/lft/lft.hash
new file mode 100644
index 0000000..dc3945c
--- /dev/null
+++ b/package/lft/lft.hash
@@ -0,0 +1,2 @@ 
+# Locally calculated, matches download from fossies.org and pwhois.org
+sha256	d7f142b9198162a48dd41261f5982e5189b951e7746e171d6b2c5b9581f26000	lft-3.74.tar.gz
diff --git a/package/lft/lft.mk b/package/lft/lft.mk
new file mode 100644
index 0000000..9128618
--- /dev/null
+++ b/package/lft/lft.mk
@@ -0,0 +1,19 @@ 
+################################################################################
+#
+# lft
+#
+################################################################################
+
+LFT_VERSION = 3.74
+# Download from pwhois.org is form-wrapped resulting in ugly filename
+LFT_SITE = https://fossies.org/linux/privat
+LFT_DEPENDENCIES = libpcap
+LFT_LICENSE = VOSTROM
+LFT_LICENSE_FILES = COPYING
+LFT_CONF_OPTS = --with-pcap=$(STAGING_DIR)/usr
+
+ifeq ($(BR2_STATIC_LIBS),y)
+LFT_CONF_OPTS += LIBS="`$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`"
+endif
+
+$(eval $(autotools-package))