diff mbox

tcl: remove non-existent --with-system-sqlite configure option

Message ID 1459344688-24416-1-git-send-email-Vincent.Riera@imgtec.com
State Rejected
Headers show

Commit Message

Vicente Olivert Riera March 30, 2016, 1:31 p.m. UTC
For some reason, even if this option is not available anymore, it's
causing build failures if we use it. When we remove it the build
succeeds.

Fixes:
  http://autobuild.buildroot.net/results/022/02296f8624d3406a63d3a179f53862f245c56dc1/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
 package/tcl/tcl.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Thomas Petazzoni March 30, 2016, 1:41 p.m. UTC | #1
Hello,

On Wed, 30 Mar 2016 14:31:28 +0100, Vicente Olivert Riera wrote:
> For some reason, even if this option is not available anymore, it's
> causing build failures if we use it. When we remove it the build
> succeeds.
> 
> Fixes:
>   http://autobuild.buildroot.net/results/022/02296f8624d3406a63d3a179f53862f245c56dc1/
> 
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>

I don't see why you think this option no longer exists. A simple grep
is pretty clear that it still exists:

pkgs/sqlite3.11.0/configure:  --with-system-sqlite    use a system-supplied libsqlite3 instead of the
pkgs/sqlite3.11.0/configure:# The --with-system-sqlite causes the TCL bindings to SQLite to use
pkgs/sqlite3.11.0/configure:# Check whether --with-system-sqlite was given.
pkgs/sqlite3.11.0/configure.ac:# The --with-system-sqlite causes the TCL bindings to SQLite to use
pkgs/sqlite3.11.0/configure.ac:AC_ARG_WITH([system-sqlite],
pkgs/sqlite3.11.0/configure.ac: [AC_HELP_STRING([--with-system-sqlite],

Looking at the output of './configure --help' to figure out which
options are available is not sufficient. Indeed, when you have
sub-configure scripts, as is the case for tcl, ./configure --help
doesn't show you the options of the sub-configures, but it is actually
passing the main configure options down to the sub-configures. See
https://www.gnu.org/software/automake/manual/html_node/Subpackages.html#Subpackages
for details.

So your patch fixes the problem because it tells TCL to use its bundled
version of sqlite, and not the one provided by Buildroot. Which means:

TCL_DEPENDENCIES = $(if $(BR2_PACKAGE_SQLITE),sqlite)

becomes useless, as well as other parts of tcl.mk that refer to
BR2_PACKAGE_SQLITE.

In addition, we generally prefer to *not* use bundled versions of the
libraries, so it would be better to figure out why using the system
sqlite no longer works, possibly by reporting a bug upstream.

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/tcl/tcl.mk b/package/tcl/tcl.mk
index 9fd1195..52be7b8 100644
--- a/package/tcl/tcl.mk
+++ b/package/tcl/tcl.mk
@@ -21,8 +21,7 @@  TCL_AUTORECONF = YES
 TCL_CONF_OPTS = \
 	--disable-symbols \
 	--disable-langinfo \
-	--disable-framework \
-	--with-system-sqlite
+	--disable-framework
 
 HOST_TCL_CONF_OPTS = \
 	--disable-symbols \