diff mbox

[v3,11/11] weston: handle libxml2 dependency

Message ID 1459262350-10974-12-git-send-email-gustavo@zacarias.com.ar
State Accepted
Headers show

Commit Message

Gustavo Zacarias March 29, 2016, 2:39 p.m. UTC
It's used for JUnit XML output support.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/weston/weston.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni March 30, 2016, 3:02 p.m. UTC | #1
Hello,

On Tue, 29 Mar 2016 11:39:10 -0300, Gustavo Zacarias wrote:
> It's used for JUnit XML output support.
> 
> Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
> ---
>  package/weston/weston.mk | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/package/weston/weston.mk b/package/weston/weston.mk
> index 9313fcc..2891fe3 100644
> --- a/package/weston/weston.mk
> +++ b/package/weston/weston.mk
> @@ -116,4 +116,11 @@ else
>  WESTON_CONF_OPTS += --disable-systemd-login --disable-systemd-notify
>  endif
>  
> +ifeq ($(BR2_PACKAGE_LIBXML2),y)
> +WESTON_CONF_OPTS += --enable-junit-xml
> +WESTON_DEPENDENCIES += libxml2
> +else
> +WESTON_CONF_OPTS += --disable-junit-xml
> +endif

Do we really care about this JUnit XML output support ?

Thomas
Gustavo Zacarias March 30, 2016, 3:04 p.m. UTC | #2
On 30/03/16 12:02, Thomas Petazzoni wrote:

>> +ifeq ($(BR2_PACKAGE_LIBXML2),y)
>> +WESTON_CONF_OPTS += --enable-junit-xml
>> +WESTON_DEPENDENCIES += libxml2
>> +else
>> +WESTON_CONF_OPTS += --disable-junit-xml
>> +endif
>
> Do we really care about this JUnit XML output support ?
>
> Thomas

Probably not very useful, just wanted to cover all available possibilities.
Regards.
diff mbox

Patch

diff --git a/package/weston/weston.mk b/package/weston/weston.mk
index 9313fcc..2891fe3 100644
--- a/package/weston/weston.mk
+++ b/package/weston/weston.mk
@@ -116,4 +116,11 @@  else
 WESTON_CONF_OPTS += --disable-systemd-login --disable-systemd-notify
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+WESTON_CONF_OPTS += --enable-junit-xml
+WESTON_DEPENDENCIES += libxml2
+else
+WESTON_CONF_OPTS += --disable-junit-xml
+endif
+
 $(eval $(autotools-package))