diff mbox

[2/2] package/qwt : added support for Qt5.

Message ID 1458850791-4205-2-git-send-email-davepiq@yahoo.fr
State Accepted
Headers show

Commit Message

David PICARD March 24, 2016, 8:19 p.m. UTC
This version of Qwt is compatible with both Qt and Qt5. This patch adds the
option to compile it for Qt5.

Signed-off-by: David Picard <davepiq@yahoo.fr>
---
 package/qwt/Config.in | 10 +++++++---
 package/qwt/qwt.mk    |  3 +++
 2 files changed, 10 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni March 25, 2016, 9:51 a.m. UTC | #1
Hello,

On Thu, 24 Mar 2016 21:19:51 +0100, David Picard wrote:

> +	depends on (BR2_PACKAGE_HAS_LIBGLES && BR2_PACKAGE_HAS_LIBEG) || \
> +		BR2_PACKAGE_QT5_GL_AVAILABLE

I know I told you to use this, but in fact I think a more correct
dependency is:

	(BR2_PACKAGE_HAS_LIBGLES && BR2_PACKAGE_HAS_LIBEGL && BR2_PACKAGE_QT) || \
	(BR2_PACKAGE_QT5_GL_AVAILABLE && BR2_PACKAGE_QT5)

so that we are sure that if we're using Qt, we have the dependencies
that are needed to have OpenGL support in Qt, and if we have Qt5, we
have the dependencies that are needed to have OpenGL support in Qt5.

I've applied after fixing this.

Also, after applying, I noticed there was a typo: BR2_PACKAGE_HAS_LIBEG
in your patch should have been BR2_PACKAGE_HAS_LIBEGL. I've fixed that
up with a following commit, as I only noticed while replying to this
e-mail.

Thanks!

Thomas
David PICARD March 25, 2016, 11:08 a.m. UTC | #2
Hello,

OK, thanks for your help and patience. It was very instructive.

Cheers,
David.


Le 25/03/2016 10:51, Thomas Petazzoni a écrit :
> Hello,
>
> On Thu, 24 Mar 2016 21:19:51 +0100, David Picard wrote:
>
>> +	depends on (BR2_PACKAGE_HAS_LIBGLES && BR2_PACKAGE_HAS_LIBEG) || \
>> +		BR2_PACKAGE_QT5_GL_AVAILABLE
>
> I know I told you to use this, but in fact I think a more correct
> dependency is:
>
> 	(BR2_PACKAGE_HAS_LIBGLES && BR2_PACKAGE_HAS_LIBEGL && BR2_PACKAGE_QT) || \
> 	(BR2_PACKAGE_QT5_GL_AVAILABLE && BR2_PACKAGE_QT5)
>
> so that we are sure that if we're using Qt, we have the dependencies
> that are needed to have OpenGL support in Qt, and if we have Qt5, we
> have the dependencies that are needed to have OpenGL support in Qt5.
>
> I've applied after fixing this.
>
> Also, after applying, I noticed there was a typo: BR2_PACKAGE_HAS_LIBEG
> in your patch should have been BR2_PACKAGE_HAS_LIBEGL. I've fixed that
> up with a following commit, as I only noticed while replying to this
> e-mail.
>
> Thanks!
>
> Thomas
>
diff mbox

Patch

diff --git a/package/qwt/Config.in b/package/qwt/Config.in
index 876d465..05d5253 100644
--- a/package/qwt/Config.in
+++ b/package/qwt/Config.in
@@ -1,7 +1,9 @@ 
 config BR2_PACKAGE_QWT
 	bool "qwt"
-	depends on BR2_PACKAGE_QT
+	depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
 	select BR2_PACKAGE_QT_GUI_MODULE if BR2_PACKAGE_QT
+	select BR2_PACKAGE_QT5BASE_GUI if BR2_PACKAGE_QT5
+	select BR2_PACKAGE_QT5BASE_CONCURRENT if BR2_PACKAGE_QT5
 	help
 	  Qwt is a graphics extension to the Qt GUI application
 	  framework. It provides a 2D plotting widget and more.
@@ -13,14 +15,16 @@  if BR2_PACKAGE_QWT
 config BR2_PACKAGE_QWT_SVG
 	bool "SVG support"
 	select BR2_PACKAGE_QT_SVG if BR2_PACKAGE_QT
+	select BR2_PACKAGE_QT5SVG if BR2_PACKAGE_QT5
 
 config BR2_PACKAGE_QWT_MATHML
 	bool "MathML support"
 
 config BR2_PACKAGE_QWT_OPENGL
 	bool "OpenGL support"
-	depends on BR2_PACKAGE_HAS_LIBGLES
-	depends on BR2_PACKAGE_HAS_LIBEGL
+	depends on (BR2_PACKAGE_HAS_LIBGLES && BR2_PACKAGE_HAS_LIBEG) || \
+		BR2_PACKAGE_QT5_GL_AVAILABLE
 	select BR2_PACKAGE_QT_OPENGL_ES if BR2_PACKAGE_QT
+	select BR2_PACKAGE_QT5BASE_OPENGL_LIB if BR2_PACKAGE_QT5
 
 endif
diff --git a/package/qwt/qwt.mk b/package/qwt/qwt.mk
index 4d481fb..594b141 100644
--- a/package/qwt/qwt.mk
+++ b/package/qwt/qwt.mk
@@ -11,6 +11,9 @@  QWT_INSTALL_STAGING = YES
 ifeq ($(BR2_PACKAGE_QT),y)
 QWT_DEPENDENCIES = qt
 QWT_QMAKE = $(QT_QMAKE)
+else ifeq ($(BR2_PACKAGE_QT5),y)
+QWT_DEPENDENCIES += qt5
+QWT_QMAKE = $(QT5_QMAKE)
 endif
 
 QWT_LICENSE = LGPLv2.1 with exceptions