diff mbox

lirc-tools: needs host-python3

Message ID 1458391485-23315-1-git-send-email-gustavo@zacarias.com.ar
State Accepted
Headers show

Commit Message

Gustavo Zacarias March 19, 2016, 12:44 p.m. UTC
As stated in NEWS "Build scripts now requires python3". Fixes:
http://autobuild.buildroot.net/results/f41/f417a17ad24eec8f72402a634588c6b3af8293be/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/lirc-tools/lirc-tools.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni March 20, 2016, 2:30 p.m. UTC | #1
Hello,

On Sat, 19 Mar 2016 09:44:45 -0300, Gustavo Zacarias wrote:
> As stated in NEWS "Build scripts now requires python3". Fixes:
> http://autobuild.buildroot.net/results/f41/f417a17ad24eec8f72402a634588c6b3af8293be/
> 
> Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
> ---
>  package/lirc-tools/lirc-tools.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks. However, one question that comes to mind is
what will happen if both host-python and host-python3 are built, will
lirc-tools build system properly use python3 ?

Best regards,

Thomas
Peter Korsgaard March 20, 2016, 6:54 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 > Hello,
 > On Sat, 19 Mar 2016 09:44:45 -0300, Gustavo Zacarias wrote:
 >> As stated in NEWS "Build scripts now requires python3". Fixes:
 >> http://autobuild.buildroot.net/results/f41/f417a17ad24eec8f72402a634588c6b3af8293be/
 >> 
 >> Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
 >> ---
 >> package/lirc-tools/lirc-tools.mk | 2 +-
 >> 1 file changed, 1 insertion(+), 1 deletion(-)

 > Applied to master, thanks. However, one question that comes to mind is
 > what will happen if both host-python and host-python3 are built, will
 > lirc-tools build system properly use python3 ?

From a quick look it seems like the scripts use:

#!/usr/bin/env python3

So that should work when we have both python versions enabled.
diff mbox

Patch

diff --git a/package/lirc-tools/lirc-tools.mk b/package/lirc-tools/lirc-tools.mk
index 2e437a6..46886a9 100644
--- a/package/lirc-tools/lirc-tools.mk
+++ b/package/lirc-tools/lirc-tools.mk
@@ -9,7 +9,7 @@  LIRC_TOOLS_SOURCE = lirc-$(LIRC_TOOLS_VERSION).tar.bz2
 LIRC_TOOLS_SITE = http://downloads.sourceforge.net/project/lirc/LIRC/$(LIRC_TOOLS_VERSION)
 LIRC_TOOLS_LICENSE = GPLv2+
 LIRC_TOOLS_LICENSE_FILES = COPYING
-LIRC_TOOLS_DEPENDENCIES = host-libxslt host-pkgconf
+LIRC_TOOLS_DEPENDENCIES = host-libxslt host-pkgconf host-python3
 LIRC_TOOLS_INSTALL_STAGING = YES
 
 LIRC_TOOLS_CONF_ENV = XSLTPROC=yes