diff mbox

slang: make install-static do install-pkgconfig

Message ID 1457838391-19605-1-git-send-email-jcmvbkbc@gmail.com
State Superseded
Headers show

Commit Message

Max Filippov March 13, 2016, 3:06 a.m. UTC
mc's configure can't find S-Lang because static S-Lang build doesn't
install pkgconfig file into staging. Adding install-pkgconfig to
install-static dependencies fixes that.

Fixes:
  http://autobuild.buildroot.net/results/085194f18bc7db1e801d98e6620e3a75fd988cc5/

Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
---
 package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard March 13, 2016, 8:14 p.m. UTC | #1
>>>>> "Max" == Max Filippov <jcmvbkbc@gmail.com> writes:

 > mc's configure can't find S-Lang because static S-Lang build doesn't
 > install pkgconfig file into staging. Adding install-pkgconfig to
 > install-static dependencies fixes that.

 > Fixes:
 >   http://autobuild.buildroot.net/results/085194f18bc7db1e801d98e6620e3a75fd988cc5/

 > Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
 > ---
 >  package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch | 3 ++-
 >  1 file changed, 2 insertions(+), 1 deletion(-)

 > diff --git a/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch b/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
 > index ee306a1..b0f8779 100644

Patch description and signed-off-by missing. Alternatively we can drop
the patch and just pass install-pkgconfig to the 'make install' step as
we already need to use a custom make target anyway.

 > --- a/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
 > +++ b/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
 > @@ -39,7 +39,8 @@ diff -rup a/autoconf/Makefile.in b/autoconf/Makefile.in
 >   	cd slsh; $(MAKE) all
 >  @@ -73,10 +76,11 @@ clean:
 >   	cd demo; $(MAKE) clean
 > - install-static:
 > +-install-static:
 > ++install-static: install-pkgconfig
 >   	cd src; $(MAKE) install-static
 >  +	cd slsh; $(MAKE) install-static
 >   install-pkgconfig: slang.pc
 > -- 
 > 2.1.4

 > _______________________________________________
 > buildroot mailing list
 > buildroot@busybox.net
 > http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni March 13, 2016, 8:17 p.m. UTC | #2
Peter,

On Sun, 13 Mar 2016 21:14:51 +0100, Peter Korsgaard wrote:

> Patch description and signed-off-by missing. Alternatively we can drop
> the patch and just pass install-pkgconfig to the 'make install' step as
> we already need to use a custom make target anyway.

This is *exactly* what Max was doing in its first iteration of the
patch, to which Yann replied:

"""
Could you instead fix the
0002-Enable-a-statically-linked-version-of-slsh patch to have
install-static also depend on install-pkgconfig, please?
"""

Best regards,

Thomas
Yann E. MORIN March 13, 2016, 8:20 p.m. UTC | #3
Peter, All,

On 2016-03-13 21:14 +0100, Peter Korsgaard spake thusly:
> >>>>> "Max" == Max Filippov <jcmvbkbc@gmail.com> writes:
> 
>  > mc's configure can't find S-Lang because static S-Lang build doesn't
>  > install pkgconfig file into staging. Adding install-pkgconfig to
>  > install-static dependencies fixes that.
> 
>  > Fixes:
>  >   http://autobuild.buildroot.net/results/085194f18bc7db1e801d98e6620e3a75fd988cc5/
> 
>  > Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
>  > ---
>  >  package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch | 3 ++-
>  >  1 file changed, 2 insertions(+), 1 deletion(-)
> 
>  > diff --git a/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch b/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
>  > index ee306a1..b0f8779 100644
> 
> Patch description and signed-off-by missing. Alternatively we can drop
> the patch and just pass install-pkgconfig to the 'make install' step as
> we already need to use a custom make target anyway.

That's what Max did in his first patch, and I asked him to do it in our
patch.
The .pc file is not installed for static-only because *we* added a patch
that breaks down install into install-staging and install-shared.

So it makes more sense to fix our own patch, that work around 
deficiencies we added.

Plus, it makes for a patch that can be more easily upstremable.

Regards,
Yann E. MORIN.

>  > --- a/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
>  > +++ b/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
>  > @@ -39,7 +39,8 @@ diff -rup a/autoconf/Makefile.in b/autoconf/Makefile.in
>  >   	cd slsh; $(MAKE) all
>  >  @@ -73,10 +76,11 @@ clean:
>  >   	cd demo; $(MAKE) clean
>  > - install-static:
>  > +-install-static:
>  > ++install-static: install-pkgconfig
>  >   	cd src; $(MAKE) install-static
>  >  +	cd slsh; $(MAKE) install-static
>  >   install-pkgconfig: slang.pc
>  > -- 
>  > 2.1.4
> 
>  > _______________________________________________
>  > buildroot mailing list
>  > buildroot@busybox.net
>  > http://lists.busybox.net/mailman/listinfo/buildroot
> 
> 
> -- 
> Bye, Peter Korsgaard
Yann E. MORIN March 13, 2016, 8:20 p.m. UTC | #4
Max, All,

On 2016-03-13 06:06 +0300, Max Filippov spake thusly:
> mc's configure can't find S-Lang because static S-Lang build doesn't
> install pkgconfig file into staging. Adding install-pkgconfig to
> install-static dependencies fixes that.
> 
> Fixes:
>   http://autobuild.buildroot.net/results/085194f18bc7db1e801d98e6620e3a75fd988cc5/
> 
> Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>

Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch b/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
> index ee306a1..b0f8779 100644
> --- a/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
> +++ b/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
> @@ -39,7 +39,8 @@ diff -rup a/autoconf/Makefile.in b/autoconf/Makefile.in
>   	cd slsh; $(MAKE) all
>  @@ -73,10 +76,11 @@ clean:
>   	cd demo; $(MAKE) clean
> - install-static:
> +-install-static:
> ++install-static: install-pkgconfig
>   	cd src; $(MAKE) install-static
>  +	cd slsh; $(MAKE) install-static
>   install-pkgconfig: slang.pc
> -- 
> 2.1.4
>
Peter Korsgaard March 13, 2016, 8:43 p.m. UTC | #5
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 > Peter,
 > On Sun, 13 Mar 2016 21:14:51 +0100, Peter Korsgaard wrote:

 >> Patch description and signed-off-by missing. Alternatively we can drop
 >> the patch and just pass install-pkgconfig to the 'make install' step as
 >> we already need to use a custom make target anyway.

 > This is *exactly* what Max was doing in its first iteration of the
 > patch, to which Yann replied:

 > """
 > Could you instead fix the
 > 0002-Enable-a-statically-linked-version-of-slsh patch to have
 > install-static also depend on install-pkgconfig, please?
 > """

Ok, I missed that mail.
Peter Korsgaard March 13, 2016, 8:44 p.m. UTC | #6
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

Hi,

 >> Patch description and signed-off-by missing. Alternatively we can drop
 >> the patch and just pass install-pkgconfig to the 'make install' step as
 >> we already need to use a custom make target anyway.

 > That's what Max did in his first patch, and I asked him to do it in our
 > patch.
 > The .pc file is not installed for static-only because *we* added a patch
 > that breaks down install into install-staging and install-shared.

But that patch is an upstream patch:

Repository: git://git.jedsoft.org/git/slang.git
Commit ID: 3796db6fb94a2fc7fe2fb0b6918501b69a4d3a02
Author: John E. Davis <jed@jedsoft.org>

So just changing what the patch does without updating the comment is
imho not the right way to go. We should instead add a 0003 patch and
send it upstream.
Yann E. MORIN March 13, 2016, 8:47 p.m. UTC | #7
Peter, All,

On 2016-03-13 21:44 +0100, Peter Korsgaard spake thusly:
> >>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:
> 
> Hi,
> 
>  >> Patch description and signed-off-by missing. Alternatively we can drop
>  >> the patch and just pass install-pkgconfig to the 'make install' step as
>  >> we already need to use a custom make target anyway.
> 
>  > That's what Max did in his first patch, and I asked him to do it in our
>  > patch.
>  > The .pc file is not installed for static-only because *we* added a patch
>  > that breaks down install into install-staging and install-shared.
> 
> But that patch is an upstream patch:
> 
> Repository: git://git.jedsoft.org/git/slang.git
> Commit ID: 3796db6fb94a2fc7fe2fb0b6918501b69a4d3a02
> Author: John E. Davis <jed@jedsoft.org>

Oh...

> So just changing what the patch does without updating the comment is
> imho not the right way to go. We should instead add a 0003 patch and
> send it upstream.

Definitely.

Thanks! :-)

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch b/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
index ee306a1..b0f8779 100644
--- a/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
+++ b/package/slang/0002-Enable-a-statically-linked-version-of-slsh.patch
@@ -39,7 +39,8 @@  diff -rup a/autoconf/Makefile.in b/autoconf/Makefile.in
  	cd slsh; $(MAKE) all
 @@ -73,10 +76,11 @@ clean:
  	cd demo; $(MAKE) clean
- install-static:
+-install-static:
++install-static: install-pkgconfig
  	cd src; $(MAKE) install-static
 +	cd slsh; $(MAKE) install-static
  install-pkgconfig: slang.pc