diff mbox

[v2] package/kbd: fix not installing to the target

Message ID 1457347031-12817-1-git-send-email-martin@barkynet.com
State Superseded
Headers show

Commit Message

Martin Bark March 7, 2016, 10:37 a.m. UTC
Commit https://git.busybox.net/buildroot/commit/?id=9f81bad fixed a build
error in kbd but unfortunately it broke the target install rule so that
nothing is being installed.

Add the missing DESTDIR=$(TARGET_DIR) install to KBD_INSTALL_TARGET_OPTS
so that it installs to the target again.

Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Martin Bark <martin@barkynet.com>

---

Changes v1 -> v2
 - Moved KBD_INSTALL_TARGET_OPTS before $(eval $(autotools-package))
   (Suggested by Thomas)
---
 package/kbd/kbd.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni March 14, 2016, 10:39 p.m. UTC | #1
Dear Martin Bark,

On Mon,  7 Mar 2016 10:37:11 +0000, Martin Bark wrote:
> Commit https://git.busybox.net/buildroot/commit/?id=9f81bad fixed a build
> error in kbd but unfortunately it broke the target install rule so that
> nothing is being installed.
> 
> Add the missing DESTDIR=$(TARGET_DIR) install to KBD_INSTALL_TARGET_OPTS
> so that it installs to the target again.
> 
> Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> Signed-off-by: Martin Bark <martin@barkynet.com>

Peter applied a similar patch from a different contributor. See
https://git.busybox.net/buildroot/commit/?id=28a55b66897f97e3acad36549a4c9e02e7f5dc22.

Best regards,

Thomas
diff mbox

Patch

diff --git a/package/kbd/kbd.mk b/package/kbd/kbd.mk
index 9dabce1..7d9adf3 100644
--- a/package/kbd/kbd.mk
+++ b/package/kbd/kbd.mk
@@ -17,6 +17,7 @@  KBD_LICENSE = GPLv2+
 KBD_LICENSE_FILES = COPYING
 KBD_AUTORECONF = YES
 
-KBD_INSTALL_TARGET_OPTS += MKINSTALLDIRS=$(@D)/config/mkinstalldirs
+KBD_INSTALL_TARGET_OPTS = MKINSTALLDIRS=$(@D)/config/mkinstalldirs \
+	DESTDIR=$(TARGET_DIR) install
 
 $(eval $(autotools-package))