diff mbox

core: override the user's locale while setting HOSTARCH

Message ID 1453326799-14060-1-git-send-email-romain.naour@gmail.com
State Accepted
Headers show

Commit Message

Romain Naour Jan. 20, 2016, 9:53 p.m. UTC
At least with French user's locale HOSTARCH is empty since
'Target' is not present in gcc output.

gcc -v 2>&1
Utilisation des specs internes.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/5.3.1/lto-wrapper
Cible : x86_64-redhat-linux

Override the user's local with LC_ALL=C.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN Jan. 20, 2016, 9:56 p.m. UTC | #1
Romain, All,

On 2016-01-20 22:53 +0100, Romain Naour spake thusly:
> At least with French user's locale HOSTARCH is empty since
> 'Target' is not present in gcc output.
> 
> gcc -v 2>&1
> Utilisation des specs internes.
> COLLECT_GCC=gcc
> COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/5.3.1/lto-wrapper
> Cible : x86_64-redhat-linux
> 
> Override the user's local with LC_ALL=C.
> 
> Signed-off-by: Romain Naour <romain.naour@gmail.com>
> Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/Makefile b/Makefile
> index 2e09611..17c181b 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -297,7 +297,7 @@ export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE
>  # So, we extract the first part of the tuple the host gcc was
>  # configured to generate code for; we assume this is our userland.
>  #
> -export HOSTARCH := $(shell $(HOSTCC_NOCCACHE) -v 2>&1 | \
> +export HOSTARCH := $(shell LC_ALL=C $(HOSTCC_NOCCACHE) -v 2>&1 | \
>  	sed -e '/^Target: \([^-]*\).*/!d' \
>  	    -e 's//\1/' \
>  	    -e 's/i.86/x86/' \
> -- 
> 2.4.3
>
Thomas Petazzoni Jan. 20, 2016, 10:03 p.m. UTC | #2
Dear Romain Naour,

On Wed, 20 Jan 2016 22:53:19 +0100, Romain Naour wrote:
> At least with French user's locale HOSTARCH is empty since
> 'Target' is not present in gcc output.
> 
> gcc -v 2>&1
> Utilisation des specs internes.
> COLLECT_GCC=gcc
> COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/5.3.1/lto-wrapper
> Cible : x86_64-redhat-linux
> 
> Override the user's local with LC_ALL=C.
> 
> Signed-off-by: Romain Naour <romain.naour@gmail.com>
> Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
>  Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 2e09611..17c181b 100644
--- a/Makefile
+++ b/Makefile
@@ -297,7 +297,7 @@  export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE
 # So, we extract the first part of the tuple the host gcc was
 # configured to generate code for; we assume this is our userland.
 #
-export HOSTARCH := $(shell $(HOSTCC_NOCCACHE) -v 2>&1 | \
+export HOSTARCH := $(shell LC_ALL=C $(HOSTCC_NOCCACHE) -v 2>&1 | \
 	sed -e '/^Target: \([^-]*\).*/!d' \
 	    -e 's//\1/' \
 	    -e 's/i.86/x86/' \