diff mbox

[1/1] openipmi: add OPENIPMI_VERSION_MAJOR variable

Message ID 1451548770-2968-1-git-send-email-jerzy.grzegorek@trzebnica.net
State Rejected
Headers show

Commit Message

Jerzy Grzegorek Dec. 31, 2015, 7:59 a.m. UTC
Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net>
---
 package/openipmi/openipmi.mk | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Dec. 31, 2015, 9:31 a.m. UTC | #1
Jerzy,

On Thu, 31 Dec 2015 08:59:30 +0100, Jerzy Grzegorek wrote:

> -OPENIPMI_VERSION = 2.0.21
> -OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library
> -OPENIPMI_SOURCE = OpenIPMI-2.0.21.tar.gz
> +OPENIPMI_VERSION_MAJOR = 2.0
> +OPENIPMI_VERSION = $(OPENIPMI_VERSION_MAJOR).21
> +OPENIPMI_SOURCE = OpenIPMI-$(OPENIPMI_VERSION).tar.gz
> +OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%20$(OPENIPMI_VERSION_MAJOR)%20Library

I believe this is going a bit too far because what's encoded in the URL
here is not really the "major version", but the name of the project,
which is "OpenIPMI 2.0 Library".

So in this case, I don't think using the _VERSION_MAJOR thing is really
appropriate.

Let's see what others think about it.

Thomas
Arnout Vandecappelle Dec. 31, 2015, 10:13 a.m. UTC | #2
On 31-12-15 10:31, Thomas Petazzoni wrote:
> Jerzy,
> 
> On Thu, 31 Dec 2015 08:59:30 +0100, Jerzy Grzegorek wrote:
> 
>> -OPENIPMI_VERSION = 2.0.21
>> -OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library
>> -OPENIPMI_SOURCE = OpenIPMI-2.0.21.tar.gz
>> +OPENIPMI_VERSION_MAJOR = 2.0
>> +OPENIPMI_VERSION = $(OPENIPMI_VERSION_MAJOR).21
>> +OPENIPMI_SOURCE = OpenIPMI-$(OPENIPMI_VERSION).tar.gz
>> +OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%20$(OPENIPMI_VERSION_MAJOR)%20Library
> 
> I believe this is going a bit too far because what's encoded in the URL
> here is not really the "major version", but the name of the project,
> which is "OpenIPMI 2.0 Library".
> 
> So in this case, I don't think using the _VERSION_MAJOR thing is really
> appropriate.
> 
> Let's see what others think about it.

 I don't care much either way. In general, I'm not too impressed with the
introduction of _VERSION_MAJOR variables, because IMHO it doesn't simplify
things at all. The idea is that it would be easier to bump the version, but in
all likelihood, when the major version changes, you have bigger problems to deal
with than just having to change things in two places.

 Regards,
 Arnout
Yann E. MORIN Jan. 1, 2016, 5:19 p.m. UTC | #3
Arnout, Thomas, Jerzy, All,

On 2015-12-31 11:13 +0100, Arnout Vandecappelle spake thusly:
> On 31-12-15 10:31, Thomas Petazzoni wrote:
> > On Thu, 31 Dec 2015 08:59:30 +0100, Jerzy Grzegorek wrote:
> >> -OPENIPMI_VERSION = 2.0.21
> >> -OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library
> >> -OPENIPMI_SOURCE = OpenIPMI-2.0.21.tar.gz
> >> +OPENIPMI_VERSION_MAJOR = 2.0
> >> +OPENIPMI_VERSION = $(OPENIPMI_VERSION_MAJOR).21
> >> +OPENIPMI_SOURCE = OpenIPMI-$(OPENIPMI_VERSION).tar.gz
> >> +OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%20$(OPENIPMI_VERSION_MAJOR)%20Library
> > 
> > I believe this is going a bit too far because what's encoded in the URL
> > here is not really the "major version", but the name of the project,
> > which is "OpenIPMI 2.0 Library".
> > 
> > So in this case, I don't think using the _VERSION_MAJOR thing is really
> > appropriate.
> > 
> > Let's see what others think about it.
> 
>  I don't care much either way. In general, I'm not too impressed with the
> introduction of _VERSION_MAJOR variables, because IMHO it doesn't simplify
> things at all. The idea is that it would be easier to bump the version, but in
> all likelihood, when the major version changes, you have bigger problems to deal
> with than just having to change things in two places.

I'm usually not against using _VERSION_MAJOR.

What however I find disturbing and to be unnecessary churn, is this
systematic change to using it.

I would prefer that we only switch to using _VERSION_MAJOR when there is
a reason to do so (e.g. shared amongst many variables, like version, URL,
path URLs, etc...) while bumping a package or fixing it somehow, and
that we do not do that change on its own.

However, the name of the project is not OpenIPMI 2.0 Library. It's just
OpenIPMI. Upstream also has "OpenIPMI 1.3 Library" and "OpenIPMI 1.4
Library" download locations, each corresponding to the 'major version'
of the library.

Still, I agree with Arnout, and I don't think we should do those changes
just for the sake of adding _VERSION_MAJOR. It should provide an actual
improvement (but I can see that URL encoding above is a bit confusing to
read without the variable).

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/openipmi/openipmi.mk b/package/openipmi/openipmi.mk
index 85bd6b4..3b9c49f 100644
--- a/package/openipmi/openipmi.mk
+++ b/package/openipmi/openipmi.mk
@@ -4,9 +4,10 @@ 
 #
 ################################################################################
 
-OPENIPMI_VERSION = 2.0.21
-OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library
-OPENIPMI_SOURCE = OpenIPMI-2.0.21.tar.gz
+OPENIPMI_VERSION_MAJOR = 2.0
+OPENIPMI_VERSION = $(OPENIPMI_VERSION_MAJOR).21
+OPENIPMI_SOURCE = OpenIPMI-$(OPENIPMI_VERSION).tar.gz
+OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%20$(OPENIPMI_VERSION_MAJOR)%20Library
 OPENIPMI_LICENSE = LGPLv2+, GPLv2+, BSD-3c
 OPENIPMI_LICENSE_FILES = COPYING.LIB COPYING COPYING.BSD
 OPENIPMI_DEPENDENCIES = popt ncurses host-pkgconf