diff mbox

[1/1] uboot: add COPY_OLD_LICENSE_FILE fix to rsync hook

Message ID 1451356050-6300-1-git-send-email-nunes.erico@gmail.com
State Accepted
Headers show

Commit Message

Erico Nunes Dec. 29, 2015, 2:27 a.m. UTC
make legal-info breaks when using an older u-boot version in local.mk
with OVERRIDE_SRCDIR, due to the reorganization of license files which
happened in u-boot v2013.10.
This issue had already been fixed in Buildroot for the regular use of
old u-boot versions (non-local.mk).
This patch adds the same fix to UBOOT_POST_RSYNC_HOOKS so that it also
covers the local.mk case.

Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
---
 boot/uboot/uboot.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Dec. 29, 2015, 11:26 a.m. UTC | #1
Dear Erico Nunes,

On Tue, 29 Dec 2015 00:27:30 -0200, Erico Nunes wrote:
> make legal-info breaks when using an older u-boot version in local.mk
> with OVERRIDE_SRCDIR, due to the reorganization of license files which
> happened in u-boot v2013.10.
> This issue had already been fixed in Buildroot for the regular use of
> old u-boot versions (non-local.mk).
> This patch adds the same fix to UBOOT_POST_RSYNC_HOOKS so that it also
> covers the local.mk case.
> 
> Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
> ---
>  boot/uboot/uboot.mk | 1 +
>  1 file changed, 1 insertion(+)

I am not super happy with having to duplicate all extract and patch
hooks as rsync hooks. The theory is that if you use a
<pkg>_OVERRIDE_SRCDIR, you should know what you're doing, and your
source tree should match the expectations of Buildroot.

But oh well, it kind of makes sense to help in this case, so I've
applied your patch. Still there is an open discussion on where to draw
the line for those post rsync hooks.

Thanks!

Thomas
diff mbox

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 868bf08..c8c50f0 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -110,6 +110,7 @@  define UBOOT_COPY_OLD_LICENSE_FILE
 endef
 
 UBOOT_POST_EXTRACT_HOOKS += UBOOT_COPY_OLD_LICENSE_FILE
+UBOOT_POST_RSYNC_HOOKS += UBOOT_COPY_OLD_LICENSE_FILE
 
 # Prior to Buildroot 2015.05, only patch directories were supported. New
 # configurations use BR2_TARGET_UBOOT_PATCH instead.