diff mbox

mplayer: use autodetection for dvdnav

Message ID 1447927571-38206-1-git-send-email-Vincent.Riera@imgtec.com
State Accepted
Headers show

Commit Message

Vicente Olivert Riera Nov. 19, 2015, 10:06 a.m. UTC
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
 package/mplayer/mplayer.mk |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

Comments

Vicente Olivert Riera Nov. 30, 2015, 4:08 p.m. UTC | #1
ping. This patch is quite trivial, I think.

Regards,

Vincent.

On 19/11/15 10:06, Vicente Olivert Riera wrote:
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
> ---
>  package/mplayer/mplayer.mk |    3 ++-
>  1 files changed, 2 insertions(+), 1 deletions(-)
> 
> diff --git a/package/mplayer/mplayer.mk b/package/mplayer/mplayer.mk
> index ad2d9dd..3051afa 100644
> --- a/package/mplayer/mplayer.mk
> +++ b/package/mplayer/mplayer.mk
> @@ -125,9 +125,10 @@ MPLAYER_CONF_OPTS +=  \
>  MPLAYER_DEPENDENCIES += libdvdread
>  endif
>  
> +# We intentionally don't pass --enable-dvdnav to let the autodetection
> +# find which library to link with.
>  ifeq ($(BR2_PACKAGE_LIBDVDNAV),y)
>  MPLAYER_CONF_OPTS +=  \
> -	--enable-dvdnav \
>  	--with-dvdnav-config=$(STAGING_DIR)/usr/bin/dvdnav-config
>  MPLAYER_DEPENDENCIES += libdvdnav
>  endif
>
Thomas Petazzoni Dec. 15, 2015, 12:39 p.m. UTC | #2
Dear Vicente Olivert Riera,

On Thu, 19 Nov 2015 10:06:11 +0000, Vicente Olivert Riera wrote:
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
> ---
>  package/mplayer/mplayer.mk |    3 ++-
>  1 files changed, 2 insertions(+), 1 deletions(-)

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/package/mplayer/mplayer.mk b/package/mplayer/mplayer.mk
index ad2d9dd..3051afa 100644
--- a/package/mplayer/mplayer.mk
+++ b/package/mplayer/mplayer.mk
@@ -125,9 +125,10 @@  MPLAYER_CONF_OPTS +=  \
 MPLAYER_DEPENDENCIES += libdvdread
 endif
 
+# We intentionally don't pass --enable-dvdnav to let the autodetection
+# find which library to link with.
 ifeq ($(BR2_PACKAGE_LIBDVDNAV),y)
 MPLAYER_CONF_OPTS +=  \
-	--enable-dvdnav \
 	--with-dvdnav-config=$(STAGING_DIR)/usr/bin/dvdnav-config
 MPLAYER_DEPENDENCIES += libdvdnav
 endif