diff mbox

[v2] readline: install configuration file from package recipe

Message ID 1447780845-22019-1-git-send-email-jezz@sysmic.org
State Accepted
Headers show

Commit Message

Jérôme Pouiller Nov. 17, 2015, 5:20 p.m. UTC
/etc/inputrc is configuration file for readline. However, until now, it
was provided by skeleton. This patch install /etc/inputrc from readline
recipe.

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
---
v2:
  Send patch using -M

  
 {system/skeleton/etc => package/readline}/inputrc | 0
 package/readline/readline.mk                      | 6 +++++-
 2 files changed, 5 insertions(+), 1 deletion(-)
 rename {system/skeleton/etc => package/readline}/inputrc (100%)

Comments

Gustavo Zacarias Nov. 17, 2015, 9:13 p.m. UTC | #1
On 17/11/15 14:20, Jérôme Pouiller wrote:

> /etc/inputrc is configuration file for readline. However, until now, it
> was provided by skeleton. This patch install /etc/inputrc from readline
> recipe.
>
> Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>

Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Thomas Petazzoni Nov. 17, 2015, 9:29 p.m. UTC | #2
Dear Jérôme Pouiller,

On Tue, 17 Nov 2015 18:20:45 +0100, Jérôme Pouiller wrote:
> /etc/inputrc is configuration file for readline. However, until now, it
> was provided by skeleton. This patch install /etc/inputrc from readline
> recipe.
> 
> Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
> ---
> v2:
>   Send patch using -M

Applied to next, thanks!

Thanks for this /etc/inputrc and /etc/issue fixes. It's definitely good
to strip down a bit the skeleton.

Thomas
diff mbox

Patch

diff --git a/system/skeleton/etc/inputrc b/package/readline/inputrc
similarity index 100%
rename from system/skeleton/etc/inputrc
rename to package/readline/inputrc
diff --git a/package/readline/readline.mk b/package/readline/readline.mk
index c004899..3d31696 100644
--- a/package/readline/readline.mk
+++ b/package/readline/readline.mk
@@ -17,8 +17,12 @@  READLINE_LICENSE_FILES = COPYING
 define READLINE_PURGE_EXAMPLES
 	rm -rf $(TARGET_DIR)/usr/share/readline
 endef
-
 READLINE_POST_INSTALL_TARGET_HOOKS += READLINE_PURGE_EXAMPLES
 
+define READLINE_INSTALL_INPUTRC
+	$(INSTALL) -D -m 644 package/readline/inputrc $(TARGET_DIR)/etc/inputrc
+endef
+READLINE_POST_INSTALL_TARGET_HOOKS += READLINE_INSTALL_INPUTRC
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))