diff mbox

[2/2] heimdal: disable parallel build

Message ID 1436544308-22652-2-git-send-email-Vincent.Riera@imgtec.com
State Rejected
Headers show

Commit Message

Vicente Olivert Riera July 10, 2015, 4:05 p.m. UTC
The commit 2fc8be39edd610623d322c71e42a06b535cbadb7 enabled parallel
build, but this is causing build failures like this one:

Making all in kadm5
make[3]: Entering directory
`/home/test/autobuild/instance-0/output/build/host-heimdal-1.6rc2/lib/kadm5'
compile_et kadm5_err.et
compile_et kadm5_err.et
  CC       ad.lo
    CC       chpass_c.lo
    In file included from chpass_c.c:34:
    kadm5_locl.h:78:23: error: kadm5_err.h: No such file or directory

The file 'kadm5_err.h' is a generated header which is being requested
before being generated.

Fixes:

  http://autobuild.buildroot.net/results/3a4/3a42c5b294a9a8602844ed1127ec5eadb60a6bed/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
 package/heimdal/heimdal.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Vicente Olivert Riera July 10, 2015, 4:19 p.m. UTC | #1
Sure, no problem.

On 10/07/15 18:19, Gustavo Zacarias wrote:
>
>
> On 10/07/15 13:05, Vicente Olivert Riera wrote:
>
>> The commit 2fc8be39edd610623d322c71e42a06b535cbadb7 enabled parallel
>> build, but this is causing build failures like this one:
>>
>> Making all in kadm5
>> make[3]: Entering directory
>> `/home/test/autobuild/instance-0/output/build/host-heimdal-1.6rc2/lib/kadm5'
>>
>> compile_et kadm5_err.et
>> compile_et kadm5_err.et
>>    CC       ad.lo
>>      CC       chpass_c.lo
>>      In file included from chpass_c.c:34:
>>      kadm5_locl.h:78:23: error: kadm5_err.h: No such file or directory
>>
>> The file 'kadm5_err.h' is a generated header which is being requested
>> before being generated.
>>
>> Fixes:
>>
>>
>> http://autobuild.buildroot.net/results/3a4/3a42c5b294a9a8602844ed1127ec5eadb60a6bed/
>>
>>
>> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
>
> Hi Vicente.
> That's harsh, specially since it seems to be a tiny breakage that's
> already fixed upstream via:
> http://repo.or.cz/w/heimdal.git/commitdiff/6affa4c
> Care to redo it in a "fixing" way? :)
> Regards.
>
Gustavo Zacarias July 10, 2015, 4:19 p.m. UTC | #2
On 10/07/15 13:05, Vicente Olivert Riera wrote:

> The commit 2fc8be39edd610623d322c71e42a06b535cbadb7 enabled parallel
> build, but this is causing build failures like this one:
>
> Making all in kadm5
> make[3]: Entering directory
> `/home/test/autobuild/instance-0/output/build/host-heimdal-1.6rc2/lib/kadm5'
> compile_et kadm5_err.et
> compile_et kadm5_err.et
>    CC       ad.lo
>      CC       chpass_c.lo
>      In file included from chpass_c.c:34:
>      kadm5_locl.h:78:23: error: kadm5_err.h: No such file or directory
>
> The file 'kadm5_err.h' is a generated header which is being requested
> before being generated.
>
> Fixes:
>
>    http://autobuild.buildroot.net/results/3a4/3a42c5b294a9a8602844ed1127ec5eadb60a6bed/
>
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>

Hi Vicente.
That's harsh, specially since it seems to be a tiny breakage that's 
already fixed upstream via:
http://repo.or.cz/w/heimdal.git/commitdiff/6affa4c
Care to redo it in a "fixing" way? :)
Regards.
Thomas Petazzoni July 14, 2015, 11:48 a.m. UTC | #3
Dear Vicente Olivert Riera,

On Fri, 10 Jul 2015 18:05:08 +0200, Vicente Olivert Riera wrote:
> The commit 2fc8be39edd610623d322c71e42a06b535cbadb7 enabled parallel
> build, but this is causing build failures like this one:
> 
> Making all in kadm5
> make[3]: Entering directory
> `/home/test/autobuild/instance-0/output/build/host-heimdal-1.6rc2/lib/kadm5'
> compile_et kadm5_err.et
> compile_et kadm5_err.et
>   CC       ad.lo
>     CC       chpass_c.lo
>     In file included from chpass_c.c:34:
>     kadm5_locl.h:78:23: error: kadm5_err.h: No such file or directory
> 
> The file 'kadm5_err.h' is a generated header which is being requested
> before being generated.
> 
> Fixes:
> 
>   http://autobuild.buildroot.net/results/3a4/3a42c5b294a9a8602844ed1127ec5eadb60a6bed/
> 
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
> ---
>  package/heimdal/heimdal.mk | 1 +
>  1 file changed, 1 insertion(+)

I've marked this patch as Rejected and instead committed a patch that
backports the upstream commit pointed by Gustavo and that should fix
the parallel build issue.

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/heimdal/heimdal.mk b/package/heimdal/heimdal.mk
index 19bca5e..8c2aa2b 100644
--- a/package/heimdal/heimdal.mk
+++ b/package/heimdal/heimdal.mk
@@ -24,6 +24,7 @@  HOST_HEIMDAL_CONF_OPTS = \
 	--without-x \
 	--disable-heimdal-documentation
 HOST_HEIMDAL_CONF_ENV = MAKEINFO=true
+HEIMDAL_MAKE = $(MAKE1)
 HEIMDAL_LICENSE = BSD-3c
 HEIMDAL_LICENSE_FILES = LICENSE