diff mbox

[v3,1/3] atf: new package

Message ID 1433717727-30214-2-git-send-email-sebastien.bourdelin@savoirfairelinux.com
State Superseded
Headers show

Commit Message

Sebastien Bourdelin June 7, 2015, 10:55 p.m. UTC
ATF, or Automated Testing Framework, is a collection of libraries to
write test programs in C, C++ and POSIX shell.

https://github.com/jmmv/atf

Signed-off-by: Sebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com>
---
Changes v2 -> v3:
  - rebase

  suggested by Arnout Vandecapelle <arnout@mind.be>:
  - adds comment to explain the need to use AUTORECONF

Changes v1 -> v2:
  suggested by Arnout Vandecapelle <arnout@mind.be>:
  - bump the version
  - uses the release archive instead of the github automatic one
  - updates the hash
  - removes host-pkgconf from dependencies
  - changes the license
  - reworks the comment around CONF_ENV to avoid error
---
 package/Config.in     |  1 +
 package/atf/Config.in | 11 +++++++++++
 package/atf/atf.hash  |  2 ++
 package/atf/atf.mk    | 23 +++++++++++++++++++++++
 4 files changed, 37 insertions(+)
 create mode 100644 package/atf/Config.in
 create mode 100644 package/atf/atf.hash
 create mode 100644 package/atf/atf.mk

Comments

Thomas Petazzoni June 11, 2015, 8:33 p.m. UTC | #1
Dear Sebastien Bourdelin,

On Sun,  7 Jun 2015 18:55:25 -0400, Sebastien Bourdelin wrote:

>  menu "Debugging, profiling and benchmark"
> +	source "package/atf/Config.in"

Is "Debugging, profiling and benchmark" the right place? It seems to be
more like the gtest package, which is in Libraries -> Other.

But agreed, we don't really have a good place for test related
libraries/frameworks. Maybe we should create one?

> new file mode 100644
> index 0000000..bf6f156
> --- /dev/null
> +++ b/package/atf/atf.mk
> @@ -0,0 +1,23 @@
> +################################################################################
> +#
> +# atf
> +#
> +################################################################################
> +
> +ATF_VERSION = 0.21
> +ATF_SITE = https://github.com/jmmv/atf/releases/download/atf-$(ATF_VERSION)
> +ATF_INSTALL_STAGING = YES
> +ATF_LICENSE = BSD-3c
> +ATF_LICENSE_FILES = COPYING
> +# Ships a beta libtool version hence our patch doesn't apply.
> +ATF_AUTORECONF = YES
> +
> +
> +# ATF_SHELL defaults to the host's bash
> +ATF_CONF_ENV = \
> +	kyua_cv_getopt_plus=yes \
> +	kyua_cv_attribute_noreturn=yes \
> +	kyua_cv_getcwd_works=yes \
> +	ATF_SHELL=/bin/sh
> +
> +$(eval $(autotools-package))

It installs quite a bunch of things to the target filesystem, including
C and C++ source code, which seems a bit useless since we don't support
building/installing a compiler for the target:

./usr/tests/atf
./usr/tests/atf/Kyuafile
./usr/tests/atf/atf-sh
./usr/tests/atf/atf-sh/tc_test
./usr/tests/atf/atf-sh/Kyuafile
./usr/tests/atf/atf-sh/atf-check_test
./usr/tests/atf/atf-sh/tp_test
./usr/tests/atf/atf-sh/integration_test
./usr/tests/atf/atf-sh/misc_helpers
./usr/tests/atf/atf-sh/normalize_test
./usr/tests/atf/atf-sh/config_test
./usr/tests/atf/atf-sh/atf_check_test
./usr/tests/atf/atf-c
./usr/tests/atf/atf-c/tc_test
./usr/tests/atf/atf-c/Kyuafile
./usr/tests/atf/atf-c/atf_c_test
./usr/tests/atf/atf-c/macros_test
./usr/tests/atf/atf-c/tp_test
./usr/tests/atf/atf-c/build_test
./usr/tests/atf/atf-c/error_test
./usr/tests/atf/atf-c/check_test
./usr/tests/atf/atf-c/utils_test
./usr/tests/atf/atf-c/pkg_config_test
./usr/tests/atf/atf-c/macros_h_test.c
./usr/tests/atf/atf-c/unused_test.c
./usr/tests/atf/atf-c/detail
./usr/tests/atf/atf-c/detail/version_helper
./usr/tests/atf/atf-c/detail/env_test
./usr/tests/atf/atf-c/detail/Kyuafile
./usr/tests/atf/atf-c/detail/process_test
./usr/tests/atf/atf-c/detail/fs_test
./usr/tests/atf/atf-c/detail/text_test
./usr/tests/atf/atf-c/detail/dynstr_test
./usr/tests/atf/atf-c/detail/sanity_test
./usr/tests/atf/atf-c/detail/list_test
./usr/tests/atf/atf-c/detail/user_test
./usr/tests/atf/atf-c/detail/process_helpers
./usr/tests/atf/atf-c/detail/map_test
./usr/tests/atf/atf-c++
./usr/tests/atf/atf-c++/atf_c++_test
./usr/tests/atf/atf-c++/macros_hpp_test.cpp
./usr/tests/atf/atf-c++/Kyuafile
./usr/tests/atf/atf-c++/tests_test
./usr/tests/atf/atf-c++/macros_test
./usr/tests/atf/atf-c++/build_test
./usr/tests/atf/atf-c++/check_test
./usr/tests/atf/atf-c++/utils_test
./usr/tests/atf/atf-c++/pkg_config_test
./usr/tests/atf/atf-c++/unused_test.cpp
./usr/tests/atf/atf-c++/detail
./usr/tests/atf/atf-c++/detail/version_helper
./usr/tests/atf/atf-c++/detail/env_test
./usr/tests/atf/atf-c++/detail/Kyuafile
./usr/tests/atf/atf-c++/detail/process_test
./usr/tests/atf/atf-c++/detail/exceptions_test
./usr/tests/atf/atf-c++/detail/fs_test
./usr/tests/atf/atf-c++/detail/application_test
./usr/tests/atf/atf-c++/detail/text_test
./usr/tests/atf/atf-c++/detail/auto_array_test
./usr/tests/atf/test-programs
./usr/tests/atf/test-programs/srcdir_test
./usr/tests/atf/test-programs/Kyuafile
./usr/tests/atf/test-programs/c_helpers
./usr/tests/atf/test-programs/sh_helpers
./usr/tests/atf/test-programs/expect_test
./usr/tests/atf/test-programs/config_test
./usr/tests/atf/test-programs/meta_data_test
./usr/tests/atf/test-programs/cpp_helpers
./usr/tests/atf/test-programs/result_test

Are all of these files needed on the target?

Thanks,

Thomas
Thomas Petazzoni June 11, 2015, 8:34 p.m. UTC | #2
Dear Sebastien Bourdelin,

On Sun,  7 Jun 2015 18:55:25 -0400, Sebastien Bourdelin wrote:

> +ATF_VERSION = 0.21
> +ATF_SITE = https://github.com/jmmv/atf/releases/download/atf-$(ATF_VERSION)
> +ATF_INSTALL_STAGING = YES
> +ATF_LICENSE = BSD-3c

The COPYING file actually has both BSD-2c and BSD-3c. Maybe specifying
only BSD-3c is OK since it's the same as BSD-2c + an additional
restriction. But I was just wondering what lead to mentioning only
BSD-3c.

Thanks,

Thomas
Sebastien Bourdelin June 11, 2015, 8:41 p.m. UTC | #3
Hi Thomas.

I do not know a lot about licenses, so it will be a lucky mistake if
it's correct otherwise i can add the BSD-2c if you think it's required.

Thanks.

On 06/11/2015 04:34 PM, Thomas Petazzoni wrote:
> Dear Sebastien Bourdelin,
>
> On Sun,  7 Jun 2015 18:55:25 -0400, Sebastien Bourdelin wrote:
>
>> +ATF_VERSION = 0.21
>> +ATF_SITE = https://github.com/jmmv/atf/releases/download/atf-$(ATF_VERSION)
>> +ATF_INSTALL_STAGING = YES
>> +ATF_LICENSE = BSD-3c
> The COPYING file actually has both BSD-2c and BSD-3c. Maybe specifying
> only BSD-3c is OK since it's the same as BSD-2c + an additional
> restriction. But I was just wondering what lead to mentioning only
> BSD-3c.
>
> Thanks,
>
> Thomas
Sebastien Bourdelin June 11, 2015, 8:42 p.m. UTC | #4
Hi Thomas.

I will leave you that choice :)

Thanks.

On 06/11/2015 04:33 PM, Thomas Petazzoni wrote:
> Dear Sebastien Bourdelin,
>
> On Sun,  7 Jun 2015 18:55:25 -0400, Sebastien Bourdelin wrote:
>
>>  menu "Debugging, profiling and benchmark"
>> +	source "package/atf/Config.in"
> Is "Debugging, profiling and benchmark" the right place? It seems to be
> more like the gtest package, which is in Libraries -> Other.
>
> But agreed, we don't really have a good place for test related
> libraries/frameworks. Maybe we should create one?
>
>> new file mode 100644
>> index 0000000..bf6f156
>> --- /dev/null
>> +++ b/package/atf/atf.mk
>> @@ -0,0 +1,23 @@
>> +################################################################################
>> +#
>> +# atf
>> +#
>> +################################################################################
>> +
>> +ATF_VERSION = 0.21
>> +ATF_SITE = https://github.com/jmmv/atf/releases/download/atf-$(ATF_VERSION)
>> +ATF_INSTALL_STAGING = YES
>> +ATF_LICENSE = BSD-3c
>> +ATF_LICENSE_FILES = COPYING
>> +# Ships a beta libtool version hence our patch doesn't apply.
>> +ATF_AUTORECONF = YES
>> +
>> +
>> +# ATF_SHELL defaults to the host's bash
>> +ATF_CONF_ENV = \
>> +	kyua_cv_getopt_plus=yes \
>> +	kyua_cv_attribute_noreturn=yes \
>> +	kyua_cv_getcwd_works=yes \
>> +	ATF_SHELL=/bin/sh
>> +
>> +$(eval $(autotools-package))
> It installs quite a bunch of things to the target filesystem, including
> C and C++ source code, which seems a bit useless since we don't support
> building/installing a compiler for the target:
>
> ./usr/tests/atf
> ./usr/tests/atf/Kyuafile
> ./usr/tests/atf/atf-sh
> ./usr/tests/atf/atf-sh/tc_test
> ./usr/tests/atf/atf-sh/Kyuafile
> ./usr/tests/atf/atf-sh/atf-check_test
> ./usr/tests/atf/atf-sh/tp_test
> ./usr/tests/atf/atf-sh/integration_test
> ./usr/tests/atf/atf-sh/misc_helpers
> ./usr/tests/atf/atf-sh/normalize_test
> ./usr/tests/atf/atf-sh/config_test
> ./usr/tests/atf/atf-sh/atf_check_test
> ./usr/tests/atf/atf-c
> ./usr/tests/atf/atf-c/tc_test
> ./usr/tests/atf/atf-c/Kyuafile
> ./usr/tests/atf/atf-c/atf_c_test
> ./usr/tests/atf/atf-c/macros_test
> ./usr/tests/atf/atf-c/tp_test
> ./usr/tests/atf/atf-c/build_test
> ./usr/tests/atf/atf-c/error_test
> ./usr/tests/atf/atf-c/check_test
> ./usr/tests/atf/atf-c/utils_test
> ./usr/tests/atf/atf-c/pkg_config_test
> ./usr/tests/atf/atf-c/macros_h_test.c
> ./usr/tests/atf/atf-c/unused_test.c
> ./usr/tests/atf/atf-c/detail
> ./usr/tests/atf/atf-c/detail/version_helper
> ./usr/tests/atf/atf-c/detail/env_test
> ./usr/tests/atf/atf-c/detail/Kyuafile
> ./usr/tests/atf/atf-c/detail/process_test
> ./usr/tests/atf/atf-c/detail/fs_test
> ./usr/tests/atf/atf-c/detail/text_test
> ./usr/tests/atf/atf-c/detail/dynstr_test
> ./usr/tests/atf/atf-c/detail/sanity_test
> ./usr/tests/atf/atf-c/detail/list_test
> ./usr/tests/atf/atf-c/detail/user_test
> ./usr/tests/atf/atf-c/detail/process_helpers
> ./usr/tests/atf/atf-c/detail/map_test
> ./usr/tests/atf/atf-c++
> ./usr/tests/atf/atf-c++/atf_c++_test
> ./usr/tests/atf/atf-c++/macros_hpp_test.cpp
> ./usr/tests/atf/atf-c++/Kyuafile
> ./usr/tests/atf/atf-c++/tests_test
> ./usr/tests/atf/atf-c++/macros_test
> ./usr/tests/atf/atf-c++/build_test
> ./usr/tests/atf/atf-c++/check_test
> ./usr/tests/atf/atf-c++/utils_test
> ./usr/tests/atf/atf-c++/pkg_config_test
> ./usr/tests/atf/atf-c++/unused_test.cpp
> ./usr/tests/atf/atf-c++/detail
> ./usr/tests/atf/atf-c++/detail/version_helper
> ./usr/tests/atf/atf-c++/detail/env_test
> ./usr/tests/atf/atf-c++/detail/Kyuafile
> ./usr/tests/atf/atf-c++/detail/process_test
> ./usr/tests/atf/atf-c++/detail/exceptions_test
> ./usr/tests/atf/atf-c++/detail/fs_test
> ./usr/tests/atf/atf-c++/detail/application_test
> ./usr/tests/atf/atf-c++/detail/text_test
> ./usr/tests/atf/atf-c++/detail/auto_array_test
> ./usr/tests/atf/test-programs
> ./usr/tests/atf/test-programs/srcdir_test
> ./usr/tests/atf/test-programs/Kyuafile
> ./usr/tests/atf/test-programs/c_helpers
> ./usr/tests/atf/test-programs/sh_helpers
> ./usr/tests/atf/test-programs/expect_test
> ./usr/tests/atf/test-programs/config_test
> ./usr/tests/atf/test-programs/meta_data_test
> ./usr/tests/atf/test-programs/cpp_helpers
> ./usr/tests/atf/test-programs/result_test
>
> Are all of these files needed on the target?
>
> Thanks,
>
> Thomas
Arnout Vandecappelle June 11, 2015, 8:45 p.m. UTC | #5
On 06/11/15 22:41, Sebastien Bourdelin wrote:
> Hi Thomas.
> 
> I do not know a lot about licenses, so it will be a lucky mistake if
> it's correct otherwise i can add the BSD-2c if you think it's required.

 BSD-2c, BSD-3c is exactly what I suggested in my review of v1... But that was
probably not clear enough.

 Regards,
 Arnout

> 
> Thanks.
> 
> On 06/11/2015 04:34 PM, Thomas Petazzoni wrote:
>> Dear Sebastien Bourdelin,
>>
>> On Sun,  7 Jun 2015 18:55:25 -0400, Sebastien Bourdelin wrote:
>>
>>> +ATF_VERSION = 0.21
>>> +ATF_SITE = https://github.com/jmmv/atf/releases/download/atf-$(ATF_VERSION)
>>> +ATF_INSTALL_STAGING = YES
>>> +ATF_LICENSE = BSD-3c
>> The COPYING file actually has both BSD-2c and BSD-3c. Maybe specifying
>> only BSD-3c is OK since it's the same as BSD-2c + an additional
>> restriction. But I was just wondering what lead to mentioning only
>> BSD-3c.
>>
>> Thanks,
>>
>> Thomas
> 
> 
>  
>  
> ************************************************************************************
> This footnote confirms that this email message has been scanned by
> PineApp Mail-SeCure for the presence of malicious code, vandals & computer viruses.
> ************************************************************************************
> 
> 
> 
>
Sebastien Bourdelin June 11, 2015, 8:48 p.m. UTC | #6
Hi Arnout.

My mistake, i took it as a BSD-2c "or" BSD-3c.

I will fix that.

Thanks.

On 06/11/2015 04:45 PM, Arnout Vandecappelle wrote:
> On 06/11/15 22:41, Sebastien Bourdelin wrote:
>> Hi Thomas.
>>
>> I do not know a lot about licenses, so it will be a lucky mistake if
>> it's correct otherwise i can add the BSD-2c if you think it's required.
>  BSD-2c, BSD-3c is exactly what I suggested in my review of v1... But that was
> probably not clear enough.
>
>  Regards,
>  Arnout
>
>> Thanks.
>>
>> On 06/11/2015 04:34 PM, Thomas Petazzoni wrote:
>>> Dear Sebastien Bourdelin,
>>>
>>> On Sun,  7 Jun 2015 18:55:25 -0400, Sebastien Bourdelin wrote:
>>>
>>>> +ATF_VERSION = 0.21
>>>> +ATF_SITE = https://github.com/jmmv/atf/releases/download/atf-$(ATF_VERSION)
>>>> +ATF_INSTALL_STAGING = YES
>>>> +ATF_LICENSE = BSD-3c
>>> The COPYING file actually has both BSD-2c and BSD-3c. Maybe specifying
>>> only BSD-3c is OK since it's the same as BSD-2c + an additional
>>> restriction. But I was just wondering what lead to mentioning only
>>> BSD-3c.
>>>
>>> Thanks,
>>>
>>> Thomas
>>
>>  
>>  
>> ************************************************************************************
>> This footnote confirms that this email message has been scanned by
>> PineApp Mail-SeCure for the presence of malicious code, vandals & computer viruses.
>> ************************************************************************************
>>
>>
>>
>>
>
Arnout Vandecappelle June 11, 2015, 9:06 p.m. UTC | #7
On 06/11/15 22:42, Sebastien Bourdelin wrote:
> Hi Thomas.
> 
> I will leave you that choice :)
> 
> Thanks.
> 
> On 06/11/2015 04:33 PM, Thomas Petazzoni wrote:
[snip]
>> It installs quite a bunch of things to the target filesystem, including
>> C and C++ source code, which seems a bit useless since we don't support
>> building/installing a compiler for the target:

 Sebastien, could you still respond to this question? AFAICS, Thomas is right,
these tests actually test atf itself so they shouldn't be installed, or they
should be cleaned up in a POST_TARGET_INSTALL_HOOK. I think the easiest is not
to install them, by setting

ATF_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-exec

 This installs only the libraries and the atf-sh program, which I think is all
that is needed.


 Regards,
 Arnout

>>
>> ./usr/tests/atf
>> ./usr/tests/atf/Kyuafile
>> ./usr/tests/atf/atf-sh
>> ./usr/tests/atf/atf-sh/tc_test
>> ./usr/tests/atf/atf-sh/Kyuafile
>> ./usr/tests/atf/atf-sh/atf-check_test
>> ./usr/tests/atf/atf-sh/tp_test
>> ./usr/tests/atf/atf-sh/integration_test
>> ./usr/tests/atf/atf-sh/misc_helpers
>> ./usr/tests/atf/atf-sh/normalize_test
>> ./usr/tests/atf/atf-sh/config_test
>> ./usr/tests/atf/atf-sh/atf_check_test
>> ./usr/tests/atf/atf-c
>> ./usr/tests/atf/atf-c/tc_test
>> ./usr/tests/atf/atf-c/Kyuafile
>> ./usr/tests/atf/atf-c/atf_c_test
>> ./usr/tests/atf/atf-c/macros_test
>> ./usr/tests/atf/atf-c/tp_test
>> ./usr/tests/atf/atf-c/build_test
>> ./usr/tests/atf/atf-c/error_test
>> ./usr/tests/atf/atf-c/check_test
>> ./usr/tests/atf/atf-c/utils_test
>> ./usr/tests/atf/atf-c/pkg_config_test
>> ./usr/tests/atf/atf-c/macros_h_test.c
>> ./usr/tests/atf/atf-c/unused_test.c
>> ./usr/tests/atf/atf-c/detail
>> ./usr/tests/atf/atf-c/detail/version_helper
>> ./usr/tests/atf/atf-c/detail/env_test
>> ./usr/tests/atf/atf-c/detail/Kyuafile
>> ./usr/tests/atf/atf-c/detail/process_test
>> ./usr/tests/atf/atf-c/detail/fs_test
>> ./usr/tests/atf/atf-c/detail/text_test
>> ./usr/tests/atf/atf-c/detail/dynstr_test
>> ./usr/tests/atf/atf-c/detail/sanity_test
>> ./usr/tests/atf/atf-c/detail/list_test
>> ./usr/tests/atf/atf-c/detail/user_test
>> ./usr/tests/atf/atf-c/detail/process_helpers
>> ./usr/tests/atf/atf-c/detail/map_test
>> ./usr/tests/atf/atf-c++
>> ./usr/tests/atf/atf-c++/atf_c++_test
>> ./usr/tests/atf/atf-c++/macros_hpp_test.cpp
>> ./usr/tests/atf/atf-c++/Kyuafile
>> ./usr/tests/atf/atf-c++/tests_test
>> ./usr/tests/atf/atf-c++/macros_test
>> ./usr/tests/atf/atf-c++/build_test
>> ./usr/tests/atf/atf-c++/check_test
>> ./usr/tests/atf/atf-c++/utils_test
>> ./usr/tests/atf/atf-c++/pkg_config_test
>> ./usr/tests/atf/atf-c++/unused_test.cpp
>> ./usr/tests/atf/atf-c++/detail
>> ./usr/tests/atf/atf-c++/detail/version_helper
>> ./usr/tests/atf/atf-c++/detail/env_test
>> ./usr/tests/atf/atf-c++/detail/Kyuafile
>> ./usr/tests/atf/atf-c++/detail/process_test
>> ./usr/tests/atf/atf-c++/detail/exceptions_test
>> ./usr/tests/atf/atf-c++/detail/fs_test
>> ./usr/tests/atf/atf-c++/detail/application_test
>> ./usr/tests/atf/atf-c++/detail/text_test
>> ./usr/tests/atf/atf-c++/detail/auto_array_test
>> ./usr/tests/atf/test-programs
>> ./usr/tests/atf/test-programs/srcdir_test
>> ./usr/tests/atf/test-programs/Kyuafile
>> ./usr/tests/atf/test-programs/c_helpers
>> ./usr/tests/atf/test-programs/sh_helpers
>> ./usr/tests/atf/test-programs/expect_test
>> ./usr/tests/atf/test-programs/config_test
>> ./usr/tests/atf/test-programs/meta_data_test
>> ./usr/tests/atf/test-programs/cpp_helpers
>> ./usr/tests/atf/test-programs/result_test
>>
>> Are all of these files needed on the target?
>>
>> Thanks,
>>
>> Thomas
> 
> 
>  
>  
> ************************************************************************************
> This footnote confirms that this email message has been scanned by
> PineApp Mail-SeCure for the presence of malicious code, vandals & computer viruses.
> ************************************************************************************
> 
> 
> 
>
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index e0c2e2a..78ed223 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -57,6 +57,7 @@  endif
 endmenu
 
 menu "Debugging, profiling and benchmark"
+	source "package/atf/Config.in"
 	source "package/blktrace/Config.in"
 	source "package/bonnie/Config.in"
 	source "package/cache-calibrator/Config.in"
diff --git a/package/atf/Config.in b/package/atf/Config.in
new file mode 100644
index 0000000..59712ab
--- /dev/null
+++ b/package/atf/Config.in
@@ -0,0 +1,11 @@ 
+config BR2_PACKAGE_ATF
+	bool "atf"
+	depends on BR2_INSTALL_LIBSTDCPP
+	help
+	  ATF, or Automated Testing Framework, is a collection of
+	  libraries to write test programs in C, C++ and POSIX shell.
+
+	  https://github.com/jmmv/atf
+
+comment "atf needs a toolchain w/ C++"
+	depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/atf/atf.hash b/package/atf/atf.hash
new file mode 100644
index 0000000..78cd3c6
--- /dev/null
+++ b/package/atf/atf.hash
@@ -0,0 +1,2 @@ 
+# Locally computed
+sha256 92bc64180135eea8fe84c91c9f894e678767764f6dbc8482021d4dde09857505 atf-0.21.tar.gz
diff --git a/package/atf/atf.mk b/package/atf/atf.mk
new file mode 100644
index 0000000..bf6f156
--- /dev/null
+++ b/package/atf/atf.mk
@@ -0,0 +1,23 @@ 
+################################################################################
+#
+# atf
+#
+################################################################################
+
+ATF_VERSION = 0.21
+ATF_SITE = https://github.com/jmmv/atf/releases/download/atf-$(ATF_VERSION)
+ATF_INSTALL_STAGING = YES
+ATF_LICENSE = BSD-3c
+ATF_LICENSE_FILES = COPYING
+# Ships a beta libtool version hence our patch doesn't apply.
+ATF_AUTORECONF = YES
+
+
+# ATF_SHELL defaults to the host's bash
+ATF_CONF_ENV = \
+	kyua_cv_getopt_plus=yes \
+	kyua_cv_attribute_noreturn=yes \
+	kyua_cv_getcwd_works=yes \
+	ATF_SHELL=/bin/sh
+
+$(eval $(autotools-package))