diff mbox

[v2,1/1] flashrom: Bump to version 0.9.8

Message ID 1431850584-6913-1-git-send-email-florent.valette@gmail.com
State Accepted
Headers show

Commit Message

florent valette May 17, 2015, 8:16 a.m. UTC
This version adds support for new Intel SoC (e.g. BayTrail) and
spi over usb devices such as pickit2 and ftdi usb-spi.

Signed-off-by: Florent Valette <florent.valette@gmail.com>

---
Changes v1 -> v2:
 propagate the dependencies for libusb and libftdi
 Note, libftdi1 is not supported, it only uses libftdi.

Signed-off-by: Florent Valette <florent.valette@gmail.com>
---
 package/flashrom/Config.in   | 5 +++++
 package/flashrom/flashrom.mk | 4 ++--
 2 files changed, 7 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni May 17, 2015, 10:56 a.m. UTC | #1
Dear Florent Valette,

On Sun, 17 May 2015 10:16:24 +0200, Florent Valette wrote:
> This version adds support for new Intel SoC (e.g. BayTrail) and
> spi over usb devices such as pickit2 and ftdi usb-spi.
> 
> Signed-off-by: Florent Valette <florent.valette@gmail.com>

This is the third time you send a "v2" of this patch. Which one is
really the v2 ?

You should increment the version number whenever there is a change made
to the patch. 

If there are no changes, then there is no need to resend the patch.

Thanks!

Thomas
florent valette May 17, 2015, 11:12 a.m. UTC | #2
Hi all, Thomas,

The fist time, i misused "git send-email", my bad, i tried to reply
and send v2 in the same time.
Then, i sent it to buildroot@busybox.net and buildroot@buildroot.org,
there are two emails addresses for the mailing list and this is not
obvious which one is the right one. Some people sends to
buildroot.org, others to busybox.net. As i only received the cc (git
send-email  sends cc to sender by default) to the mail send to
@buildroot.org, i re-send it to @busybox.net (i received twice this
one, the one from mailing list and the cc to myself).

Sorry for the inconvenience.

Florent.

2015-05-17 12:56 GMT+02:00 Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>:
> Dear Florent Valette,
>
> On Sun, 17 May 2015 10:16:24 +0200, Florent Valette wrote:
>> This version adds support for new Intel SoC (e.g. BayTrail) and
>> spi over usb devices such as pickit2 and ftdi usb-spi.
>>
>> Signed-off-by: Florent Valette <florent.valette@gmail.com>
>
> This is the third time you send a "v2" of this patch. Which one is
> really the v2 ?
>
> You should increment the version number whenever there is a change made
> to the patch.
>
> If there are no changes, then there is no need to resend the patch.
>
> Thanks!
>
> Thomas
> --
> Thomas Petazzoni, CTO, Free Electrons
> Embedded Linux, Kernel and Android engineering
> http://free-electrons.com
Thomas Petazzoni May 17, 2015, 1:58 p.m. UTC | #3
Florent,

On Sun, 17 May 2015 13:12:23 +0200, Florent Valette wrote:

> The fist time, i misused "git send-email", my bad, i tried to reply
> and send v2 in the same time.

No problem.

> Then, i sent it to buildroot@busybox.net and buildroot@buildroot.org,
> there are two emails addresses for the mailing list and this is not
> obvious which one is the right one. Some people sends to
> buildroot.org, others to busybox.net. As i only received the cc (git
> send-email  sends cc to sender by default) to the mail send to
> @buildroot.org, i re-send it to @busybox.net (i received twice this
> one, the one from mailing list and the cc to myself).

Yes, I know it's a bit confusing. Just use one or the other, they both
send to the same location.

Best regards,

Thomas
Thomas Petazzoni May 21, 2015, 9:11 p.m. UTC | #4
Dear Florent Valette,

On Sun, 17 May 2015 10:16:24 +0200, Florent Valette wrote:
> This version adds support for new Intel SoC (e.g. BayTrail) and
> spi over usb devices such as pickit2 and ftdi usb-spi.
> 
> Signed-off-by: Florent Valette <florent.valette@gmail.com>
> 
> ---
> Changes v1 -> v2:
>  propagate the dependencies for libusb and libftdi
>  Note, libftdi1 is not supported, it only uses libftdi.

Applied, thanks. I've done a few changes:

    [Thomas:
      - add missing Config.in comment about the thread dependency
      - remove 'Requires PCIUtils libraries' from the Config.in help text,
        since flashrom now requires more than PCIUtils library, and we
        typically don't document such dependencies in Config.in help
        texts.]

Also, I did some followup commits to improve the Config.in help text,
and add a hash file.

Finally, the pciutils, libusb and libftdi dependencies could be made
optional, since they are only needed for some of the flashrom drivers.
However, the mechanism to select each flashrom drivers is a bit
annoying, and I'm not sure it's really worth the effort.

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/flashrom/Config.in b/package/flashrom/Config.in
index 956500f..8bd5882 100644
--- a/package/flashrom/Config.in
+++ b/package/flashrom/Config.in
@@ -1,9 +1,14 @@ 
 config BR2_PACKAGE_FLASHROM
 	bool "flashrom"
 	select BR2_PACKAGE_PCIUTILS
+	select BR2_PACKAGE_LIBUSB
+	select BR2_PACKAGE_LIBUSB_COMPAT
+	select BR2_PACKAGE_LIBFTDI
 	# dmidecode is only a runtime dependency
 	select BR2_PACKAGE_DMIDECODE
 	depends on BR2_i386 || BR2_x86_64
+	depends on BR2_TOOLCHAIN_HAS_THREADS 	# libusb
+	depends on BR2_ARCH_HAS_ATOMICS 	# libftdi
 	help
 	  BIOS-updating utility.
 	  Requires PCIUtils libraries.
diff --git a/package/flashrom/flashrom.mk b/package/flashrom/flashrom.mk
index 70bbe30..525470a 100644
--- a/package/flashrom/flashrom.mk
+++ b/package/flashrom/flashrom.mk
@@ -4,10 +4,10 @@ 
 #
 ################################################################################
 
-FLASHROM_VERSION = 0.9.7
+FLASHROM_VERSION = 0.9.8
 FLASHROM_SOURCE = flashrom-$(FLASHROM_VERSION).tar.bz2
 FLASHROM_SITE = http://download.flashrom.org/releases
-FLASHROM_DEPENDENCIES = pciutils
+FLASHROM_DEPENDENCIES = pciutils libusb libusb-compat libftdi
 FLASHROM_LICENSE = GPLv2+
 FLASHROM_LICENSE_FILES = COPYING