diff mbox

[v5,02/24] sqlite: Add host build support

Message ID 1431553177-7280-3-git-send-email-clayton.shotwell@rockwellcollins.com
State Superseded
Headers show

Commit Message

Clayton Shotwell May 13, 2015, 9:39 p.m. UTC
From: Matt Weber <matthew.weber@rockwellcollins.com>

Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com>

---
Changes v4 -> v5:
  - No changes
---
 package/sqlite/sqlite.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni May 18, 2015, 9:17 p.m. UTC | #1
Dear Clayton Shotwell,

On Wed, 13 May 2015 16:39:15 -0500, Clayton Shotwell wrote:
> From: Matt Weber <matthew.weber@rockwellcollins.com>
> 
> Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
> 
> ---
> Changes v4 -> v5:
>   - No changes
> ---
>  package/sqlite/sqlite.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
> index fff219a..aaf84fc 100644
> --- a/package/sqlite/sqlite.mk
> +++ b/package/sqlite/sqlite.mk
> @@ -50,3 +50,4 @@ SQLITE_CONF_OPTS += --disable-readline
>  endif
>  
>  $(eval $(autotools-package))
> +$(eval $(host-autotools-package))

When adding a host package, it's always good to indicate which other
package will be using it so that it doesn't seem to be a useless change.

Thanks,

Thomas
Clayton Shotwell May 18, 2015, 9:26 p.m. UTC | #2
Thomas,

On Mon, May 18, 2015 at 4:17 PM, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:
> Dear Clayton Shotwell,
>
> On Wed, 13 May 2015 16:39:15 -0500, Clayton Shotwell wrote:
>> From: Matt Weber <matthew.weber@rockwellcollins.com>
>>
>> diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
>> index fff219a..aaf84fc 100644
>> --- a/package/sqlite/sqlite.mk
>> +++ b/package/sqlite/sqlite.mk
>> @@ -50,3 +50,4 @@ SQLITE_CONF_OPTS += --disable-readline
>>  endif
>>
>>  $(eval $(autotools-package))
>> +$(eval $(host-autotools-package))
>
> When adding a host package, it's always good to indicate which other
> package will be using it so that it doesn't seem to be a useless change.

I can add a comment to the commit stating why the host support is being added.

Thanks,
Clayton

Clayton Shotwell
Senior Software Engineer, Rockwell Collins
clayton.shotwell@rockwellcollins.com
Thomas Petazzoni May 18, 2015, 9:33 p.m. UTC | #3
Dear Clayton Shotwell,

On Mon, 18 May 2015 16:26:04 -0500, Clayton Shotwell wrote:

> > When adding a host package, it's always good to indicate which other
> > package will be using it so that it doesn't seem to be a useless change.
> 
> I can add a comment to the commit stating why the host support is being added.

Yes that is all what I'm asking for.

Thomas
diff mbox

Patch

diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
index fff219a..aaf84fc 100644
--- a/package/sqlite/sqlite.mk
+++ b/package/sqlite/sqlite.mk
@@ -50,3 +50,4 @@  SQLITE_CONF_OPTS += --disable-readline
 endif
 
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))